Monospace font broken after upgrade to Jaunty

Asked by Vegard Svanberg

After upgrading from Intrepid to Jaunty, something happened to the Monospace font:

Before (correct):

Now (wrong):

I've chosen (in gnome-terminal or system->preferences->appearance the Dejavu Sans Mono font, but it makes no difference in gnome-terminal. It doesn't seem that the Dejavu font is used, but some other font instead. It seems to work okay if I view a text file in Firefox, though.

Any ideas?

Question information

English Edit question
Ubuntu gnome-terminal Edit question
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #366417.

Revision history for this message
Vegard Svanberg (vegard-svanberg) said :

Found the solution:


Best Shapes is now chosen by default. Change to Subpixel smoothing and everything seems to be as it was before.

Revision history for this message
Thomas Foss (tafoxx) said :

Interesting... turning on subpixel smoothing seems to make the terminal look the way it used to, but everything else looks abnormal now. Is it possible to enable subpixel smoothing only for monospace fonts?

Can you help with this problem?

Provide an answer of your own, or ask Vegard Svanberg for more information if necessary.

To post a message you must log in.