Unable to determine XFree86 Version

Asked by ragingmon on 2007-05-16

I run the check.sh file that I downloaded from this link >> http://ati.amd.com/support/drivers/linux/linux-radeon-prer200.html
And this is the output...

ragingmon@ubuntu:~/Desktop$ sh ./check.sh
-e =====================================================================
-e ATI Technologies
-e =====================================================================
You are either not running this script from the console
or simply do not have console ownership. Requirement failed.
Unable to determine XFree86 Version. Stopping now.

I don't know if I have XFree86 version rigth now..
pls help pls help..

I googled everthing, but still found nothing...
I'm really a noob in linux and I need help.. T_T

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
ragingmon
Solved:
Last query:
Last reply:
Massimo Forti (slackwarelife) said : #1

Thanks for your question. If you are using the 7.04
ubuntu/kubuntu version you are using the 7.2 xorg version.
The ati driver you have linked not support this version of
xorg. You must use the Ubuntu restrict driver manager to
install the ATI driver. Let me know thanks.

----- Segue Messaggio Originale -----
Da : ragingmon <email address hidden>
A : <email address hidden>
oggetto : [Question #6684]: Unable to determine XFree86
Version
Data : Wed, 16 May 2007 09:54:54 -0000

> New question #6684 on gnome-terminal in ubuntu:
>
https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/6684
>
> I run the check.sh file that I downloaded from this link
> >>
>
http://ati.amd.com/support/drivers/linux/linux-radeon-prer200.html
> And this is the output...
>
> ragingmon@ubuntu:~/Desktop$ sh ./check.sh
> -e
> ==========================================================
> ==========-e ATI Technologies -e
> ==========================================================
> ==========You are either not running this script from the
> console or simply do not have console ownership.
> Requirement failed. Unable to determine XFree86 Version.
> Stopping now.
>
>
> I don't know if I have XFree86 version rigth now..
> pls help pls help..
>
> I googled everthing, but still found nothing...
> I'm really a noob in linux and I need help.. T_T

Cesare Tirabassi (norsetto) said : #2

check.sh is a bash script.
To execute it you have to run it using "bash ./check.sh" or change it to executable with chmod +x check.sh and then simply run it with ./check.sh

ragingmon (ragingmon) said : #3

I followed this link >> https://help.ubuntu.com/community/BinaryDriverHowto/ATI

and in this part >> Open the restricted drivers manager included in 7.04 "System -> Administration -> Restricted Drivers Manager" and select "ATI accelerated graphics driver". This will hopefully enable fglrx in a painless way. If not, follow the instructions for Edgy. <<

A window pops up and says this >> Your hardware does not need any restricted drivers.

Im very sorry for beeing so noobish...
And I'm rally glad that people like you helps me..
tnx so much.. its really appreciated..

Cesare Tirabassi (norsetto) said : #4

Hey, no problem. We all were noobs once, some of us still are (I know I'm). Have fun, thats what it counts :)

Best ragingmon (ragingmon) said : #5

ok I've already fixed this problem..
Its been a week that I've been struggling with this problem. (what a noob T_T)

I've uninstalled feisty fawn and installed edgy eft just to have xorg 7.1 that is compatible with my ATI Radeon 9250 PRO. I didn't know how to downgrade xorg in feisty fawn at that time, and I think it's better to choose edgy eft.

I just followed this link >> http://doc.gwos.org/index.php/ATI_AMD_fglrx_Edgy
and changed the installer that is only compatible with my driver >> http://ati.amd.com/support/drivers/l...n-prer200.html

Right now I got 3d acceleration using the fglrx driver.
I tried blender and its much more faster here in ubuntu than in windows..

tnx to all the people who helped me.. tnx a lot!!
special tnx to >> http://neuralbrew.blogspot.com/
weeeeeee!