error: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)

Asked by aneesh on 2009-02-22

When I try to remove vlc player from my system by typing "apt-get remove vlc vlc-plugin-esd mozilla-plugin-vlc" , there is two error message appear " Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable) and "Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? " what is its meaning ? While Iam trying this no other window like "synaptic package manager" was not opened

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Last query:
2009-02-22
Last reply:
2009-02-28
Andrew (and471) said : #1

Have you tried

sudo apt-get remove vlc vlc-plugin-esd mozilla-plugin-vlc

You must be sure no other package manager is active... (startup and on regular basis Ubuntu check for updates and upgrades then it try to download , install them) please check modify the settings under menu
System → Administration → Software Sources: [ Updates ] tab → "Automatic updates"

If you are unsure what to do please simply reboot the pc...

Then retry...

Hope this helps

Hernan Praddaude (hercampradd) said : #3

I'm trying to download an Nvidia pkg. but I get the error: 'lock /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)' and 'Unable to lock the download directory' What should I do? Thank you.

@ Herman simply wait and

please don't append a new question on a already answered or marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered questions are usually not read from answering people.

Thank you

Can you help with this problem?

Provide an answer of your own, or ask aneesh for more information if necessary.

To post a message you must log in.