install real player

Asked by janis508 on 2007-02-06

 have downloaded real player for linux, but have problems downloading it ,do not know how to work correctly whith terminal!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
tokj
Solved:
Last query:
Last reply:

This question was reopened

The following page details how to install Real Player:-

https://help.ubuntu.com/community/RealplayerInstallationMethods

janis508 (ajanis40) said : #2

still cannot install the Real Player. Am folwing those instructions but the answer is permision denied.

At what point? When do you get that message?

janis508 (ajanis40) said : #4

ubuntu@ubuntu:~$ '/home/ubuntu/Desktop/RealPlayer10GOLD.bin' $ sudo
./RealPlayer10GOLD.bin
bash: /home/ubuntu/Desktop/RealPlayer10GOLD.bin: Permission denied
ubuntu@ubuntu:~$
Also when I wanted to install it whith .deb file
ubuntu@ubuntu:~$ sudo dpkg -i realplayer_10.0.7-0.0_i386.deb
dpkg: error processing realplayer_10.0.7-0.0_i386.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 realplayer_10.0.7-0.0_i386.deb
I have not installed Ubuntu on my computer still but I am booting it
from my DVD.
Also when I ubuntu@ubuntu:~$
'/home/ubuntu/Desktop/RealPlayer10GOLD.bin' $ chmod a+x
realPlayer10GOLD.bin
bash: /home/ubuntu/Desktop/RealPlayer10GOLD.bin: Permission denied
ubuntu@ubuntu:~$
What Could be the problem??
  Quoting Alan Pope : Your support request #3534 on gnome-terminal in
ubuntu changed:

https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+ticket/3534
 Status: Open => Needs information
 Alan Pope requested for more information:
 At what point? When do you get that message?

_______________________________________________________________________
 To answer this request for more information, you can either reply to
 this email or enter your reply at the following page:

https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+ticket/3534

Links:
------
[1] mailto:<email address hidden>

Advertisement:

Β• Inbox.lv Β– bezmaksas 2.5 GB (2500 MB) liela pastkastiite
Β• Anti-Virus un Anti-Spam aizsardziiba
Β• WWW.INBOX.LV

You do realise that if you install realplayer and then reboot, you will lose it? This is due to you running off the live DVD/CD.

If you still want to install it, you need follow the instructions very carefully. In the instructions where you see a "$" sign, you do not type that sign, it is telling you that your prompt on the screen should have a dollar sign. For example it looks like you typed

ubuntu@ubuntu:~$ '/home/ubuntu/Desktop/RealPlayer10GOLD.bin' $ sudo ./RealPlayer10GOLD.bin

Where you should have:-

ubuntu@ubuntu:~$ sudo ./RealPlayer10GOLD.bin

Which wont work, because the file is not executable, so you need to do what it says which is:-

ubuntu@ubuntu:~$ chmod a+x ./RealPlayer10GOLD.bin

Note you typed

ubuntu@ubuntu:~$
'/home/ubuntu/Desktop/RealPlayer10GOLD.bin' $ chmod a+x
realPlayer10GOLD.bin

Note that the file RealPlayer10GOLD.bin has a capital R.

janis508 (ajanis40) said : #6

 I was traying to do this.
ubuntu@ubuntu:~$ chmod a+x RealPlayer10GOLD.bin
chmod: cannot access `RealPlayer10GOLD.bin': No such file or
directory
ubuntu@ubuntu:~$ chmod a+x ./RealPlayer10GOLD.bin
chmod: cannot access `./RealPlayer10GOLD.bin': No such file or
directory
ubuntu@ubuntu:~$
Also
ubuntu@ubuntu:~$ chmod a+x RealPlayer10GOLD.bin
chmod: cannot access `RealPlayer10GOLD.bin': No such file or
directory
ubuntu@ubuntu:~$
What is the problem here?
  Quoting Alan Pope : Your support request #3534 on gnome-terminal in
ubuntu changed:

https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+ticket/3534
 Status: Open => Answered
 Alan Pope proposed the following answer:
 You do realise that if you install realplayer and then reboot, you
will
 lose it? This is due to you running off the live DVD/CD.
 If you still want to install it, you need follow the instructions
very
 carefully. In the instructions where you see a "$" sign, you do not
type
 that sign, it is telling you that your prompt on the screen should
have
 a dollar sign. For example it looks like you typed
 ubuntu@ubuntu:~$ '/home/ubuntu/Desktop/RealPlayer10GOLD.bin' $ sudo
 ./RealPlayer10GOLD.bin
 Where you should have:-
 ubuntu@ubuntu:~$ sudo ./RealPlayer10GOLD.bin
 Which wont work, because the file is not executable, so you need to
do
 what it says which is:-
 ubuntu@ubuntu:~$ chmod a+x ./RealPlayer10GOLD.bin
 Note you typed
 ubuntu@ubuntu:~$
 '/home/ubuntu/Desktop/RealPlayer10GOLD.bin' $ chmod a+x
 realPlayer10GOLD.bin
 Note that the file RealPlayer10GOLD.bin has a capital R.

_______________________________________________________________________
 If this answers your request, please go to the following page to let
us
 know that it is solved:

https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+ticket/3534/+confirm?answer_id=4
 If you still need support, you can reply to this email or go to the
 following page to enter your feedback:

https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+ticket/3534

Links:
------
[1] mailto:<email address hidden>

Advertisement:

Β• Inbox.lv Β– bezmaksas 2.5 GB (2500 MB) liela pastkastiite
Β• Anti-Virus un Anti-Spam aizsardziiba
Β• WWW.INBOX.LV

The file is in your ~/Desktop directory, so you need to go there first, like this:-

cd ~/Desktop
chmod a+x ./RealPlayer10GOLD.bin
sudo sh ./RealPlayer10GOLD.bin

janis508 (ajanis40) said : #8

 I followed your advice and first went to cd ~/Desktop and then wrote all the rest and I installed the realPlayer. Thank You!!!

janis508 (ajanis40) said : #9

 I installed the Ubuntu on my hard disk and now I wanted to install RealPlayer, but having the same problems installing
janka@janka-desktop:~$ chmod a+x RealPlayer10GOLD.bin
chmod: cannot access `RealPlayer10GOLD.bin': No such file or directory
And ... janka@janka-desktop:~$ sudo ./RealPlayer10GOLD.bin
Password:
sudo: ./RealPlayer10GOLD.bin: command not found
Also ... janka@janka-desktop:~$ ~/Desktop
bash: /home/janka/Desktop: is a directory
janka@janka-desktop:~$ chmod a+x RealPlayer10GOLD.bin
chmod: cannot access `RealPlayer10GOLD.bin': No such file or directory
 How to solve this problem?

Recently RealPlayer has been added also in edgy-commercial repositories:

http://archive.canonical.com/dists/edgy-commercial/main/binary-i386/Packages.gz

so you can install it simply by adding the Canonical commercial repos in your sources.list and then install RealPlayer with apt.

I think that the guide should be updated.

Hi

janis508 (ajanis40) said : #11

 thank you for advice , I installed RealPlayer from repo, but when I need to use it, to listen some programs from internet, I cannot find that player in my sistem,where it is hidden, cannot find it in system files and so on,
How to make realplayer play those files on an internet page that he is seposed to play and not some other player?

If you're using Firefox copy files nphelix.so and nphelix.xpi from the directory
/RealPlayer/plugins to /usr/lib/firefox/plugins.

Otherwise, yuo have to follow this procedure:

1) Open a new tab and type about:config in the address bar
2) Right click somewhere in the new tab and select New --> String
3) In the new window that will appear type: network.protocol-handler.app.rtsp
4) As value, insert the path of the realplayer esecutable file (it should be /usr/local/RealPlayer/realplay)
5) Close the tab and restart Firefox

janis508 (ajanis40) said : #13

 I followed your advice, whith new tab and so on, but those places where it ,needs to open whith realplayer he is not opening..
Coul you help me how to copy those files ? What else could be the problem?

Everything i should tell you is well described here:

https://help.ubuntu.com/community/RealplayerInstallationMethods#head-02313c026706d5aca8b8b8f2a8a93e02727a1697

I hope that this will solve your troubles.

janis508 (ajanis40) said : #15

 I tryed to do what is written on that page, but something is not working
janka@janka-desktop:~$ /usr/lib/firefox/plugins
bash: /usr/lib/firefox/plugins: is a directory
also janka@janka-desktop:~$ /usr/local/RealPlayer/realplay
bash: /usr/local/RealPlayer/realplay: No such file or directory
janka@janka-desktop:~$
also in Edit > Preferences > Content > File Types > Manage.. there is only
spl file . what here is the problem?

You typed the wrong things in terminal:

If you want enter in the directory /usr/lib/firefox/plugins you have to launch the following command:

cd /usr/lib/firefox/plugins

The esecutable file should be located in /usr/bin/ (in my case is located there) so the complete path is /usr/bin/realplay

Anyway it shuld be enough that you do what is described in the chapter "handling plugins".

janis508 (ajanis40) said : #17

User confirmed that the request is solved.