ubuntu screen resolution preferences

Asked by oahmad on 2006-01-22

I am a new convert to ubuntu/linux. I have successfully installed ubuntu in a partition. I also haver windows XP Professional in another partition. So far so good. Unfortunately, the screen resolution allows me just 640x480 60Hz. Could anyone tell me how to get higher resolutions? Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
Jeremiah C. Foster
Solved:
Last query:
Last reply:

I have gone through this recently and can offer some advice. First, go to System -> Preferences -> Screen Resolution. There you should be able to select the resolution you prefer for your screen. If there are no higher resolutions available, then there could possibly have been an X11 misconfiguration when you first installed the Ubuntu system.

If you open an editor in the terminal you can edit your /etc/X11/xorg.conf file and insert the desired resolution. Try it through the graphical interface first since that will feel more familiar. If you still have a problem post your error messages here.

regards,

Jeremiah

oahmad (oahmad) said : #2

Thanks Jeremiah. I have tried using the terminal command:
sudo gedit /etc/X11/xorg.conf.
All I get is a blank screen with no text.
Am I mssing something?

Regards,

Omar

oahmad (oahmad) said : #3

Issue has been resolved. Thank you

ZepOz (claritas) said : #4

On this subject, I noted the following during install:

During Ubuntu 10.5 install, the allowed resolutions for my older video card were "ticked" up to 1024x768 (indicating supported), my preferred operating resolution. The card is rated as being capable of this resolution, but possibly at a lower colour-depth.

However on completion of the install, the maximum available resolution provided was only 800x600, which is quite bit clumsy to work in.

I get the impression that the resolution selection process selects those options with maximum colour bit-depth only, regardless of the bigger screen real estate offered by slightly lower bit-depths. Comments?

Quentin (qpackard) said : #5

I am heartened that the user's problem is resolved and he is enjoying his image, and I, too, would like to insert the correct resolution in the xorg.conf file. Could anyone share how this was done, such as how and where with some instructions? I found many resolutions listed in my xorg.conf file several times but nothing seemed apparent, such as, "set resolution here: xxxx" and "set refresh rate here: xxx".

I am using ubuntu 5.10 and my monitor is a Samsung SyncMaster 730B. Ubuntu's System>Preferences lists only 640x480, but my monitor is capable of seven modes, up to 1280x1024. I think my graphics card has this information: NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU].
TIA.

the_anomoly (bradstone888) said : #6

Quentin, here's how I got it to work.

 In xorg.conf, as you said, there are resolutions listed a few times. Mine had six subsections, with different depths but the same modes. I added my desired depth to the list of sizes in <i>all</i> of the subsections and then rebooted.
After reboot I went to System->Preferences->Screen Resolution and was able to select the new size that I had entered.

the_anomoly (bradstone888) said : #7

Correction on last comment:

"I added my desired depth to the list of sizes"
should be
"I added my desired size to the list of modes"

coldfire1784 (coldfire1784) said : #8

Hey, I have been having some of the same problems as listed above. However, when I go in to xorg.conf all the screeen resolution settings that it says are 1024x768 and yet when I go to Screen > Preferences > Screen Resolution the only option it gives me is 640x480. If anyone has any suggestions, I would be glad for them.

Thanks

indijay (pp77subs) said : #9

So here is another newbie who is on his way from m$ to Linux. I downloaded 6.10 Ubuntu and tried to install but the same issue troubles me as well.

When I try to install, I see only half of the screen so I dont see the buttons at the bottom (in live CD, which later offers me an option to install OS).

So how do I fix this so that I can install Ubuntu without much hassle? (I couldnt figure out how to launch the terminal)

indijay (pp77subs) said : #10

Update=

So now I found the terminal and tried to locate the file but I dont know the navigation so I just copy and pasted the above path given by jeremiah and it says permission denied !!

Then I tried the command given by oahmad and it opened that file for edit that I have pasted below. Can anyone tell me where do I make changes here?

****************
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/X11/fonts/misc"
 FontPath "/usr/share/X11/fonts/cyrillic"
 FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/Type1"
 FontPath "/usr/share/X11/fonts/100dpi"
 FontPath "/usr/share/X11/fonts/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc104"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "stylus"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "stylus"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "eraser"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "eraser"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "cursor"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "cursor"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "ATI Technologies, Inc. Radeon Xpress 200 (RS480)"
 Driver "ati"
 BusID "PCI:1:5:0"
EndSection

Section "Monitor"
 Identifier "C791"
 Option "DPMS"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies, Inc. Radeon Xpress 200 (RS480)"
 Monitor "C791"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
 InputDevice "stylus" "SendCoreEvents"
 InputDevice "cursor" "SendCoreEvents"
 InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
 Mode 0666
EndSection
***************

Paul Purvis (elvino) said : #11

May I add a request?

I run my Ubuntu on a box with no monitor, keyboard or mouse and do it all via VNC. It works fine, but try as I might I cannot get the resolution to lock at 800x600, which would be my preferred resolution.
I have followed the suggested steps to edit the conf file, and it LOOKS like it should work, but as soon as I disconnect the monitor and reboot, I am back to 640x480
Any suggestions appreciated!

St.Anger (eliofucile) said : #12

Hi,

If anyone can tell me what to change as well i'm having the same issue.

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/X11/fonts/misc"
 FontPath "/usr/share/X11/fonts/cyrillic"
 FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/Type1"
 FontPath "/usr/share/X11/fonts/100dpi"
 FontPath "/usr/share/X11/fonts/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc104"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "stylus"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "stylus"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "eraser"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "eraser"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "cursor"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "cursor"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "ATI Technologies, Inc. 3D Rage I/II 215GT [Mach64 GT]"
 Driver "ati"
 BusID "PCI:0:15:0"
EndSection

Section "Monitor"
 Identifier "DELL D1025TM"
 Option "DPMS"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "ATI Technologies, Inc. 3D Rage I/II 215GT [Mach64 GT]"
 Monitor "DELL D1025TM"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1024x768" "800x600" "720x400" "720x350" "1024x768"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1024x768" "800x600" "720x400" "720x350" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1024x768" "800x600" "720x400" "720x350" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1024x768" "800x600" "720x400" "720x350" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1024x768" "800x600" "720x400" "720x350" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1024x768" "800x600" "720x400" "720x350" "640x480"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
 InputDevice "stylus" "SendCoreEvents"
 InputDevice "cursor" "SendCoreEvents"
 InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
 Mode 0666
EndSection

mooser (kim-moose) said : #13

There seems to be quite a few questions that haven't been answered in this thread - at least not in anyway that has been helpful to me. Could perhaps one of the great gurus of the side point out the error of my thinking and set me down the right path. The requirements are:
- Use Ubuntu remotely via VNC (or similar)
- No keyboard, mouse or most importantly, monitor are connected.
- Set screen resolution above 640 x 480.

From what i've seen of my xorg.conf it contains multiple resolutions for the monitor that was original attached when the system was built.

Any help would be most appreciated.

Thanks!

fongcha (fongcha) said : #14

Launch a Terminal window by going Applications > Terminal
Type this at the command prompt:

sudo gedit /etc/X11/xorg.conf
Find the text:

Section "Monitor"
Create the entries for "HorizSync" and "VertRefresh" each on a separate line with the values corresponding to your monitor.
For example, I have a generic 17 inch monitor at 1024x768 and my section looks like this:

Section "Monitor"
  Identifier "HWP" # this is my monitor name
  Option "DPMS" # default options, leave these alone
  HorizSync 28-60 # horizontal refresh frequencies
  VertRefresh 43-60 # vertical refresh frequencies
EndSection
Reboot your computer and your resolution should be all set

wb0gaz (wb0gaz) said : #15

I am having trouble with firefox 2 crashing on some websites under Ubuntu 6.10, and I understand the work-around is to set color depth to 24 bits vs. 16 bits. There is nothing in Ubuntu's system administration menus to control color depth (only resolution and refresh rate.)

The problem is this - earlier when I changed my monitor, the new monitor's screen resolution wasn't available, so I "fixed" this by changing the name of /etc/X11/xorg.conf (in lieu of just erasing it), figuring xorg might build a new one at the next restart, picking up the new display resolution. The new (correct) resolutions became available on the next restart, but now I discover to change to 24 bit color depth, an edit of /etc/X11/xorg.conf is required, but this file is not present at all (somehow xorg is not saving the new xorg.conf.)

Is there a way to tell xorg to regenerate xorg.conf and save it, so that I can then edit it and fix the color depth? I did not want to restore the original xorg.conf because it did not have the correct screen resolution available.

Very tks,

Dave

Oran (ocf1) said : #16

Hi all,

This is regarding the problem experienced by those users with no monitor attached to their machine running ubuntu, and who use ubuntu via a vnc client.

I had the same problem - the screen res was fixed at 640x480 making it impossible to use ubuntu in a lot of cases (like when the OK button was off the bottom of the screen for example). But I managed to fix the problem.

Steps I took:
 - Opened /etc/X11/xorg.conf
 - Went to the "Screen" section
 - From each "Display" subsection, removed this: "720x400" "640x480"

From what I could gather from the comments in the xorg.conf file, rebooting the computer now wouldn't have been enough to fix the problem. These are the comments I read:

# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg

So the nexts steps I took were:

 - Run the commands from the comments
       cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
       sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
       sudo dpkg-reconfigure xserver-xorg

*NOTE: judging by the xorg.conf outputs posted in other messages in this thread, the exact commands you need to run in this step can vary. Please read your own xorg.conf file, and find the correct commands to run there (near the top of the file).

 - During the last step, a number of dialogs pop up with questions for the user. For most of these dialogs, I left the fields the same as they were and just hit 'yes' or 'ok' (I assumed the values were based on my xorg.conf file anyway), but for one dialog where I was asked about allowable screen resolutions, I deselected 640x480, and left only 800x600 and 1024x756 selected as my allowable screen resolutions.

 - After the setup utility exited, I rebooted the machine and vnc'ed in in the usual way and it was in 800x600 mode like I had hoped.

Hope this helps.
Oran Fry of OCF Web Design
http://www.ocf.co.nz/

kenlyle (kenlyle) said : #17

fongcha 2006-12-01 18:12:47 UTC - Worked for me on Edubuntu - Dapper.

lazyfirecloud (madbox3456) said : #18

Man there's a lot of useless information in forums about this problem =)
Here's everything you need:
https://help.ubuntu.com/community/DebuggingXAutoconfiguration

Issa (farhang-moaser) said : #19

Alright,
I have set my HorizSync and VertRefr, I have added my resolution (1440 by 900), but I still cannot see the option for 1440x900 under System-->Preferences-->Screen Resolution.

Is there anything else i must do?

Mistofelees (ptmusta) said : #20

I have gone through FAQ:s and web-pages.

I have not found a tool to set the screen resolution.

Could it be possible that there is no such tool ?!

Year after year we are told to TRY this and that by editing this xorg.conf by hand. Is this some kind of joke ?

In ubuntu 8.04 it seems that the highest resolution is 800x600 even though every monitor nowadays has at least 1024x768.

Please wake up. Stop making more and more colorful themes and make something useful. Make a program to set the resolution.

If M$ can do it, it should be possible for somebody else too.