how to resolve generated breaks caused by held packages

Asked by Grace Salazar on 2014-11-04

Calculating upgrade... Failed
The following packages have unmet dependencies:
  base-files: Breaks: initscripts (< 2.88dsf-13.3) but 2.87dsf-4ubuntu17.5 is to be installed
  gnome-utils: Depends: libbonobo2-0 (>= 2.15.0) but it is not going to be installed
               Depends: libbonoboui2-0 (>= 2.15.1) but it is not going to be installed
               Depends: libcanberra-gtk0 (>= 0.4) but it is not going to be installed
               Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
               Depends: libgconf2-4 (>= 2.27.0) but it is not going to be installed
               Depends: libgdict-1.0-6 (>= 2.23.90) but it is not going to be installed
               Depends: libgnome2-0 (>= 2.17.3) but it is not going to be installed
               Depends: libgnomecanvas2-0 (>= 2.11.1) but it is not going to be installed
               Depends: libgtk2.0-0 (>= 2.18.0) but it is not going to be installed
               Depends: libice6 (>= 1:1.0.0) but it is not going to be installed
               Depends: liblaunchpad-integration1 (>= 0.1.17) but it is not going to be installed
               Depends: libpanel-applet2-0 (>= 2.26.0) but it is not going to be installed
               Depends: libpango1.0-0 (>= 1.14.0) but it is not going to be installed
               Depends: libsm6 but it is not going to be installed
               Depends: gconf2 (>= 2.10.1-2) but it is not going to be installed
               Recommends: gksu but it is not going to be installed
  initscripts: Depends: sysv-rc but it is not going to be installed or
                        file-rc but it is not installable
               Depends: upstart but it is not going to be installed
               Recommends: e2fsprogs but it is not going to be installed
  libcairo2: Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
  libgdict-common: Breaks: gnome-utils (< 3.2.1-0ubuntu6) but 2.30.0-0ubuntu1.1 is to be installed
  libkrb5-3: Breaks: libsmbclient (<= 2:3.6.1-2) but 2:3.4.7~dfsg-1ubuntu3.10 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
lucy@lucy-laptop:~$ ubuntu-support-status
Traceback (most recent call last):
  File "/usr/bin/ubuntu-support-status", line 105, in <module>
    (still_supported, support_str) = get_maintenance_status(cache, pkg.name, support_tag)
  File "/usr/bin/ubuntu-support-status", line 37, in get_maintenance_status
    raise Exception("No date tag found")
Exception: No date tag found
lucy@lucy-laptop:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
  base-files: Breaks: initscripts (< 2.88dsf-13.3) but 2.87dsf-4ubuntu17.5 is to be installed
  gnome-utils: Depends: libbonobo2-0 (>= 2.15.0) but it is not going to be installed
               Depends: libbonoboui2-0 (>= 2.15.1) but it is not going to be installed
               Depends: libcanberra-gtk0 (>= 0.4) but it is not going to be installed
               Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
               Depends: libgconf2-4 (>= 2.27.0) but it is not going to be installed
               Depends: libgdict-1.0-6 (>= 2.23.90) but it is not going to be installed
               Depends: libgnome2-0 (>= 2.17.3) but it is not going to be installed
               Depends: libgnomecanvas2-0 (>= 2.11.1) but it is not going to be installed
               Depends: libgtk2.0-0 (>= 2.18.0) but it is not going to be installed
               Depends: libice6 (>= 1:1.0.0) but it is not going to be installed
               Depends: liblaunchpad-integration1 (>= 0.1.17) but it is not going to be installed
               Depends: libpanel-applet2-0 (>= 2.26.0) but it is not going to be installed
               Depends: libpango1.0-0 (>= 1.14.0) but it is not going to be installed
               Depends: libsm6 but it is not going to be installed
               Depends: gconf2 (>= 2.10.1-2) but it is not going to be installed
               Recommends: gksu but it is not going to be installed
  initscripts: Depends: sysv-rc but it is not going to be installed or
                        file-rc but it is not installable
               Depends: upstart but it is not going to be installed
               Recommends: e2fsprogs but it is not going to be installed
  libcairo2: Depends: libfontconfig1 (>= 2.8.0) but it is not going to be installed
  libgdict-common: Breaks: gnome-utils (< 3.2.1-0ubuntu6) but 2.30.0-0ubuntu1.1 is to be installed
  libkrb5-3: Breaks: libsmbclient (<= 2:3.6.1-2) but 2:3.4.7~dfsg-1ubuntu3.10 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Last query:
2014-11-04
Last reply:
2014-11-05

I suggest you report a bug. If you have PPAs added to your system then this may be the cause.

Manfred Hampl (m-hampl) said : #2

Please provide the output of the terminal commands

uname -a
lsb_release -a
sudo dpkg --audit
apt-cache policy base-files initscripts

Can you help with this problem?

Provide an answer of your own, or ask Grace Salazar for more information if necessary.

To post a message you must log in.