Tab key for bash not working !!!

Asked by fredsmite on 2013-11-07

With this terminal emulator the tab key in bash ( for character matching ) is ignored.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Last query:
2013-11-07
Last reply:
2013-11-08

What is the output of:

lsb_release -a; uname -a

Thanks

Also, have you made any changes to $HOME/.bashrc at all?

Thanks

fredsmite (gwbdopesmoker) said : #2

jpd@jpd-servergy-01:~/servergy/engineering$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise
jpd@jpd-servergy-01:~/servergy/engineering$ lsb_release -a ; uname -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise
Linux jpd-servergy-01 3.8.0-32-generic #47~precise1-Ubuntu SMP Wed Oct 2 16:28 UTC 2013 i686 i686 i386 GNU/Linux

No changes no bashrc. It only occurs with xfce desktop which now leads me to think it is the desktop .

The running desktop has no bearing on Bash. You could boot to single user mode and it would be the same.

Run:

sudo mv ~/.bashrc ~/.bashrc-old; cp /root/.bashrc ~/.bashrc && sudo chown $USER:$USER; gedit ~/.bashrc

At the bottom you will see 3 hashed out lines these are the auto complete lines and are disabled for root. Delete the hash character at the start of the three lines. Save the new file and close gedit.

You can now run:

source ~/.bashrc

And test TAB completion.

Sorry prefix the cp command with sudo

Can you help with this problem?

Provide an answer of your own, or ask fredsmite for more information if necessary.

To post a message you must log in.