Finding installation date of any software package in Ubuntu Linux

Asked by Julianloui on 2013-10-07

How do I find the installation date of any software package in Ubuntu Linux? I am trying to verify whether I've succeeded in installing the current version of eSpeak. Going by the version number does not always give me full confidence. Thanks.

Julianloui

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
David Pires
Solved:
2013-10-10
Last query:
2013-10-10
Last reply:
2013-10-10

grep -i espeak /var/log/dpkg.log

May show it

Julianloui (julianloui) said : #2

Hi, Andrew,

When I try your suggestion on one of my two Ubuntu 12.04 computers, Linux returns "Permission denied" . Even i I precede your command with sudo, I still get the same response.

When applied to my second Ubuntu 12.04 machine, your suggestion results in no output. eSpeak appears to work on both computers.

Thank you very much for your prompt help.

Julianloui

Best David Pires (slickymaster) said : #3

Hi

I think this is what you're looking for. This one liner I wrote will output you its existence and date of installation:
zcat -f /var/log/dpkg* | grep "\ install\ " | grep espeak

Here's the output in my VM:
slickymaster@VirtualBox:~$ zcat -f /var/log/dpkg* | grep "\ install\ " | grep espeak
2013-03-11 23:24:40 install espeak-data:i386 <none> 1.46.02-2ubuntu1
2013-03-11 23:24:40 install libespeak1:i386 <none> 1.46.02-2ubuntu1
2013-03-11 23:25:00 install espeak:i386 <none> 1.46.02-2ubuntu1

Julianloui (julianloui) said : #4

Hi, David,

Thank you very much for a nifty solution. I've just tried it and got the following long-sought output.

Julianloui

2013-10-07 14:45:20 install python-espeak <none> 0.4-0ubuntu1
2013-10-07 14:45:25 install espeak-gui <none> 0.4-2
2012-04-23 11:36:43 install espeak-data <none> 1.46.02-0ubuntu1
2012-04-23 11:36:44 install libespeak1 <none> 1.46.02-0ubuntu1
2012-04-23 11:37:18 install espeak <none> 1.46.02-0ubuntu1

Julianloui (julianloui) said : #5

Thanks David Pires, that solved my question.