I need help working basic command line stuff. Totally new

Asked by Matt S on 2008-02-01

I don't know how to even install a new program. I looked up that I need to run in the terminal ./install the flash player or something like that. But I can't even get to the directory because seriously I type cd /thefilename and it says there is no such file name. But I previously I typed ls and it shows that that file is there in that directory. It just won't work. I'm getting a little frustrated. Please hellp

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
Matt S
Solved:
2008-02-01
Last query:
2008-02-01
Last reply:
2008-02-01
Matt S (mattsisco) said : #1

matt@Sisco:~/Desktop$ ls
install_flash_player_9_linux
matt@Sisco:~/Desktop$ cd /install_flash_player_9_linux
bash: cd: /install_flash_player_9_linux: No such file or directory

Bhavani Shankar (bhavi) said : #2

Hello matt..
Presuming you are using ubuntu 7.10,
Due to a bug#173890 it is not possible to install the flash player from synaptic package manager. A new package can be obtained from :

http://launchpadlibrarian.net/10761023/flashplugin-nonfree_9.0.115.0ubuntu2_i386.deb

(click on this link and select save to disk or a similar option, when the file downloads double click the file and flash player installs itself.. (since its a .deb file))

Hope it helps

Bhavani Shankar.

"matt@Sisco:~/Desktop$ cd /install_flash_player_9_linux
bash: cd: /install_flash_player_9_linux: No such file or directory"

There is no such file or directory because you were searching in the root directory( / ) and the ls command print the list of the file in your home directory( ~ ).

if you type cd install_flash_player_9_linux

or

cd ./install_flash_player_9_linux

you can enter in the directory.

/ means root directory if you put at the beginning of the path.( like: cd /usr/local )
. means current directory(home in your case)

For a simple how-to see the link below
https://help.ubuntu.com/community/UsingTheTerminal?action=show&redirect=BasicCommands

sorry, i was wrong, you were in your Desktop and so the ls command printed the file in your Desktop

Matt S (mattsisco) said : #5

Thanks for the help. Guys. There might be more than one way to do it I suppose. The way that worked for me is that I typed it in the long way. cd ~/Desktop/install_flash_player_9_linux and that brought me to the directory. But I will try the cd./filename next time to see if that works. Thanks a bunch.

Matt S (mattsisco) said : #6

I didn't get a chance to test the automatic flash-plugin-nonfree
because I figured out how to install it from the terminal in a tar(?)
file or is it taz I forget, I'm pretty new. But thanks for the help.