no location or prompt in terminal

Asked by Bruce Ferguson

Running Ubuntu 12.04.2LTS, but I wanted a less "busy" desktop, so after trying Gnome Classic, went to Xubuntu. Now when I open a terminal, I get a blank screen. No computer name, no location, no prompt. Also, when I attempt to convert music from wav to mp3 using winff, the gui opens a termnal window, but no conversion happens. I went ahead and installed Guake, just so I could work through CL, but what in blue blazes did I break by changing desktops? btw, I do not find the hidden file ~/.bash(somethingsomething) that other searches have led me to look for. Is this significant?

Question information

English Edit question
Ubuntu gnome-terminal Edit question
No assignee Edit question
Solved by:
Stuart Hine
Last query:
Last reply:
Revision history for this message
Warren Hill (warren-hill) said :

Was this a fresh install of Xubuntu, or if not how did you install it.

You should see a command prompt in the terminal.

Can you also give us the output of:

lsb_release -a; uname -a; echo $DESKTOP_SESSION

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Also, what is the output of:

echo $PS1


Revision history for this message
Bruce Ferguson (pstrbrc1) said :

Not a fresh install. Started with a dual-boot setup on a new laptop that has W-XP. Am running Ubuntu 12.04.2 (with Unity desktop) at work, and the retiring laptop was running 12.04 with a Gnome Classic desktop. Started with Unity, went to Gnome Classic, but couldn't get a stable jumbo mouse pointer (my vision isn't what it should be) so, having found Xubuntu big pointer, went to Xubuntu. (Ran it before on a previous laptop, with 10.04) All this desktop environment progression has been since Jan 1, 2013. Went to Xubuntu at the first of summer, noticed the blank terminal screen a couple of weeks ago. (I admit, I don't do much command line work, but often enough to be certain it worked at first with the Xubuntu environ.)

re: the output of <echo $PS1>
"bruce@bruce-2:~$ echo $PS1
\[\e]0;\u@\h: \w\a\]${debian_chroot:+($debian_chroot)}\u@\h:\w\$"

(This was done on Guake. Gnome terminal still shows a completely blank screen.)

Revision history for this message
actionparsnip (andrew-woodhead666) said :

In gnome-terminal if you run:

source ~/.bashrc

Is it ok? If so we can make it stick

Revision history for this message
Bruce Ferguson (pstrbrc1) said :

Here's a screenshot of my terminal window-
I copied your command (source ~/.bashrc) and went ahead and "pasted" it into the terminal, hit [enter], (without seeing anything change on the blank screen), closed the terminal window, opened it back up, nothing.
I have re-installed gnome-terminal with Synaptic, (did this when I first noticed the aberrant behavior) but it made no difference. I have thought to completely remove it, then re-install, but Synaptic wants to remove gnome-core as well, and this seemed somewhat severe. =/

Revision history for this message
Best Stuart Hine (f-stuart) said :

I had the same problem when I first started using Lubuntu, but if you change the "Colours" settings in "Profile Settings" around to "White on Black" then you should be able to see the prompt and everything you typed, couldn't believe how simple the solution was tbh. Goodluck

Revision history for this message
Bruce Ferguson (pstrbrc1) said :

Thanks Stuart Hine, that solved my question.

Revision history for this message
Bruce Ferguson (pstrbrc1) said :

Just to add:
Having found nothing to fix this, i had installed Guake so I could do cl work when I needed. But I really missed that nautilus option "open terminal here"!
But today all I did was change my appearance style from "mist" to "high contrast." (I'm not sure what is analogous to "profile settings" in my bastard setup, so I just set out to change the appearance some way ) Shazam!!!!!
Thanks for the help!