install printer with mx430series-3.70-1-deb.tar.gz file I downloaded

Asked by yzfvie on 2013-03-10

I downloaded the above file from the internet and now, I don't know what to do with it. Can someone help?
Thanks. The file is in my Downloads directory.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2013-03-14
Last query:
2013-03-14
Last reply:
2013-03-11

You haven't stated exactly which printer you are trying to use.

You probably don't need that file mx430series-3.70-1-deb.tar.gz at all.

Please first run these commands in a Terminal to install some extra printer drivers:

sudo apt-get update

sudo apt-get install cups-driver-gutenprint

sudo apt-get install ijsgutenprint-ppds

sudo apt-get install openprinting-ppds

sudo apt-get install openprinting-ppds-extra

sudo apt-get install printer-driver-gutenprint

sudo apt-get install foomatic-db-gutenprint

sudo apt-get install printer-driver-all

Then open Printing using the Unity dash. Click Add.

Select your Canon printer from the list of devices and click Forward.

After installing the drivers this way, try printing.

If it does not work, then please tell us the exact model and make of your printer.

Source: http://gimp-print.sourceforge.net/p_Supported_Printers.php

extract the file, you will find debs. install the ones for your architecture.

yzfvie (yzfvie) said : #3

Its a Canon MX430 Printer

yzfvie (yzfvie) said : #4

I will try the above instructions later and let you know how I made out. The computer is in use right now.

yzfvie (yzfvie) said : #5

OK, here is what returned after entering the following:

andy@andy-laptop:~$ sudo apt-get install cups-driver-gutenprint
Reading package lists... Done
Building dependency tree
Reading state information... Done
cups-driver-gutenprint is already the newest version.
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.32-21 user-setup linux-headers-2.6.32-21-generic localechooser-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

andy@andy-laptop:~$ sudo apt-get install ijsgutenprint-ppds
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package ijsgutenprint-ppds

andy@andy-laptop:~$ sudo apt-get install openprinting-ppds
Reading package lists... Done
Building dependency tree
Reading state information... Done
openprinting-ppds is already the newest version.
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.32-21 user-setup linux-headers-2.6.32-21-generic localechooser-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

andy@andy-laptop:~$ sudo apt-get install openprinting-ppds-extra
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.32-21 user-setup linux-headers-2.6.32-21-generic localechooser-data
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  openprinting-ppds-extra
0 upgraded, 1 newly installed, 0 to remove and 10 not upgraded.
Need to get 18.4MB of archives.
After this operation, 24.3MB of additional disk space will be used.
Get:1 http://ca.archive.ubuntu.com/ubuntu/ lucid/main openprinting-ppds-extra 20100216-0ubuntu3 [18.4MB]
Fetched 18.4MB in 30s (596kB/s)
Selecting previously deselected package openprinting-ppds-extra.
(Reading database ... 319922 files and directories currently installed.)
Unpacking openprinting-ppds-extra (from .../openprinting-ppds-extra_20100216-0ubuntu3_all.deb) ...
Setting up openprinting-ppds-extra (20100216-0ubuntu3) ...

andy@andy-laptop:~$ sudo apt-get install printer-driver-gutenprint
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package printer-driver-gutenprint

andy@andy-laptop:~$ sudo apt-get install foomatic-db-gutenprint
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.32-21 user-setup linux-headers-2.6.32-21-generic localechooser-data
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  foomatic-db foomatic-db-engine hpijs ijsgutenprint libhpmud0
Suggested packages:
  hplip hplip-cups m2300w cjet foomatic-db-hpijs foomatic-gui hpijs-ppds hplip-doc
The following NEW packages will be installed:
  foomatic-db foomatic-db-engine foomatic-db-gutenprint hpijs ijsgutenprint libhpmud0
0 upgraded, 6 newly installed, 0 to remove and 10 not upgraded.
Need to get 7,054kB of archives.
After this operation, 118MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ca.archive.ubuntu.com/ubuntu/ lucid/main foomatic-db 20100216-0ubuntu3 [755kB]
Get:2 http://ca.archive.ubuntu.com/ubuntu/ lucid/main foomatic-db-engine 4.0.4-0ubuntu1 [304kB]
Get:3 http://ca.archive.ubuntu.com/ubuntu/ lucid-updates/main ijsgutenprint 5.2.5-0ubuntu1.1 [56.1kB]
Get:4 http://ca.archive.ubuntu.com/ubuntu/ lucid-updates/main foomatic-db-gutenprint 5.2.5-0ubuntu1.1 [5,352kB]
Get:5 http://ca.archive.ubuntu.com/ubuntu/ lucid-updates/main libhpmud0 3.10.2-2ubuntu2.2 [161kB]
Get:6 http://ca.archive.ubuntu.com/ubuntu/ lucid-updates/main hpijs 3.10.2-2ubuntu2.2 [427kB]
Fetched 7,054kB in 9s (763kB/s)
Selecting previously deselected package foomatic-db.
(Reading database ... 321835 files and directories currently installed.)
Unpacking foomatic-db (from .../foomatic-db_20100216-0ubuntu3_all.deb) ...
Selecting previously deselected package foomatic-db-engine.
Unpacking foomatic-db-engine (from .../foomatic-db-engine_4.0.4-0ubuntu1_i386.deb) ...
Selecting previously deselected package ijsgutenprint.
Unpacking ijsgutenprint (from .../ijsgutenprint_5.2.5-0ubuntu1.1_i386.deb) ...
Selecting previously deselected package foomatic-db-gutenprint.
Unpacking foomatic-db-gutenprint (from .../foomatic-db-gutenprint_5.2.5-0ubuntu1.1_all.deb) ...
Selecting previously deselected package libhpmud0.
Unpacking libhpmud0 (from .../libhpmud0_3.10.2-2ubuntu2.2_i386.deb) ...
Selecting previously deselected package hpijs.
Unpacking hpijs (from .../hpijs_3.10.2-2ubuntu2.2_i386.deb) ...
Processing triggers for man-db ...
Setting up ijsgutenprint (5.2.5-0ubuntu1.1) ...
Setting up libhpmud0 (3.10.2-2ubuntu2.2) ...
Setting up hpijs (3.10.2-2ubuntu2.2) ...
PPD for printer Deskjet_D2600 updated
Setting up foomatic-db-engine (4.0.4-0ubuntu1) ...
Setting up foomatic-db (20100216-0ubuntu3) ...
Setting up foomatic-db-gutenprint (5.2.5-0ubuntu1.1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

andy@andy-laptop:~$ sudo apt-get install printer-driver-all
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package printer-driver-all
andy@andy-laptop:~$

                                                  The printer (Canon Pixma MX430) is not in the list that comes up.

yzfvie (yzfvie) said : #6

I see that the printer is listed as "Experimental"

The printer Canon Pixma MX430 does come up in my printer list after running the commands I gave you..

Maybe it is because I am running Ubuntu 12.10 and you are running Ubuntu 10.04

I suggest performing a clean install of Ubuntu 12.10 and then rerunning the commands I gave you in 12.10.

Ubuntu 10.04 will be end-of-life and not supported anymore next month anyway.

Lucid is EOL in April this year so I suggest you upgrade to Precise which you can get in one jump (LTS to LTS upgrades are very supported)
After Lucid goes EOL it will get zero support and zero updates.

yzfvie (yzfvie) said : #9

Thanks actionparsnip, that solved my question.