Permission error extracting tar file?

Asked by paul christie on 2012-10-31

Hi

I am trying to set up my laptop for secure access to my work via a citrix server and need to download the receiver which is a tar file.

It downloads but then won't extract saying I don't have permission to extract it from the download folder. I am the administrator.

I am not great with IT and I'm following so rough instructions but have managed to extract the files on a different laptop I have that is running 12.4. This laptop is running 12.10 which I have just installed.

Can anyone help?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-31
Last reply:
2012-11-02

Use "sudo" command to extract the tar content into system (normal user restricted permission) tree

sudo tar ...

paul christie (f-tucker) said : #2

Thanks, the download contains 4 files.

I am not sure how to type the command into terminal to extract them.

This is what I have:

linuxx86_12.1.0.203066.tar.gz
setupwfc
pkgld
setupwfc.msg

Any idea how I do it?

I also need to use the Citrix Receiver for GNU/Linux to access my work desktop from home.

This is how I install the Citrix receiver on my Lubuntu 12.10 laptop without using the .tar.gz files.

Go to http://www.citrix.com/downloads/citrix-receiver/receivers-by-platform/receiver-for-linux-121.html

Then click on the download button RIGHT ABOVE the following text:

File Size: 3.39MB
File Type: .deb

So you need to download and install the .deb file, not the .tar.gz file.

Then install the icaclient-12.1.0_i386.deb file

Once the icaclient-12.1.0_i386.deb file is installed, I can successfully access the Citrix desktop using the Chromium browser.

After logging into your work account via Chromium, the CITRIX/XENAPP/clientDetection routine will probably not detect the fact that the Citrix receiver is already installed on your GNU/Linux PC.

 In that case, simply click on the "Already installed" link, to let the website know that you already have the receiver installed.

This routine works perfectly for me.

Hope this helps.

paul christie (f-tucker) said : #4

Thanks.

I will try the .deb file. I thought I tried that one as well though!

For some reason my instructions from our IT people state it has to be the .tar file that I use. I don't know why?

If you are using Ubuntu (or Debian), you should use the .deb file, not the .tar file.

The .tar file is only a LAST resort, not the first option.

paul christie (f-tucker) said : #6

Hi

I have downloaded the .deb file and it suggested it had installed ok via the software centre.

However, I can't see the ICA file anywhere.

I need to copy the globalsign root certificate into the keystore file before it will work ok once logged into citrix. I can't find where the files are to copy the cert in there??

I just checked the list of certificates in the Chromium browser. The GlobalSign Root CA certificate is already installed by default in Chromium in Ubuntu (which does not surprise me). So you can skip that step....

The icaclient is probably called "Citrix Receiver" somewhere in your start menu.

But to be honest, I never need to launch the Citrix Receiver manually. When I visit the Citrix website and I authenticate with my login and password, the website automatically launches the Citrix Receiver after I click on the "Already installed" link (see my previous instructions)....

That is why I did not mention the ICA file / Citrix Receiver / etc.... in the procedure I gave you yesterday...

paul christie (f-tucker) said : #9

Thanks

I have found the file locations.

I don't know why but my employers appear require that I copy the cert location into the CACERTS file.

I have logged in to Citrix and when I try to open any files or access my email I am getting an SSL global certificate error.

I don't know if this is something specific to my our IT access or what, but their instructions were to use the tar file and copy the cert into the certs folder.

Hence, I still can't log on despite now having the ICA client files installed!! Hmmmm will keep messing and see if I get some joy!!

Here is where the GlobalSign Root certificate is installed on my PC (and probably also yours):

x@localhost:/etc/ssl/certs$ ls -lia |grep GlobalSign
1181793 lrwxrwxrwx 1 root root 27 Oct 18 23:42 062cdee6.0 -> GlobalSign_Root_CA_-_R3.pem
1182562 lrwxrwxrwx 1 root root 27 Oct 18 23:42 111e6273.0 -> GlobalSign_Root_CA_-_R2.pem
1181794 lrwxrwxrwx 1 root root 27 Oct 18 23:42 1e8e7201.0 -> GlobalSign_Root_CA_-_R3.pem
1182529 lrwxrwxrwx 1 root root 27 Oct 18 23:42 4a6481c9.0 -> GlobalSign_Root_CA_-_R2.pem
1183698 lrwxrwxrwx 1 root root 22 Oct 18 23:42 5ad8a5d6.0 -> GlobalSign_Root_CA.pem
1183737 lrwxrwxrwx 1 root root 22 Oct 18 23:42 b0f3e76e.0 -> GlobalSign_Root_CA.pem
1181607 lrwxrwxrwx 1 root root 57 Mar 5 2012 GlobalSign_Root_CA.pem -> /usr/share/ca-certificates/mozilla/GlobalSign_Root_CA.crt
1181608 lrwxrwxrwx 1 root root 62 Mar 5 2012 GlobalSign_Root_CA_-_R2.pem -> /usr/share/ca-certificates/mozilla/GlobalSign_Root_CA_-_R2.crt
1181695 lrwxrwxrwx 1 root root 62 Mar 5 2012 GlobalSign_Root_CA_-_R3.pem -> /usr/share/ca-certificates/mozilla/GlobalSign_Root_CA_-_R3.crt
x@localhost:/etc/ssl/certs$

So the certificates are installed in /usr/share/ca-certificates/mozilla/

There are several symbolic links from /etc/ssl/certs to /usr/share/ca-certificates/mozilla/

Here is more information that you requested:

https://help.ubuntu.com/12.04/serverguide/certificates-and-security.html

paul christie (f-tucker) said : #11

I can't get access.

No matter what I do I get an SSL error saying contact your help desk, you have chosen not to trust 'globalsign root'

So the cert isn't right for some reason.

I have tried to manually copy the cert into the CACERTS folder, but it's held in root and I don't have permissions.

On another Ubuntu laptop I successfully got access with the tar file but I had to manually copy the cert on that occasion before it would give access, so it must be the company set up that's the issue. On that laptop it dropped the ICA file into my home folder, so I had permissions to copy the certificate.

I have just copied the OPT file into my home folder and copied the cert into there, but still no joy!

Looks like I will have to leave it to our IT to get me set up on this laptop.

Many thanks..

The following will not work due to lack of permissions:

cp <location_of_file>/name_of_certificate.crt /usr/share/ca-certificates/mozilla/

The following WILL work thanks to the use of sudo:

sudo cp <location_of_file>/name_of_certificate.crt /usr/share/ca-certificates/mozilla/

More info about sudo is here:

https://help.ubuntu.com/community/RootSudo

sudo will temporarily escalate your privileges to that of root user and then the copy WILL work.

Can you help with this problem?

Provide an answer of your own, or ask paul christie for more information if necessary.

To post a message you must log in.