ls -l output 'c' appears where 'd' would be expected. Whatis the significance of 'c'

Asked by Royalist on 2012-10-18

I am having difficulty printing from a Canon ip4850. Under properties Device URI the following path is shown when the printer is connected and powered up. [CODE]cnijusb:/dev/usb/lp0[/Code]. ls -l results in [CODE]ls -l is crw-rw---- 1 root lp 180, 0 Oct 18 12:58/dev/usb/lp0 [/Code]. What does the 'c', mean please? I hoped to be able to rename and/or copy this location to disable lp0 temporarily. Removal of the printer followed by rebooting and re-installation does not solve the problem.

Background info: I have been trying to connect the printer directly to the usb socket of the BT HomeHub3 to be able to print when the machine the printer is connected to, is not running. This has been unsucessful and I am now trying to restore normal printing from a desktop usb port.

The result is that now in Printer>Properties>Printer State:, There is a 'cable unplugged' etc message displayed. There is no problem with the cables or connections. When documents are in the print queue "Processing - STS:USB IP4800 0C IYF LL010 MI000 CRUK l 040 YI000 5TF f 4" is displayed instead.

The executable appears to be located at [CODE]sudo ls -l /usr/lib/cups/backend/usb
-r-xr--r-- 2 root root 30416 Aug 20 15:07 /usr/lib/cups/backend/usb[/Code].

Any comments and advice please.

P.S. I have discovered how to stop and start CUPS in 'service and then registered with lpadmin.

lp0 is only evident when the printer is powered up.

Question information

English Edit question
Ubuntu gnome-terminal Edit question
No assignee Edit question
Solved by:
Warren Hill
Last query:
Last reply:
Revision history for this message
Best Warren Hill (warren-hill) said :

This is a long directory listing. Unix / Linux treats (almost) everything as a file and the first character lists the file type the most common ones we see are '-' for a normal file and 'd' for a directory but there are others.

The 'c' in this case says its not a normal file but a character device

A typical directory entry looks like this

drwxrwxr-x 3 warren warren 4096 Sep 29 13:13 ASUS-Desktop

 The file permission display should be interpreted this way:

     flags owner group world
       | --- --- ---
       d rwx rwx r-x 2 lstein 1024 Aug 29 22:58 problems/

    "d" = directory
    "l" = link
    "p" = pipe
    "b" = block special device
    "c" = character special device
    Permissions for the owner of the file/directory:
    "r" = read permission
    "w" = write permission
    "x" = execute permissin
    Permissions for the group owner of the file/directory.
    Permissions for everyone else

Revision history for this message
actionparsnip (andrew-woodhead666) said :
Revision history for this message
Royalist (royalist10-2) said :

Thanks Warren. This is what I wanted to know. However I shall now post another query relating to the ongoing printer problem and which I have tried to post on the Canon Europe site. That site is apparently down at present and they may not know much about the Ubuntu side of the problem.

Again thanks