Make ISO-8859-1 chars in terminal application

Asked by Peter Jennett on 2012-04-07

I would like to be able to create the extended chars that are available to users of MS windows and most terminal emulator applications. In these applications the keypad can be used to enter the decimal value of the character.

I have enabled the ISO-8859-1 chars in terminal and I am now able to display the chars that I want which are the french accented chars. This I can do using echo both in "bash" shell in terminal and telneting to another host.

What I am unable to do is to issue the characters using the keyboard.

I am sure there is a method in "terminal" of generating codes above ascii 128 0x7Fh 0o177 but I do not seem to be able to find this in the help.

Regards
Peter Jennett

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
Peter Jennett
Solved:
2012-05-05
Last query:
2012-05-05
Last reply:
2012-04-08
José Antonio Rey (jose) said : #1

Well, the terimnal is based on UTF-8 characters. You can find a complete list in:

http://en.wikipedia.org/wiki/List_of_Unicode_characters

Peter Jennett (techwrk01) said : #2

Thanks José Antonio Rey for the pointer to the "List of Unicode characters". This does not solve my problem. As I stated in my original question I am able to see the characters on the screen but not able to generate the characters easily using a keyboard.

I am sad to say that I have now forgotten the source, but I have found a solution to this problem. In a windows environment the codes can be generated by holding down the [Alt] key and tapping the decimal value of the character on the numeric pad on the keyboard. On an Ubuntu workstation in Xterm the same can be achieved by holding down [shift] and [Ctrl] and then pressing "u" this gives an underlined lowercase "u" on the screen indicating that the value of the Unicode character should be entered in HEX notation. Having entered the HEX value of the character the [Enter] key should be pressed. On pressing the enter key the typed Unicode hex value is removed and replaced with the Unicode character.

This method I admit is not as convenient as the MS Windows method. However, I am more than prepared to put up with this minor inconvenience in order to not use MS Windows which I consider is a considerable hinderance to the world.

I have this same problem. It caused me a lot of frustration b/c I was using a gnome-terminal with bash to test my keyboard settings, and I kept thinking that the settings weren't working, or only worked sometimes (ie when I typed into gedit). If I change my shell in the gnome-terminal to ksh or zsh, I can input the characters fine, and in other apps it works (see: «»“”çáßðfäåéëþ!), but I can't type them into bash. The same thing happens using terminator, so I think I can safely say the problem lies with bash.

Recently upgraded to Ubuntu 12.04. I haven't noticed this issue before, and I've been using this layout (altgr-intl) for a while.
Relevant env vars:

LANG=en_US.UTF-8
TERM=xterm