After downloading ip2700_Linux_Package.tar step by step how to install

Asked by larryk335 on 2011-11-15

After downloading am I supposed to extract the file. what directory shoulld I be in? When it comes to run tar -xvf file.tar I seem to be doing something wrong. I am intrested to install canon printer driver. Or I will take the Da__ printer back to the store and get a HP which I should have done in the first place.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-11-19
Last query:
2011-11-19
Last reply:
2011-11-18
larryk335 (larryk335) said : #1

I am running Ubuntu 11.04

I will assume the file is in the Downloads folder, Run:

sudo apt-get -y install unp; cd ~/Downloads; clear; unp ip2700_Linux_Package.tar

You will now see a new folder which you can now enter with:

cd Foldername

obviously CHANGE foldername for the actual folder name, you should now run:

sudo install.sh

And it should install

larryk335 (larryk335) said : #3

I attempted to do as instructed and while running it came up with a error--unp not installed--but it told me how to install unp so I did that and came up with another error near line 934. It was parsing file '/var/lib/dpkg available near line 934 package 'gimp':
'depends' field, reference to0 'Python-gtk2': version contains `' E: Subprocess /usr/bin/dpkg returned an error code (2)

So I am completely out of my depth. I ran your instructions again and came up with the same error. I appreciate any help that I can get. I am a Ubuntu linux lover and maybe this is part of the reason that I am. thanks

Try:

sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sudo rm -rf /var/lib/dpkg/updates/*
sudo rm -rf /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists/partial
sudo apt-get clean
sudo apt-get update
sudo dpkg --clear-avail
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt-get update
sudo apt-get dist-upgrade

larryk335 (larryk335) said : #5

Well--I really do appreciate your efforts. I entered all the ccommands as prescribed. My printer is still not working. Yes it is plugged in and turned on. Sometimes things dont work because of the stupidest oversight (mine)

My machine went through a lot of processing as I entered your commands but in the end nothing. I went to administration>printing just to look around--there were some changes but no luck. At this stage should I go back to that first command and retry that? thanks for your help

larryk335 (larryk335) said : #6

for some reason it still doesnt work

larryk335 (larryk335) said : #7

Hello all--its me. I went back to downloads and double-clic'd on the tar file. then then came up in the extract window. I highligted it then clic'd extract and I got a deb file with tree sub files packages--resources and install.sh. So I quess I need to cd to the deb file and install.sh. Ill add more later after I see if that works thanks

Extract the files to a folder, in the same folder as install.sh there is a folder with debs in, you need to install the two which match your systems architecture.

larryk335 (larryk335) said : #9

Thanks actionparsnip, that solved my question.

larryk335 (larryk335) said : #10

I just want to thank andrew-woodhead666. I think he went the distance to help me solve my driver
problem. Its really appreciated. It5s one of the reasons that linux appeals to me.