when entering a command, Terminal is asking for a password.

Asked by Asoka Dissanayake on 2011-06-13

Binary package hint: gnome-terminal

Whenever I try to enter something in the CLI (command line interface) I am asked for a password which I do not know about. I have only the log in password. If I enter that it says sorry try again. I am fed up with this already.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-terminal 2.32.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-10.44-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic i686
Architecture: i386
Date: Mon Jun 13 20:02:42 2011
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=si_LK:en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=si_LK.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to natty on 2011-04-28 (45 days ago)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2011-07-08
Last query:
2011-07-08
Last reply:
2011-07-06
Pedro Villavicencio (pedro) said : #1

Please ask such questions in the answer tracker, thanks.

The password the system ask you is simply your user password you have set it at install time...
The terminal will not show you any screen cher when you type the password so type then press enter.

if you have forgot the password please change it: http://www.psychocats.net/ubuntu/resetpassword

Asoka Dissanayake (adsinky) said : #3

First, thanks for all the suggestions. I tried them and did some experimenting also to find out about why this happens. In the meantime, I had to abort an operation in Synaptic Package Manager while experimenting. So again I was directed to some command in the Terminal which did not work. As a last resort, I reinstalled the entire program (operating system). This time, I selected a simpler password. Now the problem is not there. Yet, I end up with a question mark many times when using Terminal.

With the re-installation I found that there is a Root Terminal in addition to Terminal. This Root Terminal was not to be found earlier. This could be due to trial-and-error methods employed to solve a problem. I do not know whether the Terminal and the Root Terminal is different in their use. Anyway for the time being the problem is solved and it may be closed.

Asoka Dissanayake (adsinky) said : #4

Having got more and more familiar with the terminlogy used in Ubuntu, together with discussions and answers in Launchpad, it is possible to find solutions. Hope this commend will be useful for new users.