how to install fujitsu-kbdlights using terminal

Asked by MetungKP on 2011-04-19

I get stuck at at step 3. When I put in cd fujitsu-kbdlights-0.1.0 in Terminal it says no such file or directory. I downloaded fujitsu-kbdlights-0.1.0.tar.gz and extracted it. Maybe I'm not understanding what compile mean...

Any help is always appreciated.

download the fujitsu-kbdlights-0.1.0.tar.gz to any directory in your computer

2 decompress the package (it will create another directory, fujitsu-kbdlights-0.1.0/)
tar zxvf fujitsu-kbdlights-0.1.0.tar.gz

3 compile and install
cd fujitsu-kbdlights-0.1.0
make
sudo make install

4 and in a command shell, you can type

fujitsu_kbdlights on

fujitsu_kbdlights off

fujitsu_kbdlights toggle

fujitsu_kbdlights

5 if you want, you can bind any of the previous commands to a hot-key using any keyboard setup utility

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
MetungKP
Solved:
2011-04-27
Last query:
2011-04-27
Last reply:
2011-04-25
delance (olivier-delance) said : #1

Could you run command:
   ls -l
in folder which contains fujitsu-kbdlights-0.1.0.tar.gz

MetungKP (metungkp) said : #2

Where would I in put ls-l in a folder?

delance (olivier-delance) said : #3

Open a terminal (Ctrl+Alt+T), goes to folder which contains fujitsu-kbdlights-0.1.0.tar.gz and run command:
   ls -l
   ls -l fujitsu-kbdlights-0.1.0
and report results.

MetungKP (metungkp) said : #4

I get this...

ls-l: Command not found

This link should help you some:

http://ubuntuforums.org/showthread.php?t=1549473

Also, I believe you typed:

'ls-l'

which is wrong. There is a space between the 'ls' and '-l', and it should be:

$ ls -l

where the '$' is the command prompt - you do not type that in.

MetungKP (metungkp) said : #6

metungkp1@MetungKP1:~$ ls -l
total 476
drwxr-xr-x 2 metungkp1 metungkp1 4096 2011-03-28 17:05 Desktop
drwxr-xr-x 3 metungkp1 metungkp1 4096 2011-04-20 19:33 Documents
-rw-r--r-- 1 metungkp1 metungkp1 211912 2010-10-09 04:45 download
-rw-r--r-- 1 metungkp1 metungkp1 211912 2010-10-09 04:45 download.1
drwxr-xr-x 2 metungkp1 metungkp1 4096 2011-04-20 20:09 Downloads
-rw-r--r-- 1 metungkp1 metungkp1 179 2011-03-28 16:43 examples.desktop
drwxr-xr-x 2 metungkp1 metungkp1 4096 2011-04-07 19:47 Music
drwxr-xr-x 3 metungkp1 metungkp1 4096 2011-04-07 19:47 Pictures
drwxr-xr-x 2 metungkp1 metungkp1 4096 2011-03-28 17:05 Public
drwxr-xr-x 2 metungkp1 metungkp1 4096 2011-03-28 17:05 Templates
drwxr-xr-x 3 metungkp1 metungkp1 4096 2011-03-28 17:07 Videos
metungkp1@MetungKP1:~$

delance (olivier-delance) said : #7

I see any folder named fujitsu-kbdlights-0.1.0. I suspect folder to be in "Downloads". Please run following commands:
   cd $HOME
   cd Downloads
   ls -l
and post result.

MetungKP (metungkp) said : #8

metungkp@MetungKP:~$ cd $HOME
metungkp@MetungKP:~$ cd Downloads
metungkp@MetungKP:~/Downloads$ ls -l
total 212
-rw-r--r-- 1 metungkp metungkp 206290 2011-01-06 03:48 010620111033.jpg
drwx------ 6 metungkp metungkp 4096 2011-03-25 16:58 backintime
drwx------ 3 metungkp metungkp 4096 2010-11-28 19:15 System Volume Information
metungkp@MetungKP:~/Downloads$

I hope you can help because I have 2 other softwares I've trying to install and I get stuck in the same spot.

It doesn't matter if I do cd ~/Downloads or I thought about doing cd ~/Home/MetungKP/downloads. It still not able to find the directory.

What I don't understand is in the step is says "Decompress". I've researched and nothing I come up with. There is also compress. I installed 7RAR from the software store but then I can't find where it is installed in my PC

MetungKP (metungkp) said : #9

Not sure if this makes any difference but this is for a notebook.

delance (olivier-delance) said : #10

In which folder is file fujitsu-kbdlights-0.1.0.tar.gz, and in which folder did you uncompressed it?

MetungKP (metungkp) said : #11

Downloads and I uncompressed it in the same folder. When you say decompress I just double click on it and then another folder pops up, right? I even tried using a different folder, such as, Documents.

MetungKP (metungkp) said : #12

I hope someone can help. This is happening on 3 softwares I would like to install.

MetungKP (metungkp) said : #13

Anyone?

MetungKP (metungkp) said : #14

I found the solution.

MetungKP (metungkp) said : #15

I found the solution.