how do I install and set up clamav

Asked by paul on 2007-09-22

trying to run"freshclam-v" as root
just trying to get fresh clam to work in ubuntu7.0
the following question was answered and thanks for all the tips and help
after all that trouble still could not get clam av set up
does any one use it
on the main page it says 4 steps but doesn't say how to do them?

now a days I do not like to use a comp with out anti virus and clamav is suposted to be good
thanks for any help
paul

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
Ulisses Montenegro
Solved:
2007-09-29
Last query:
2007-09-29
Last reply:
2007-09-25
Best Ulisses Montenegro (urma) said : #1

Ubuntu is installed with the root user password setup in a such a way that it is impossible to login as root. This is done in order to discourage users from using the root account as if it was a regular user account. You can try:

$ sudo freshclam -v

which will run only the freshclam command as root, or you can use

$ sudo /bin/bash

which will open up a root shell (be careful while trying stuff under a root shell, though). Both will require you to provide your password.

paul (skib1999) said : #2

tried both in command line terminal
sudo freshclam-v and the respomce was command not found

sudo/bin/bash responce was no such file or folder

I am extreamly new and hate windows luv linnux have read and keep reading books about linnux os for now just want to get clam anti virus going for protection.
thanks for any help apreciated very much
paul

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

Chris Deresz (cderesz) said : #3

Hi Paul,

If you tried to use the commands as you typed them, you have to add spaces between "sudo" "freshclam" and "-v", i.e. sudo freshclam -v. The same applies to "sudo" and "/bin/bash", as sudo /bin/bash. Try to run the commands with the spaces.

Bhavani Shankar (bhavi) said : #4

Hi paul...a couple of things you can try out
1.sudo freshclam -v, and sudo /bin/bash with spaces... (Sudo emulates the superuser)
2.Root access is disabled by default in ubuntu... If you want to login as root without sudo try this:
$ su
$ password: rootpassword
in case you cant login as root (assuming you havent set your root password) follow these simple steps..
$sudo passwd root
$New Password: typeyourpassword
$Retype password: Again
This will set your root password..

Then you can log in as root by doing as mentioned above,

hope it helps,

br,

Bhavani Shankar.

cablop (cablop) said : #5

It's not recommended to use root directly, just for administrative and correction issues.

Whenever you need to run a command or program use sudo your_command, if you want to start a graphical application use gksudo your_command instead.

If you have a graphical interface (such as gnome or KDE) you don't need to go to command line ant type commands for changing or setting root's password, you just need to go system and edit users directly, then go to gdm settings and enable root access in graphical environment. But again, i remind you that's strongly NOT recommended.

Do you want to use your account as a sudo account directly, ok, then add your account to sudo group in early versions or check about sudoers to be able to use sudo without needing to type your password every time (and works better in graphical environment, some times you use sudo and applications don't become visible cause system is wanting you to type your password in a non visible console, if any)... in this moment i don't rememeber how is the sudoers configuration steps, but i remember i googled and found them some months ago...

Mackenzie Morgan (maco.m) said : #6

You can get a root shell by typing "sudo -i" or "sudo su -" first.

Bhavani Shankar (bhavi) said : #7

yes I too know its not strongly recommended to use root directly.. because I m working on reversing and cracking and hacking 6yrs down the lane mate...:) question was how to login as root? I discussed both the methods in my answer.. as sudo and as well as root...:) I hope I answered to the point..:)

Bhavani Shankar.

Bhavani Shankar (bhavi) said : #8

Concentrating on linux systems from past 5 yrs and using ubuntu right from warty days...:)
Bhavani Shankar.

Bhavani Shankar (bhavi) said : #9

Ok... Let me be more clearer about the issue...
You do have root privileges. You just need to use the sudo or gksudo commands.

https://help.ubuntu.com/community/RootSudo

If you created a root user during install you may have some problems using it. It is automatically created anyway so I'm surprised it let you make another. This account is disabled (i.e. no way to log in as root) by default. However, it exists and is vital to your system working. If you also created a root account then there may be some conflicts. You can look under system - admin - users and groups to see what's up. There should be a root account there. Don't mess with it. Changing how root works will totally bork your system. Use sudo. See the link above for the rationale behind using sudo. In short, it's more secure.

Hope it clears your doubts...:)

br,

Bhavani Shankar.

Bhavani Shankar (bhavi) said : #10

So use sudo freshclam -v for a more secure root access...:)

paul (skib1999) said : #11

Thanks Ulisses Montenegro, that solved my question.

I got the freshclam (as desribed above) but it comes up with the "DON'T PANIC" message, which I cannot figure out. I still have no antivirus signatures in my ClamAV scanner.