Ubuntu

Setting default character encoding for a particular profile

Asked by Andrew Rendle on 2010-07-14

Is it possible to change the character encoding that's used by a particular gnome-terminal profile?

Here's what I'm trying to achieve:
I have created a few profiles with custom commands to SSH to a particular server (i.e. a profile called server1 with custom command "ssh user@server1", a profile called server2 with custom command "ssh user@server2", etc.)
And then I've created a custom launcher with the command "gnome-terminal --tab-with-profile=Default --tab-with-profile=server1 --tab-with-profile=server2 --tab-with-profile=server3", so that with one click I get a gnome-terminal window with command lines on the local machine and on the various servers in a set of tab.
My desktop and most of the servers are set to use UTF8, but one server is set to ISO-8859-1 and it would be very neat if my "one click useful set of terminals" had the tab for this server using ISO-8859-1 rather than me having to remember to change it.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Last query:
2010-07-15
Last reply:
2010-07-15
Sam_ (and-sam) said : #1

You could set environment variable in terminal profile.
https://help.ubuntu.com/community/EnvironmentVariables

Andrew Rendle (andrew-andrewr) said : #2

Unfortunately, I can't find any way to set an environment variable in the gnome-terminal profile settings. I've tried setting the custom command to "LANG=en_GB.iso88591;ssh user@server", which this results in a gnome-terminal error saying "There was an error creating the child process for this terminal".
So my next attempt was to create a small shell script that says:
#!/bin/sh
LANG=en_GB.iso88591
ssh user@server

and use this in the profile's custom command setting, which does at least connect, but gnome-terminal is still set to UTF-8.

Sam_ (and-sam) said : #3

Can you help with this problem?

Provide an answer of your own, or ask Andrew Rendle for more information if necessary.

To post a message you must log in.