Adjust Date & Time in Ubuntu 8.10

Asked by Jonathan Thomas on 2009-03-15

I'm using Ubuntu 8.10 (AMD 64bit) and I can't figure out how to adjust my date / time to be correct. After daylight savings, my clock is off by 1 hour. Whenever I manually adjust the clock, it only seems to fix the problem temporarily.

Also, I don't see any options to "sync" with a ntp server, such as ntp.ubuntu.com. Any ideas?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-system-tools Edit question
Assignee:
No assignee Edit question
Last query:
2009-03-17
Last reply:
2009-03-18
Jonathan Thomas (jonoomph) said : #1

I forgot to mention the steps I am taking to set the time.

Step 1) I right click on the date/time panel
Step 2) I select the "Adjust Date & Time" option
Step 3) The screen that pops up only has a small calendar to select the current date, and 3 text boxes to enter the current time. There are no other options on the window. It just doesn't match the screenshots I've found on the Ubuntu Forums.

This might be a good starting point https://help.ubuntu.com/community/UbuntuTime

Hope this helps

Jonathan Thomas (jonoomph) said : #3

Thanks for the link. I've already looked at that article, and my "Adjust Date & Time" screen just doesn't look like those. It doesn't have an option to synchronize or an option to select a timezone. I'm wondering if it's because I'm using the 64 bit build of Ubuntu?

The Ubuntu you have installed is like my Ubuntu 8.10 32 bits they haven't no more this options to adjust time.
You need to use the menu System → Administration → Date and time and try to set options using this menu.
If you have trouble to authenticate yourself after giving your user password then tell me here i'm about to fill a bug on this issue that i have.

Thank you

Andre Mangan (kyphi) said : #5

This facility is missing in 8.10. In synaptic you will find "ntp" and "ntpdate" - these are installed by default in 8.04 and provide the facility that you are looking for.

@Andre: Thank you, please tell me / verify if you have trouble to authenticate yourself as i have now in my Ubuntu 8.10 32 bits using the menu System → Administration → Date

Thank you

Andre Mangan (kyphi) said : #7

@marcobra: I use Hardy Heron where this facility is part of the standard install. I have Intrepid Ibex installed in VirtualBox and know that the ntp facility has been left out - but it is available via synaptic.
The System -> Administration -> Date approach does not effect a change on a permanent basis.

Might be not concerning with original question but there is a bug about this authentication issue https://bugs.launchpad.net/ubuntu/+source/gnome-system-tools/+bug/187335

Jonathan do you have same issue...?

Thank you

Andre Mangan (kyphi) said : #9

On closer inspection, the option to install ntp support is offered (in Intrepid).

Go to System, Administration, Time and Date. Unlock the screen with your password. Click on the button next to Configuration and the option to synchronise will be available. Click on "Keep synchronised with Internet servers" and the option to install ntp will be offered.

Comment: One should not have to ask for this.

Jonathan Thomas (jonoomph) said : #10

When I go to System / Admin / Time & Date, I am able to unlock the screen just fine. I am also able to choose a server to sync my time with Internet servers. However, the time is still off by 1 hour, due to daylight savings (I'm assuming). Is there a setting for daylight savings time I am missing? Or should syncing with a NTP server figure out the correct time?

Thanks,
-Jonathan

Andre Mangan (kyphi) said : #11

There is no setting for daylight saving - there cannot be since daylight saving dates are subject to change.

Time synchronisation is made depending on your specified locale although you can select your LOCAL ntp server.

Jonathan Thomas (jonoomph) said : #12

I have selected a "local" ntp server from the list of servers, and double checked my time zone. For some reason, the ntp server doesn't ever update my time. It just seems to do nothing. When I manually set the time, it seems to be remember what I enter now, even though it's drifted a few minutes in the last 48 hours.

I guess my problem still remains. Regardless of what ntp server I select, it just doesn't seem to do anything. Is there a log file somewhere that might contain clues to what the ntp service is doing? Thanks.

Andre Mangan (kyphi) said : #13

You can specify as many ntp servers as you like. I use two.

Go to System, Administration, Services and after unlocking the facility with your password, ensure that there is a tick in the box next to "Clock synchronisation service (ntp)".

Can you help with this problem?

Provide an answer of your own, or ask Jonathan Thomas for more information if necessary.

To post a message you must log in.