I am not allowed to change my Old & main profile login.

Asked by tosoth on 2008-05-07

Hi, I'm using Ubuntu 10.10. I have strange problem with change my main profile enable.
I have disable my main profile & create a 2nd profile but after that i can't enable my main profile on Ubuntu.
The password are denied & Show me the "Authentication Failure".Can you tell me the solution of the problem.
I think this is a strange problem.Please reply me via mail.
My email id <email address hidden>.

tosoth (tosoth) said : #1

Well, forget about the last one. I can run nm-applet with sudo. It was working without sudo earlier, but it works. There could be a problem running it automatically with gnome session without password.

tosoth (tosoth) said : #2

Really noone knows how to help me?

Sławek Mikuła (zorba) said : #3

same problem here, i'm stomped. Trying everything but without any sucess.

Sławek Mikuła (zorba) said : #4

First step: console-kit-daemon isn't running after start-up. When i run manually (from tty1) this daemon as root and login to X afterwards Network Manager starts working again, messages "Failed to execute program /usr/lib/dbus-1.0/dbus-daemon-launch-helper ..." are missing, but the error dialog box still is present.

Maybe someone tell my about files at /usr/share/dbus-1/system-services. There is ConsoleKit file, but apparently it does not starts at system startup ?

tosoth (tosoth) said : #5

Hi. My problem was, that all users (root, normal users, system users) had nogroup as their primary group. I don't know how's that possible that something like this happened. After I corrected groups, g-s-t started to work, but I wasn't able to Unlock them, because authentification window wasn't appearing. It was happening only for my user, when I created new one, it was working for him.

Obviously your problem is different.

I gave up finally i made a clean install of ubuntu. I even deleted most of program's settings from my home directory. I think that I didn't leave anything that could interfere. After install everything was ok... for a short while. When I installed some programs problems started again, but not so serious. Sometimes authentification window doesn't appear and I have to restart system. After every login I can start only one of system tools without any problem. Second one I try to run show me only clean window (ie Users and Groups without any users or groups in the list, Services without any services, etc.). Imho something here is bugged as hell, but I had enough. I'll leave it as it is and wait until someone admits that there's a bug and fix it.

Sam_ (and-sam) said : #6

Hi tosoth,
since you've made a new installation and still experience problems you might want to join these bugs #227383 and/or #187335.
I'm lucky only having a problem with network-manager after upgrading to 8.04, but until this moment no one could tell me which setting has to be done.
I'm not sure about the mentioned unconsistency within dbus+pam+polkit, because why other apps are running then by unlocking them e.g. changing date+time or hal+mount?

Sam_ (and-sam) said : #7

Hi Sławek Mikuła,
in
#/usr/share/dbus-1/system-services/org.freedesktop.ConsoleKit.service
the content is:
[D-BUS Service]
Name=org.freedesktop.ConsoleKit
Exec=/usr/sbin/console-kit-daemon
User=root

Sławek Mikuła (zorba) said : #8

Hello Sam,

 Yes indeed it was exactly as You've written. I'm saying "was" because i went the same way as tosoth and reinstalled hardy from scratch. Now everything is working perfectly, nonetheless the fight with the previous upgrade made me quite dissapointed of my skills :)

Sam_ (and-sam) said : #9

Hi Sławek Mikuła,
I'm happy for you, but unfortunately it still doesn't work for tosoth.
And of course you don't know why it is now working? :-)
After reinstalling you didn't make any changes concsiously to provide polkit with commands, say settings?
In this bug #227383 I've just told to won half the way, because at the moment I'm getting in from terminal with #network-admin, but not within the GUI, but I'm happy with that.
Every upgrade can be an adventure and offers to learn a lot, so have fun and enjoy.

Sławek Mikuła (zorba) said : #10

Hi Sam,

 No i'haven't done anything to the configuration regarding polkit, dbus, hal. My home directory stays still the same (different partition from the system). I've checked also on the other user and it is still working.
 Maybe it's something with packages that tosoth installed. I can provide my packages list (priv) and tosoth maybe can too and we can compare what package is the cause. Unfortunately i cannot provide list of packages from my previous (buggy) installation - i haven't backed up my var directory.

ilia_2s (ilia-2s) said : #11

hi all. I have this problem also. I create new user with administrative rights and login but however network-admin and some else can't be unlocked. froom root it works fine. but from my user I get an "authority error".

And this in console

teddy@PLUTON:~$ sudo network-admin
[sudo] password for teddy:
(network-admin:9075): Gtk-WARNING **: Unknown property: GtkComboBox.items
** (network-admin:9075): CRITICAL **: Unable to lookup session information for process '9075'

I can write my list of install packages.

Sam_ (and-sam) said : #12

Hi,
the advice from Tim Jarvid solved the problem for good here.
Opening the main menu with a right click -> edit menus and right click on network in system administration, the command looks like "gksu network-admin", remove >gksu<, so it has only "network-admin" in the command. Close and done.
https://bugs.launchpad.net/ubuntu/+source/gnome-system-tools/+bug/227383/comments/20

voilsb (brian-voils) said : #13

I'm having the exact same problem as ilia_2s / teddy. I'm trying to work around it through config files, but unfortunately *all* the documentation assumes you're using gnome and all the gui tools work fine, so it's a slow process.

blub (blub-immortux) said : #14

I had exact the same problem after I have copied my ubuntu to a new harddisc.
Fixed it with the reinstallation of dbus -> but no idea why this was broken...

apt-get install --reinstall dbus

regards...

Can you help with this problem?

Provide an answer of your own, or ask tosoth for more information if necessary.

To post a message you must log in.