how do you find admin rights ubuntu 10.10?

Asked by lezlow111 on 2011-01-18

is this a bug?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-system-tools Edit question
Assignee:
No assignee Edit question
Last query:
2011-01-19
Last reply:
2011-01-20

This question was originally filed as bug #704704.

Micah Gersten (micahg) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug. There is also a vibrant support community available at http://askubuntu.com and you might consider asking your question there.

Sam_ (and-sam) said : #2

User needs to be in 'admin' group.
To find out, open a terminal and type:
groups

If 'admin' is listed, then you can type for example:
sudo apt-get update
## password for user_name: ...

You won't see anything, e.g. starts or alike, while typing the password, but it'll be recognized.

Make sure to start GUI applications with 'gksudo' not with 'sudo' e.g.:
gksudo gedit

Reference.
https://help.ubuntu.com/community/GnomeTerminal

If Sam's answer doesn't help, then you'll need to tell us specifically what you are trying to do, what you have tried so far (if anything), and what happened in response to each of your attempts.

If you mean to ask about for an easy way to change which users are permitted to administer the system, try users-admin (System > Administration > Users and Groups).

lezlow111 (lezlow111) said : #4

well i,m shocked ?i asked a question and you all go around the world? when i try to do something in ubuntu 10.10 it denies access and states you dont have admin rights? i know where admin right are in all the other ubuntu,s [under admin] there not there in 10.10

Sam_ (and-sam) said : #5

First question was how to find admin rights.
Answer was to verify if user is in admin group.
Are you in admin group?

Ubuntu doesn't deny access just out of the blue or without active interference of user.
Without information which changes and steps have been made before and after the issue occured it's like throwing darts.

lezlow111 (lezlow111) said : #6

why are you all still producing new ubuntu,s when the old ones still have issues? which are not solved,you answer an issue and it does,nt work? i brought issues up with 10.04 and that didn,t work,the answered didn,t work so i reverted back to ubuntu 9.10? now you,ve issued ubuntu 10.10 and i can,t gain admin rights? it says i am adminestrator,but i cant load to a pendrive? as it says i,m not the adminestrator,how can i distribute crap like this free to people? your all trying to run before you can walk, lets go back to ubuntu 9.10 which works good enough and improove it before trying peoples patience,and i do ppreciate ubuntu <email address hidden>

You still need to explain in detail what you are trying to do, what you have done so far, and what behavior (including any error messages) you have received in response to what you have attempted.

Your complaints are very general. It is impossible for anyone to help you so far, because you have not provided much information about the problem (or problems) that you are experiencing.

Phrases that make sense to you sometimes may not make sense to others. It was unclear what you meant by "find admin rights", and to an extent still is. For example, is your problem that you are not an administrator (i.e. not a member of the "admin" group), or that you are an administrator but you still cannot perform administrative actions, or is your problem something else altogether? Likewise, the term "load to a pendrive" is not clear. There are numerous things that could mean. Are you unable to use USB flash drives in any manner? Are you able to read them but not write to them? Are you able to read from and write to them, but unable to format them? Or are you able to read and write to them, and to format them, but unable to read and write to them *after* you have formatted them? Or are you trying to *install* Ubuntu so that it *runs* from a USB flash drive, and that's what's not working? If that's what's not working, is it that you can't install it to the flash drive, that it doesn't run properly once installed to a flash drive, or that it installs and runs properly but changes you make to the system on the flash drive when running it disappear when you reboot the computer? Or perhaps "i cant load to a pendrive" means something different from all these possibilities. You know what it means, but we can only guess.

It is not your fault if you don't know what things are called, and no one would blame you for that, but if you are unable or unwilling to describe your situation in detail, then there is nothing anyone can do for you.

As for us all going "around the world" -- perhaps an explanation of what has happened so far in this Question would help you to better understand the responses you've received.

First you filed a bug report, but your bug report didn't identify any specific problem, and was highly indicative of a support request. So Micah Gersten converted it from a Bug into a Question. After it was converted into a Question, Sam responded by telling you how to determine if a user on an Ubuntu system is an administrator, which was the most reasonable interpretation of your question. Given that your question was vague, it occurred to me that this answer might not fully address whatever issue you were having, so I commented, explaining that you would need to provide more information if Sam's answer didn't help you.

Then you replied, expressing your disapproval of all the people who tried to help you so far; your reply was worded in such a way as to suggest that you believe that we should all have known what you meant. Your reply provided some information, but not very much, and you did not indicate specific steps that you had taken, as I had said you'd have to do if you needed further assistance. Sam replied, reiterating the need for you to provide more specific information, but while you have since replied, you have still not provided it.

We still cannot help you, based on what you have said so far. For example, you have still not clearly answered the question of whether or not you are a member of the "admin" group (i.e. an administrator) on your Ubuntu system. Or, to be precise, you *have* answered that question, but you have answered it with contradictory information: "it says i am adminestrator,but i cant load to a pendrive? as it says i,m not the adminestrator,how can i distribute crap like this free to people?" This answer is also not specific. *What* says you are an administrator? *What* says you aren't? If you don't know what some part of Ubuntu is called, that is OK; in that case, though, you will have to describe how you got to the point where "it" told you something, what it looked like, what else it said (if anything), and what its *exact* words were.

What follows is an example of indicating specific steps. I am not saying that this describes *your* issue (in fact that is very unlikely)--it's just an example of the *kind* of information we need you to tell us, in order for us to help you:
'I wanted to configure Ubuntu to download and install security updates automatically, so I went into the update manager and clicked Settings. But instead of bringing up the settings window, and without even asking me for my password, it displayed a message box with no text in its title bar, with the message: "Failed to run /usr/bin/software-properties-gtk '--open-tab' '2' '--toplevel' '44040195' as user root. Unable to copy the user's Xauthorization file." I clicked Close in the message box, and it was as if I had never clicked on Settings.'

Can you help with this problem?

Provide an answer of your own, or ask lezlow111 for more information if necessary.

To post a message you must log in.