How to create a user who can't make wireless connections

Asked by Scot Becker on 2010-09-23

Is there a way to create a user who does not have permission to initiate or create a wireless/ethernet/modem connection?

In System > Administration > Users and Groups > [username] > Advanced Settings > User Privileges, it appears that you are able to control whether a new user can have permission to "Connect to wireless and ethernet networks" or not. The setting doesn't work. To Test: Create a 'Desktop User' without this permission. Log out. Log back in as new user, and you will still be able to use the network manager just as an Admin could. This is apparently an artifact of the transition from old style unix groups to policykit and is reported as a bug here:

https://bugs.launchpad.net/ubuntu/+source/gnome-system-tools/+bug/326135

I have tried in Ubuntu 10.4 and an updated 10.10 beta.

According to the bug report, these options change the groups the user is a member of, but that is simply not respected by Network Manager. Anyone have any advice on how to either (1) create a user whose privilege limitations Network Manager will respect or (2) make Network Manager respect Unix group membership?

If this is not the place to ask this, I'll happily go elsewhere. I post it here since it results from the above bug which is posted here in gnome-system-tools.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-system-tools Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2010-09-23
Last query:
2010-09-23
Last reply:
2010-09-23
Scot Becker (scot-becker) said : #1

What I've learned so far: It's not a matter of creating a certain kind of user as much as getting the PolicyKit-1 settings right for network manager.

Best Sam_ (and-sam) said : #2

> not have permission to initiate or create

Depends how advanced the user is. In the meantime I'd say remove all menu entries, disable applets, chmod, chown files.
Maybe modify the script to your needs.
http://ubuntuforums.org/showthread.php?t=53239
Other ideas.
http://www.ubuntugeek.com/disable-internet-access-for-particular-user-in-ubuntu.html
http://ubuntuforums.org/showthread.php?t=493427

Although this one was before Intrepid, but maybe it helps.
https://help.ubuntu.com/community/NetworkManager#Disabling%20NetworkManager

> getting the PolicyKit-1 settings right for network manager
http://hal.freedesktop.org/docs/PolicyKit/
https://help.ubuntu.com/community/WifiDocs
https://help.ubuntu.com/community/NetworkConfigurationCommandLine

Scot Becker (scot-becker) said : #3

Thanks for the effort. I should be able to make something out of all that.