system monitor not displaying dual core

Asked by Craig Cornwall on 2007-11-14

I have just applied the 7.10 upgrade & now the system-monitor only displays 1 cpu. Previously the monitor displayed 2 cpus (Athlon 64 dual core). Otherwise the upgrade is great. Sorry if this is obvious. I am fairly new to this.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-system-monitor Edit question
Assignee:
No assignee Edit question
Solved by:
Albert Damen
Solved:
2007-12-28
Last query:
2007-12-28
Last reply:
2007-11-14
Best Albert Damen (albrt) said : #1

This may be caused if you are running a -386 kernel instead of a -generic kernel.
To see which kernel is running, open a terminal window and type the command:
$ uname -r
Please paste the output of this command here.

If the result ends with -386, you are using a kernel that cannot handle two cpu's or dual core processors. You will then need to install a -generic kernel and reboot using the new kernel. To do this, open synaptic (in menu, choose system --> Administration --> Synaptic Package Manager) and install the package linux-generic.
After the package is installed, reboot your system. At the beginning of the reboot, you will see the grub menu (you my need to press escape if you only see a counter counting down). Here make sure you select the kernel with -generic in it's name.
After you rebooted, use the command uname -r again to see if you are now running the -generic kernel (it should now say 2.6.22-14-generic). Now system-monitor should show two cpu's again.

Craig Cornwall (craigcor) said : #2

albert

Thanks for the help - this solved the dual core problem but using the 2.6.22-14-generic package I have now lost my nvidia customisation including my 1440x900 screen resolution and desktop effects.

craig

Craig Cornwall (craigcor) said : #3

Thanks albert, that solved my question.

nicholas zaghi (nickzaghi) said : #4

ok, I'd like to bring this issue back to life

I have the same problem on Lucid 10.04, only I am using the generic kernel..

Any help would be great..

I have an Amilo with a dual 1.8ghz CPU, however it only shows a single 1.6ghz CPU