cannot start gnome-system-monitor any more, top says: gnome-system-mo <defunct>

Asked by Dirk Bundies on 2011-08-24

Hi Folks,

on my ubuntu natty 11.04 i cannot start gnome-system-monitor any more. Top says: "gnome-system-mo <defunct>".
If I try to start it from the console, I get:
 dirk@DirksX61T:~$ gnome-system-monitor

 ** (gnome-system-monitor:18850): WARNING **: SELinux was found but is not enabled.

Thanks in advance for any hints,

Dirk

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-system-monitor Edit question
Assignee:
No assignee Edit question
Solved by:
Dirk Bundies
Solved:
2011-08-26
Last query:
2011-08-26
Last reply:
2011-08-24
enubuntu (mr.tennents) said : #1

Hi try to do this in terminal:
sudo apt-get purge gnome-system-monitor
sudo apt-get install gnome-system-monitor

then start it.

Dirk Bundies (dirk-bundies) said : #2

Hello Enrico,

thanks a lot for your quick reply, but: still no luck. Same symptoms.

Dirk Bundies (dirk-bundies) said : #3

Hey guys,

don't know why, but today it is working again!?

thanks & bye

Dirk Bundies (dirk-bundies) said : #4

I had a similar symptom with evince. But now I'va caught the reason.

Symptom
- evince starts when I want to open a PDF file. The window appears but becomes grey. After minutes (!) it shows the PDF. Similar symptoms with nautilus.

Reason
- a day before I had some gvfs connections and today I'm working in another network so they are still mounted but not accessible any more

Solution
- unmount connections. Afterwards everything works fine.