GNOME Shell Compilation Syntax Error

Asked by shekhar on 2009-12-28

Hi

I want to compile GNome Shell 3.0 but after running the setup script I get the following error:

shekhar@shekhar-laptop:~$ curl -O http://git.gnome.org/cgit/gnome-shell/plain/tools/build/gnome-shell-build-setup.sh
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 371 100 371 0 0 36 0 0:00:10 0:00:10 --:--:-- 1081
shekhar@shekhar-laptop:~$ /bin/bash gnome-shell-build-setup.sh
gnome-shell-build-setup.sh: line 1: syntax error near unexpected token `newline'
gnome-shell-build-setup.sh: line 1: `<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">'n

I have installed and updated all the dependencies:

shekhar@shekhar-laptop:~$ sudo apt-get install curl libgstreamer0.10-dev libcroco3-dev xserver-xephyr xulrunner-dev python-dev mesa-common-dev libreadline5-dev libgl1-mesa-dev libwnck-dev librsvg2-dev libgnome-desktop-dev libgnome-menu-dev libffi-dev libgtk2.0-dev libgconf2-dev libdbus-glib-1-dev gtk-doc-tools gnome-common git-core flex bison automake build-essential

Can anybody please tell me How to fix it?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Last query:
2009-12-28
Last reply:
2009-12-28
Appiah (appiah) said : #1

1) Try to wget the script file : wget http://git.gnome.org/cgit/gnome-shell/plain/tools/build/gnome-shell-build-setup.sh
2) type chmod +x gnome-shell-build-setup.sh
3) ./gnome-shell-build-setup.sh

same error?

Try the PPA
https://launchpad.net/~vperetokin/+archive/unofficial-gnome-shell

maybe there's more PPA's

shekhar (shekhar-sharmaa) said : #2

No This is Not working.Same error is popping up.

Can you help with this problem?

Provide an answer of your own, or ask shekhar for more information if necessary.

To post a message you must log in.