Debug symbols out of date?

Asked by Bram Stolk on 2019-03-12

I am using bionic updates repository, and I can't install the debug symbols for gnome-shell.

Is gnome-shell-dbgsym out of date, perhaps?

gnome-shell-dbgsym : Depends: gnome-shell (= 3.28.3+git20190124-0ubuntu18.04.1) but 3.28.3-0ubuntu0.18.04.4 is to be installed
E: Unable to correct problems, you have held broken packages.

More info: https://stackoverflow.com/questions/55129053/how-to-install-debug-symbols-for-gnome-shell-package

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Solved by:
Bram Stolk
Solved:
2019-03-13
Last query:
2019-03-13
Last reply:
2019-03-13

What is the output of:
lsb_release - a; uname -a; apt-cache policy gnome-shell-dbgsym gnome-shell

Thanks

Bram Stolk (b-stolk) said : #2

$ lsb_release - a; uname -a; apt-cache policy gnome-shell-dbgsym gnome-shell
Usage: lsb_release [options]

lsb_release: error: No arguments are permitted
Linux ubuntupc 4.15.0-46-generic #49-Ubuntu SMP Wed Feb 6 09:33:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
gnome-shell-dbgsym:
  Installed: (none)
  Candidate: 3.28.3+git20190124-0ubuntu18.04.1
  Version table:
     3.28.3+git20190124-0ubuntu18.04.1 500
        500 http://ddebs.ubuntu.com bionic-proposed/main amd64 Packages
     3.28.3-0ubuntu0.18.04.4 500
        500 http://ddebs.ubuntu.com bionic-updates/main amd64 Packages
     3.28.1-0ubuntu2 500
        500 http://ddebs.ubuntu.com bionic/main amd64 Packages
gnome-shell:
  Installed: 3.28.3-0ubuntu0.18.04.4
  Candidate: 3.28.3-0ubuntu0.18.04.4
  Version table:
 *** 3.28.3-0ubuntu0.18.04.4 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.28.1-0ubuntu2 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Bram Stolk (b-stolk) said : #3

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

Thanks for correcting my typo. I suggest you report a bug to get the packages brought in line

Bram Stolk (b-stolk) said : #5

This was due to a mis-configured system. My apologies.