gnome-shell collapses caused by screenshot

Asked by Marzy on 2012-09-19

Today when I was visiting a website and wanted to take a screenshot, I pressed Shift+Print Screen. Then I changed my mind and right-clicked the mouse to cancel the screenshot. After I did this, however, the gnome-shell collapsed and there came out a notification asking me to send messages to ubuntu. A moment later the gnome-shell restarted again. So I tried again the operations described above and the same thing happened, except that gnome-shell didn't restart at this time. What was worse, I couldn't input via my keyboard any more! That means I couldn't restart my computer in the terminal. So I used tty2 to restart and reported the problem here, wondering if this is a bug? Or the conflict with other programs? The distribution I use is Ubuntu 12.04.1, and the gnome-shell's version is 3.4.1.

Hope my messages do some help. Thank you for reading!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-19
Last reply:
2012-09-19

Try scrot or imagemagick at CLI with:

import ~/Screenshot.png

Sounds like a bug to me

Marzy (marzy-ya) said : #2

I'm sorry that I'm a freshman here and I don't know how to reply a user. These are words replied to actionparsnip (andrew-woodhead666):
Is the command you mentioned a way to take a full screenshot? I have tried the command at the terminal and it asked me to install imagemagick. If the command is just for a screenshot, it's totally unnecessary as the screenshot I'm using is enough, ignoring the unusual phenomenon I can hardly meet in daily use. If not, what should I do then? I don't quite understand CLI although I had google for it, and I don't know whether the terminal at ubuntu is a part of it.

Whatever, thank you for your answer. XD

Can you help with this problem?

Provide an answer of your own, or ask Marzy for more information if necessary.

To post a message you must log in.