when I log in to m y root user account, from the gnome 2 shell. it just hangs, but other user accounts log in just fine.

Asked by Mark Jones on 2012-04-30

When I come to the login screen, with its list of users, I select "other" and type "root" and then give the password, nothing happens. All the other users accounts I can log into without any problem. I am using Gnome 2 (gnome 2 fallback session) with ubuntu 12.04 precise. I can use su root ok though, in another users desktop from a terminal. And why does Appearances not give me the faciltiy to download and install new Gnome Art themes any more? Are the two problems connected? Any help would be appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-30
Last reply:
2012-05-01

That's because the OS is not designed to be logged in as root to the desktop, nor is it needed. I suggest you stick to how it is designed and use sudo. Nobody has a single issue with it and you are not restricted in any way with it

Mark Jones (mark-jones-prom) said : #2

Thanks actionparsnip, that solved my question.

Mark Jones (mark-jones-prom) said : #3

I have always been able to log in as root on the desktop before - until I upgraded to 12.04. Besdies which there is some data I cannot access just by using su root. I have a root directory with data in, and also links and bookmarks for Firefox etc so if anyone can help me to recover my root account I would be grateful.

You can use:

sudo -i

And become root, the account can then remain disabled and secure.

Mark,

I had the same problem. Here is the way to restore the functionality lost by upgrading to 12.04.

Open Terminal (Dash home>More Apps>Installed (Expand)>Terminal)

TO ACTIVATE THE ROOT ACCOUNT
In terminal type or paste: <sudo passwd root> (without the brackets)
Enter your normal login password, then you will be asked to enter the new root password and confirm it.

TO ADD A NEW LOGIN PROMPT THAT ALLOWS YOU TO ENTER ROOT & IT'S PASSWORD
In terminal type or paste: <gksudo gedit /etc/lightdm/lightdm.conf> (without the brackets)

Add the line: <greeter-show-manual-login=true> (without the brackets) to the bottom of the file.
The file should read as follows:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
greeter-show-manual-login=true

Save the lightdm.conf file and exit from gedit

Reboot Ubuntu 12.04 and you will see a new “Login” window (replaces the previous "Other" window) which allows for Username and Password input . Enter “root” for the user name and then enter the password you assigned to the root account.

Can you help with this problem?

Provide an answer of your own, or ask Mark Jones for more information if necessary.

To post a message you must log in.