How To install “Auto Hide Top Panel” extension

Asked by Tong Sun on 2012-04-24

Hi,

I am having a hard time trying to find out exactly how to install “Auto Hide Top Panel” extension.

Most sites just merely say *install* the Auto Hide Top Panel extension, but never get into detail onto *how*.
The only site that I found saying how is
http://techhamlet.com/2011/12/auto-hide-the-top-gnome-panel/

With the new Shell Extension website, installing and managing shell extensions have become much more easier!

    * First, go to this page : https://extensions.gnome.org/extension/42/auto-hide-top-panel/
    * Next, click on the “Off” switch and turn it to “On” (Located near the title)
    * Next, it will ask you whether to install the plugin or not :
    * Hit

But I found it is not the case at all.

Any one has actually done the actual installation of the Auto Hide Top Panel extension?

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-01
Last reply:
2012-06-01
Tong Sun (suntong001) said : #1

Ubuntu 11.10 (Oneiric Ocelot)

samuel (samuel-h) said : #2

Make sure you do this using firefox with the gnome-shell intergration add-on enabled, this will not work on other browsers, or if you have removed or disabled the addon with firefox, if you have got both of these things then I have no idea what is wrong, as I have never experienced any problems installing shell extension's (it has been as simple for me as the quote you posted), the final thing that I suppose you could try is installing the package gome-tweak-tool run the command sudo apt-get install gnome-tweak-tool, or search it in software center. Now you will need to download the file for the shell extension (just search it on google). Then, in your programs, search for advanced settings, (although the package is called gnome-tweak-tool, the program it installs is named advanced settings). and start the program, go to the extensions tab in the side and click the install extension from file, now navigate to the file you downloaded and click ok, and hopefully it should work :)

Tong Sun (suntong001) said : #3

"Make sure you do this using firefox with the gnome-shell intergration add-on enabled, this will not work on other browsers"

Thanks, that's the missing piece for me. I was going down the installing gnome-tweak-tool route, and was able to "go to the extensions tab", but there is no "install extension from file" for me to click. Actually the whole tab is blank, nothing in and nothing to click.

Will try the firefox add-on route...

Thanks

Tong Sun (suntong001) said : #4

"Will try the firefox add-on route..."

Didn't find the firefox add-on

https://addons.mozilla.org/en-US/firefox/search/?q=gnome-shell+integration&appver=11.0&platform=linux

please help. Thx

samuel (samuel-h) said : #5

firefox on ubuntu should come with the extension pre-installed, so that is weird. Also if the tab was blank that means you are running the defualt ubuntu ui (unity), gnome-classic, or another user interface, gnome shell extension only work when using gnome shell (when you login click the cog by your name and select gnome, if that doesn't appear, search GNOME Shell in software center, and now it will appear when you click the cog, and you will be able to use shell extensions (gnome shell does look different to the default interface though, and I don't know how to auto hide the top panel on that interface))

Tong Sun (suntong001) said : #6

Hm...

This is getting far more complicated than I thought. So, some background,

First, I installed the gnome-session-fallback to return to "Gnome Classic", (then removed unity-2d unity-2d-launcher unity-2d-panel unity-2d-places unity-2d-spread). Having found that I was not able to auto hide the Top Panel, I searched for the answer myself and installed gnome-shell (and gnome-tweak-tool), and tried log into "Gnome" instead of "Gnome Classic".

Bottom line, all that I wanted to do is to auto hide the Top Panel. What's the easiest way to do?

Thanks

Tong Sun (suntong001) said : #7

Confirmed that the extension is pre-installed on my ubuntu firefox,

However, I can't visit any of the following page:

https://extensions.gnome.org/extension/42/auto-hide-top-panel/
https://extensions.gnome.org/extension/42/auto-hide-top-panel
https://extensions.gnome.org/extension/42/
https://extensions.gnome.org/extension/42

The only place that I can download the Auto Hide Top Panel extension is from
http://fpmurphy.com/gnome-shell-extensions
which is a tar.gz file that is not recognized by the pre-installed firefox extension.

samuel (samuel-h) said : #8

you can't visit the page because it doesn't exist (so it's not a problem at your end, I can't visit that page either), sorry that I took a while getting back to you, try this page
https://extensions.gnome.org/extension/42/auto-hide-top-panel/version/99/

Tong Sun (suntong001) said : #9

NP.

I've been to that page as well. but didn't find where to click to install the extension.

samuel (samuel-h) said : #10

You must be logged into gnome shell to visit the page (to do this (as you probably already know) select gnome from cog dropdown menu at login), then visit the page and there should be an on/off switch to turn the extension on or off near the top left hand corner.

Sam_ (and-sam) said : #11

I don't use GS but there is a ppa which incl. auto-hide-top-panel. Hope it helps.
http://www.upubuntu.com/2012/05/collection-of-20-top-extensions-for.html

There is a video showing the install procedure from web page.
https://www.youtube.com/watch?gl=US&feature=player_embedded&v=Uci3E89wcqE

Tong Sun (suntong001) said : #12

Sorry for responding late. I knew that it would not a quick fix and it turns out true again.

OK,

First, I've confirmed that I log into gnome shell (select gnome from cog dropdown menu before login), then visit https://extensions.gnome.org/extension/42/auto-hide-top-panel/version/99/ with the firefox, but I still can't see that
on/off switch to turn the extension on or off near the top left hand corner.

How can I verify that I've indeed log into gnome shell?

Second, the ppa which incl. auto-hide-top-panel is for 12.04 only. I get

Failed to fetch http://ppa.launchpad.net/upubuntu-com/ext/ubuntu/dists/oneiric/main/source/Sources 404 Not Found

Sam_ (and-sam) said : #13

Sorry, overlooked that you still run 11.10.
That's Gnome 3.2 and I'm not sure if shell-extension work there. Precise and Quantal already run with 3.4.
The ppa only offers 12.04.
https://launchpad.net/~upubuntu-com/+archive/ext

> verify that I've indeed log into gnome shell?

The dm menu should offer gnome-shell as option.
http://3.bp.blogspot.com/-2Z6BaRDokKs/T5pFnOu92sI/AAAAAAAADtg/bD8BAJuEh5M/s320/Gnome-Shell-session-menu.png

Other than that gnome-shell looks pretty different from other shells [http://www.gnome.org/gnome-3/] at least 'top' should display the process.

When sorted by name I don't see an extension called autohide-panel or similar.
https://extensions.gnome.org/#sort=name&page=2

But there is an extension 'panel-settings' which offers an autohide option.
https://extensions.gnome.org/extension/208/panel-settings/

Tong Sun (suntong001) said : #14

thanks a lot Sam, will get back to you later...

Can you help with this problem?

Provide an answer of your own, or ask Tong Sun for more information if necessary.

To post a message you must log in.