Easy to loose copy dialog

Asked by tazr42 on 2011-11-11

I've found that when I'm copying any files in Gnome-shell that the copy dialog is very easy to loose.

By that I mean that if you bring another application on top of the copy dialog, either by the activities overlay or any other method, it is then remarkably difficult to find the copy dialog again as it's now behind the new application. This is especially true when there are many applications open.
I find that when I have a copy running, I have to move each application to a corner (careful it doesn't sideways maximize) to reveal the center of the desktop.

Why it's difficult:
Copy dialog doesn't appear in Alt+Tab menu
Copy dialog doesn't appear in Activities overlay
Copy icon from Gnome2 doesn't exist
As there's no minimize buttons, it's hard to move the existing windows out of the way

What I'd expect (in order):
A copy notification as in Gnome 2 to allow me to see a copy is still in progress and to bring it to focus.
It to exist in Activities overlay
It to exist in alt+tab menu.

I've tried multiple systems and seen this issue on all, but they're all running:
Gnome-shell-3.2.0 or 3.2.1
Ubuntu 11.10 (clean install)
Nautilus

I've tried it on Fedora 16 and it appears in the Activities overlay.

Am I correct in saying this is a usability bug?

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-11
Last reply:
2011-12-08

I recommend you report a bug

Peter BaĊĦista (pbasista) said : #2

This has been reported and fixed some weeks ago. See bug #868032.

Monico Dolor (monico-francis) said : #3

Hi, there is another alternative that you can do in order to handle this problem. Sometimes patches are related to the desktop version that you use and from what I got is that implementing Cairo Dock has this function to see all process that Nautilus file manager is doing. You can try this out if you are not comfortable with the patch mentioned in the bug fix above..

Can you help with this problem?

Provide an answer of your own, or ask tazr42 for more information if necessary.

To post a message you must log in.