Gnome Shell won't load properly - Ubuntu 11.10

Asked by Kris Livermore on 2011-10-18

After installing Gnome Shell, I wanted to test it out. However, after logging in, I can't seem to click on anything, the system clock seems frozen etc. From playing around with it for a few days and trying different things, it seems like programs are still running in the background, it's just the display that 'freezes'.

I'm not really sure what's causing the problem. If it was my graphics card, wouldn't it just go into the fallback?

What really gets me is; I can load a Live USB of OpenSUSE running Gnome 3/Gnome Shell by default and it runs without any of the above issues.

Laptop basic specs:
Intel Core 2 T5600 @ 1.83 GHz x2
2 GB of Memory
Nvidia GeForce Go 7400 with 285.05.09 Driver version

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Solved by:
Kris Livermore
Solved:
2011-10-18
Last query:
2011-10-18
Last reply:
Kris Livermore (kazarsanaga) said : #1

So I decided to look into the Nouveau drivers. I noticed that they were already on the system so I installed the firmware package from the software center and then removed my proprietary Nvidia driver using jockey-gtk.

I restarted and first tried Ubuntu Unity, it refused to load. Then I attempted gnome shell, and.. somehow it's working. I'm not sure how to tell if nouveau drivers are in use. The Compiz fusion icon says "Indirect Rendering".

I'm glad that it's gnome shell is working now, but I need someway to monitor my GPU temp since this laptop gets hot.

Kris Livermore (kazarsanaga) said : #2

Alright, so I found out that the nouveau drivers did kick in because under my temp monitor the GPU sensor is listed under nouveau-pci-0100.

I guess I'll mark this as solved.