Installing gnome 3

Asked by Chethan S. on 2010-09-25

Today I watched a video about GNOME 3.0 on YouTube and wanted to install it on ubuntu 10.04. But when I proceed to install gnome-shell I get an error about the xulrunner dependency. I searched on web and found that adding some ritcoz ppa helps but it resulted in same error. The command executed by me and the output is given below. Can anyone suggest a solution.

chethan@chethan-desktop:~$ sudo aptitude install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  libgjs0
The following NEW packages will be installed:
  gir1.0-atk-1.0{a} gir1.0-clutter-1.0{a} gir1.0-freedesktop{a}
  gir1.0-glib-2.0{a} gir1.0-gtk-2.0{a} gir1.0-mutter-2.28{a}
  gir1.0-pango-1.0{a} gnome-shell xserver-xephyr{a}
0 packages upgraded, 10 newly installed, 0 to remove and 22 not upgraded.
Need to get 3,370kB of archives. After unpacking 7,721kB will be used.
The following packages have unmet dependencies:
  libgjs0: Depends: xulrunner-1.9.2 (<= 1.9.2.9~) but 1.9.2.10+build1+nobinonly-0ubuntu0.10.04.1 is installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
gnome-shell [Not Installed]
libgjs0 [Not Installed]

Score is -9868

Accept this solution? [Y/n/q/?]

I answered Y as I did not want to face problems later.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-25
Last reply:
2010-09-25

Can you help with this problem?

Provide an answer of your own, or ask Chethan S. for more information if necessary.

To post a message you must log in.