The following packages have unmet dependencies: gnome-shell: Depends: libgjs0 but it is not going to be installed

Asked by Gonzalo Castro on 2010-09-15

attempting "sudo apt-get install gnome-shell"
output;
$ sudo apt-get install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnome-shell: Depends: libgjs0 but it is not going to be installed
E: Broken packages

Followed instructions from https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure
This did not resolve the issue.
Synaptic Package Manager does not list any broken packages.

Output:

timf@timf-desktop:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"
timf@timf-desktop:~$ uname -a
Linux timf-desktop 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:24:04 UTC 2010 i686 GNU/Linux
timf@timf-desktop:~$ sudo rm /var/lib/apt/lists/lock
timf@timf-desktop:~$ sudo rm /var/lib/apt/lists/lock
rm: cannot remove `/var/lib/apt/lists/lock': No such file or directory
timf@timf-desktop:~$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
timf@timf-desktop:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
timf@timf-desktop:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
timf@timf-desktop:~$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/availabletimf@timf-desktop:~$ sudo rm -rf /var/lib/dpkg/updates/*
timf@timf-desktop:~$ sudo rm -rf /var/lib/apt/lists
timf@timf-desktop:~$ sudo mkdir /var/lib/apt/lists
timf@timf-desktop:~$ sudo mkdir /var/lib/apt/lists/partial
timf@timf-desktop:~$ sudo rm /var/cache/apt/*.bin
timf@timf-desktop:~$ LANG=C;sudo apt-get clean
timf@timf-desktop:~$ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
timf@timf-desktop:~$ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
18 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up tzdata-java (2010l-0ubuntu0.10.04) ...
Setting up java-common (0.34) ...
Setting up gstreamer0.10-pitfdll (0.9.1.1+cvs20080215-1ubuntu2) ...
Setting up gstreamer0.10-plugins-ugly-multiverse (0.10.14-0ubuntu2) ...
Setting up libavutil-extra-49 (4:0.5.1-1ubuntu1) ...

Setting up libopenjpeg2 (1.3+dfsg-4) ...

Setting up libavcodec-extra-52 (4:0.5.1-1ubuntu1) ...

Setting up libmp4v2-0 (1:1.6dfsg-0.2ubuntu8) ...

Setting up ubuntu-restricted-extras (39) ...
Setting up unrar (1:3.9.3-1) ...

Setting up openjdk-6-jre-lib (6b18-1.8.1-0ubuntu1) ...
Setting up openjdk-6-jre-headless (6b18-1.8.1-0ubuntu1) ...

Setting up libaccess-bridge-java (1.26.2-3) ...
Setting up libaccess-bridge-java-jni (1.26.2-3) ...

Setting up icedtea-6-jre-cacao (6b18-1.8.1-0ubuntu1) ...
Setting up ca-certificates-java (20100406ubuntu1) ...
creating /etc/ssl/certs/java/cacerts...
done.

Setting up openjdk-6-jre (6b18-1.8.1-0ubuntu1) ...

Setting up icedtea6-plugin (6b18-1.8.1-0ubuntu1) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for menu ...
timf@timf-desktop:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824
Get:1 http://mirror.peer1.net lucid Release.gpg [189B]
Get:2 http://archive.canonical.com lucid Release.gpg [198B]
Get:3 http://mirror.peer1.net lucid-updates Release.gpg [198B]
Get:4 http://mirror.peer1.net lucid-backports Release.gpg [189B]
Get:5 http://archive.canonical.com lucid Release [8215B]
Get:6 http://mirror.peer1.net lucid-security Release.gpg [198B]
Get:7 http://mirror.peer1.net lucid Release [57.2kB]
Get:8 http://archive.canonical.com lucid/partner Packages [11.5kB]
Get:9 http://mirror.peer1.net lucid-updates Release [44.7kB]
Get:10 http://mirror.peer1.net lucid-backports Release [32.5kB]
Get:11 http://mirror.peer1.net lucid-security Release [38.5kB]
Get:12 http://mirror.peer1.net lucid/main Packages [1386kB]
Get:13 http://mirror.peer1.net lucid/restricted Packages [6208B]
Get:14 http://mirror.peer1.net lucid/main Sources [659kB]
Get:15 http://mirror.peer1.net lucid/restricted Sources [3775B]
Get:16 http://mirror.peer1.net lucid/universe Packages [5448kB]
Get:17 http://mirror.peer1.net lucid/universe Sources [3165kB]
Get:18 http://mirror.peer1.net lucid/multiverse Packages [180kB]
Get:19 http://mirror.peer1.net lucid/multiverse Sources [119kB]
Get:20 http://mirror.peer1.net lucid-updates/main Packages [295kB]
Get:21 http://mirror.peer1.net lucid-updates/main Packages [295kB]
Get:22 http://mirror.peer1.net lucid-updates/restricted Packages [3252B]
Get:23 http://mirror.peer1.net lucid-updates/main Sources [119kB]
Get:24 http://mirror.peer1.net lucid-updates/restricted Sources [1439B]
Get:25 http://mirror.peer1.net lucid-updates/universe Packages [115kB]
Get:26 http://mirror.peer1.net lucid-updates/universe Sources [46.1kB]
Get:27 http://mirror.peer1.net lucid-updates/multiverse Packages [3771B]
Get:28 http://mirror.peer1.net lucid-updates/multiverse Sources [1715B]
Get:29 http://mirror.peer1.net lucid-backports/main Packages [7339B]
Get:30 http://mirror.peer1.net lucid-backports/restricted Packages [14B]
Get:31 http://mirror.peer1.net lucid-backports/universe Packages [24.6kB]
Get:32 http://mirror.peer1.net lucid-backports/multiverse Packages [1135B]
Get:33 http://mirror.peer1.net lucid-security/main Packages [71.1kB]
Get:34 http://mirror.peer1.net lucid-security/restricted Packages [14B]
Get:35 http://mirror.peer1.net lucid-security/main Sources [26.4kB]
Get:36 http://mirror.peer1.net lucid-security/restricted Sources [14B]
Get:37 http://mirror.peer1.net lucid-security/universe Packages [36.6kB]
Get:38 http://mirror.peer1.net lucid-security/universe Sources [9427B]
Get:39 http://mirror.peer1.net lucid-security/multiverse Packages [1998B]
Get:40 http://mirror.peer1.net lucid-security/multiverse Sources [656B]
Fetched 11.9MB in 1min 23s (142kB/s)
Reading package lists... Done
timf@timf-desktop:~$ sudo dpkg --clear-avail
timf@timf-desktop:~$ sudo dpkg --configure -a
timf@timf-desktop:~$ LANG=C;sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
timf@timf-desktop:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824 && sudo apt-get dist-upgrade
Get:1 http://mirror.peer1.net lucid Release.gpg [189B]
Hit http://archive.canonical.com lucid Release.gpg
Get:2 http://mirror.peer1.net lucid-updates Release.gpg [198B]
Get:3 http://mirror.peer1.net lucid-backports Release.gpg [189B]
Hit http://archive.canonical.com lucid Release
Get:4 http://mirror.peer1.net lucid-security Release.gpg [198B]
Get:5 http://mirror.peer1.net lucid Release [57.2kB]
Hit http://archive.canonical.com lucid/partner Packages
Get:6 http://mirror.peer1.net lucid-updates Release [44.7kB]
Get:7 http://mirror.peer1.net lucid-backports Release [32.5kB]
Get:8 http://mirror.peer1.net lucid-security Release [38.5kB]
Get:9 http://mirror.peer1.net lucid/main Packages [1386kB]
Get:10 http://mirror.peer1.net lucid/restricted Packages [6208B]
Get:11 http://mirror.peer1.net lucid/main Sources [659kB]
Get:12 http://mirror.peer1.net lucid/restricted Sources [3775B]
Get:13 http://mirror.peer1.net lucid/universe Packages [5448kB]
Get:14 http://mirror.peer1.net lucid/universe Sources [3165kB]
Get:15 http://mirror.peer1.net lucid/multiverse Packages [180kB]
Get:16 http://mirror.peer1.net lucid/multiverse Sources [119kB]
Get:17 http://mirror.peer1.net lucid-updates/main Packages [295kB]
Get:18 http://mirror.peer1.net lucid-updates/restricted Packages [3252B]
Get:19 http://mirror.peer1.net lucid-updates/main Sources [119kB]
Get:20 http://mirror.peer1.net lucid-updates/main Sources [119kB]
Get:21 http://mirror.peer1.net lucid-updates/restricted Sources [1439B]
Get:22 http://mirror.peer1.net lucid-updates/universe Packages [115kB]
Get:23 http://mirror.peer1.net lucid-updates/universe Sources [46.1kB]
Get:24 http://mirror.peer1.net lucid-updates/multiverse Packages [3771B]
Get:25 http://mirror.peer1.net lucid-updates/multiverse Sources [1715B]
Get:26 http://mirror.peer1.net lucid-backports/main Packages [7339B]
Get:27 http://mirror.peer1.net lucid-backports/restricted Packages [14B]
Get:28 http://mirror.peer1.net lucid-backports/universe Packages [24.6kB]
Get:29 http://mirror.peer1.net lucid-backports/multiverse Packages [1135B]
Get:30 http://mirror.peer1.net lucid-security/main Packages [71.1kB]
Get:31 http://mirror.peer1.net lucid-security/restricted Packages [14B]
Get:32 http://mirror.peer1.net lucid-security/main Sources [26.4kB]
Get:33 http://mirror.peer1.net lucid-security/restricted Sources [14B]
Get:34 http://mirror.peer1.net lucid-security/universe Packages [36.6kB]
Get:35 http://mirror.peer1.net lucid-security/universe Sources [9427B]
Get:36 http://mirror.peer1.net lucid-security/multiverse Packages [1998B]
Get:37 http://mirror.peer1.net lucid-security/multiverse Sources [656B]
Fetched 11.9MB in 1min 16s (156kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
timf@timf-desktop:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
timf@timf-desktop:~$ sudo apt-get install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnome-shell: Depends: libgjs0 but it is not going to be installed
E: Broken packages
timf@timf-desktop:~$ sudo apt-get clean
timf@timf-desktop:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
timf@timf-desktop:~$ sudo apt-get update
Get:1 http://mirror.peer1.net lucid Release.gpg [189B]
Hit http://archive.canonical.com lucid Release.gpg
Get:2 http://mirror.peer1.net lucid-updates Release.gpg [198B]
Get:3 http://mirror.peer1.net lucid-backports Release.gpg [189B]
Hit http://archive.canonical.com lucid Release
Get:4 http://mirror.peer1.net lucid-security Release.gpg [198B]
Hit http://archive.canonical.com lucid/partner Packages
Get:5 http://mirror.peer1.net lucid Release [57.2kB]
Get:6 http://mirror.peer1.net lucid-updates Release [44.7kB]
Get:7 http://mirror.peer1.net lucid-backports Release [32.5kB]
Get:8 http://mirror.peer1.net lucid-security Release [38.5kB]
Get:9 http://mirror.peer1.net lucid/main Packages [1386kB]
Get:10 http://mirror.peer1.net lucid/restricted Packages [6208B]
Get:11 http://mirror.peer1.net lucid/main Sources [659kB]
Get:12 http://mirror.peer1.net lucid/restricted Sources [3775B]
Get:13 http://mirror.peer1.net lucid/universe Packages [5448kB]
Get:14 http://mirror.peer1.net lucid/universe Sources [3165kB]
Get:15 http://mirror.peer1.net lucid/multiverse Packages [180kB]
Get:16 http://mirror.peer1.net lucid/multiverse Sources [119kB]
Get:17 http://mirror.peer1.net lucid-updates/main Packages [295kB]
Get:18 http://mirror.peer1.net lucid-updates/main Packages [295kB]
Get:19 http://mirror.peer1.net lucid-updates/restricted Packages [3252B]
Get:20 http://mirror.peer1.net lucid-updates/main Sources [119kB]
Get:21 http://mirror.peer1.net lucid-updates/restricted Sources [1439B]
Get:22 http://mirror.peer1.net lucid-updates/universe Packages [115kB]
Get:23 http://mirror.peer1.net lucid-updates/universe Sources [46.1kB]
Get:24 http://mirror.peer1.net lucid-updates/multiverse Packages [3771B]
Get:25 http://mirror.peer1.net lucid-updates/multiverse Sources [1715B]
Get:26 http://mirror.peer1.net lucid-backports/main Packages [7339B]
Get:27 http://mirror.peer1.net lucid-backports/restricted Packages [14B]
Get:28 http://mirror.peer1.net lucid-backports/universe Packages [24.6kB]
Get:29 http://mirror.peer1.net lucid-backports/multiverse Packages [1135B]
Get:30 http://mirror.peer1.net lucid-security/main Packages [71.1kB]
Get:31 http://mirror.peer1.net lucid-security/restricted Packages [14B]
Get:32 http://mirror.peer1.net lucid-security/main Sources [26.4kB]
Get:33 http://mirror.peer1.net lucid-security/restricted Sources [14B]
Get:34 http://mirror.peer1.net lucid-security/universe Packages [36.6kB]
Get:35 http://mirror.peer1.net lucid-security/universe Sources [9427B]
Get:36 http://mirror.peer1.net lucid-security/multiverse Packages [1998B]
Get:37 http://mirror.peer1.net lucid-security/multiverse Sources [656B]
Fetched 11.9MB in 1min 20s (148kB/s)
Reading package lists... Done
timf@timf-desktop:~$ sudo apt-get install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnome-shell: Depends: libgjs0 but it is not going to be installed
E: Broken packages

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-shell Edit question
Assignee:
No assignee Edit question
Last query:
2010-09-15
Last reply:
2010-09-15

Please enable the 'proposed' repository to install gnome-shell and libgjs0 via the 'proposed' repo.

See following bugreports for details and possible solutions:

https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/509177

https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/555155

https://bugs.launchpad.net/ubuntu/+source/gjs/+bug/608940

Can you help with this problem?

Provide an answer of your own, or ask Gonzalo Castro for more information if necessary.

To post a message you must log in.