How to disable ubuntu-dock and revert to standard gnome shell configuration

Asked by J Cord on 2017-08-19

I would like to disable or remove the package Ubuntu dock package and revert to the standard gnome shell configuration which better suits my particular needs . How may I accomplish this ? Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-shell-extension-ubuntu-dock Edit question
Assignee:
No assignee Edit question
Solved by:
J Cord
Solved:
2017-08-24
Last query:
2017-08-24
Last reply:
2017-08-23

If you install gnome-shell then log off and log in to the new session in lightdm does the dock still run?

J Cord (j7cord) said : #2

This is Ubuntu 17.10 gnome-shell is the default desktop and prior to an update on or about Aug 18 2017 there was no Ubuntu-dock extension, i.e. the normal gnome-shell . I have tired what I can find to turn the dock off but nothing changes . GDM is now the default display manager on 17.10 so I am not understanding what you are suggesting I try. ???? I up'd to 17.10 due to a problem with gnome ubuntu 16.04 which had no current fix other than to move up to 17.10 , at least at the time ( 2 or 3 weeks ago) I thank you for your interest but I don't see how your suggestion applies.

Then I suggest you report a bug. Artful is not ready and not stable.

Francois Thirioux (fthx) said : #4

You can install the gnome-session package and select GNOME session (X or Wayland) in GDM to get a vanilla GNOME experience.
But just disabling ubuntu-dock without leaving all the other specific changes in ubuntu-session, that I don't know how to do it. Disabling the ubuntu-dock extension does nothing, the dock is still active.

J Cord (j7cord) said : #5

Thank You Francois. I will give your suggestion a try. I appreciate your time and effort to respond to my question.
I will wait until the stable release date and try 17.10 again with your suggestion.

Francois Thirioux (fthx) said : #6

Didier Roche from Ubuntu answered me in the French Ubuntu forum : you cannot disable Ubuntu specific extensions (Dock, Indicators) from GNOME Tweaks or any browser through the connector with the extensions website. The extension state on/off is not correctly read by GT or browser connector.

There is a simple solution if, like me, you prefer some Ubuntu settings (shell fonts, e.g.) : remove Dock and Indicators extensions from /usr/share/gnome-shell/extensions . But it has to be done again when any update is done.

J Cord (j7cord) said : #7

To Francois . My sincere thanks to you for the work-around above. I appreciate your assistance. I will save the instructions you provide and upon final release give it a try. I am not complaining about the dock itself, as I am sure most others will appreciate it, I just have a purpose for using gnome-shell that requires the standard experience. So, again many thanks for your help.