4 boot entries for ubuntu (as opposed to the usual 2)... and gnome settings daemon not starting... all this after failed upgrade to hardy

Asked by abilash0101

Binary package hint: gnome-settings-daemon

Hi all,
I think this will be a long report in my attempt to be detailed.. pls bear with me :-)
Also I searched for other bugs relating to gnome-settings-daemon not starting, but I felt none of them matched my case exactly… so I thought I’ll file a separate bug for something that looks so technical (at least, to me).

What Happened:
 0. I dual boot Ubuntu Gutsy and Windows XP
 1. I decided to upgrade my gutsy to hardy, fired up the update manager, installed most updates through the Update Manager.
 2. For reasons I don’t know, some (around 3) updates were disabled in the Update Manager … so I couldn’t select them though I could see them listed in the Update manager. So I selected them in Synaptic and updated them by marking them for updates.
 3. One of the disabled updates was linux-backports-modules upgrade to After I installed this update, the boot menu now has 4 options for Ubuntu:, (Recovery Mode), and (Recovery mode). My windows options, thankfully, have not been touched.
 4. Anyway, I booted into Gutsy and started the Upgrade to Hardy. The system then started fetching files... during which, it went to sleep a couple of times (due to inactivity) and failed to wake up. I had to use the power button to boot back into gutsy and continue the upgrade process.
 5. After all files were fetched, it started to install them. Unfortunately, when the system was still doing this, some emergency cropped up in my home and I had to switch my system off.. so I clicked on Shut Down.. still here? now this is the important point...
 6. I pulled the battery out of my laptop and in about 1 minute the battery came to near 0% and started beeping and then shut down !!! (I never know my battery had deteriorated to such an extent and that's why I had pulled the plug expecting the system will shut down without worrying abt he battery). I still don't know whether the laptop shut down properly or forcibly because of zero battery :-(
 7. The next day, I started my laptop to log into gutsy and finish the upgrade, expecting the upgrade to continue from where it left off.

 1. It takes longer than earlier for the boot menu (where I get to choose between Ubuntu and Windows) to appear.

 2. The boot menu now has 4 options for Ubuntu (instead of my usual 2)

 3. I can't log in properly !! Everytime I enter my username and password and press Enter, the following error message is shown:
     There was an error starting the Gnome Settings Daemon.
     Some things, like themes, sounds, or background settings may not work correctly.
     The last error message was:
     Failed to execute child process ”/usr/lib/gnome-settings-daemon/gnome-settings-daemon” (No such file or directory)
     GNOME will still try to restart the Settings Daemon next time you log in.

 4. It logs in after some time after this error is shown, and the system is very slow. The theme is not applied properly. It takes a lot of time to shut down, too.

I suspect that my Ubuntu system is part-gutsy and part-hardy now :-D because of the interrupted upgrade Also, what do I do with the 4 Ubuntu options? Someone please help... and I dont want to touch my Windows install in any way.

Question information

English Edit question
Ubuntu gnome-settings-daemon Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Chris Coulson (chrisccoulson) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Revision history for this message
Chris Coulson (chrisccoulson) said :


In response to your problems:

1. I'm not sure why this is, because GRUB is the first thing that loads after your BIOS has finished doing its stuff.

2. Thats normal. It is because you have installed an updated kernel. The older kernel has not been removed. You can remove it by uninstalling the older kernel, using Synaptic.

3. This is probably because you interrupted the upgrade by removing power. You could try fixing this by pressing CTRL+ALT+F1 to switch to a terminal, logging in and then running "sudo dpkg --configure -a".

4. See response to 3.

Revision history for this message
abilash0101 (abilash01) said :

Thanks! I tried the command sudo dpkg –configure –a. It asked if I wanted to keep the version I installed manually or upgrade to the version given by the provider. I chose upgrade. The system then (I think) started doing updating/upgrading/changing files. I saw some updates had their names ending with hardy… does it mean that somewhere something in my system thinks that the Ubuntu I have is hardy?

Anyway, it came to the login screen after that. Still, no luck... the gnome-settings-daemon error comes up even now. Also, now it doesn’t shut down properly. It shows some error about killswitch … ipw … That error keeps repeating, and no key works... not even Ctrl Alt Del. I’ll post the picture I took with my mobile.

I’m not one to give up so easily :-P so I restarted gutsy (GRUB still says 7.10), started update manager. It said “impossible to install or remove software” or something like that and asked me to use Synaptic or the command “sudo apt-get install –f”. I used it but soon came across an error message saying that something is missing/corrupted (don’t remember the exact error) I need to use “sudo dpkg --configure –a” first . I did it, but came across a lot of dependency errors like:

Dpkg: dependency problems prevent configuration of <package 1>:
<package 1> depends on <package 2>; however:
Package <package 2> is not configured yet.
(Attaching screenshot 2 for this)

By the way, after running ur command, the time to the boot (GRUB?) menu seems to load faster after powering on my laptop 
Will post screenshots shortly..

Revision history for this message
Thomas Kluyver (takluyver) said :

The dependency problems you mention could well be causing some of the other issues--some of the packages have failed to upgrade.

Because of the complex system of dependencies, a lot of errors may arise if one package fails to upgrade successfully (as each package that depends on that one then can't upgrade). Can you find which package "sudo dpkg --configure -a" first falls over on? If not, pipe the output to a file ("sudo dpkg --configure -a > somefilename.txt"), and post the file here.

Revision history for this message
abilash0101 (abilash01) said :

(guys, is thr a way to post screenshots here?? anyway i'll try to type whatever i saw)

hi... thx for ur reply..
it's working now (sort of). the dependency errors are gone.

i did a sudo apt-get -f install (note -f comes first now) and it worked .. at least to some extent. update-manager does not show "unmet dependencies" error. Thx for the lead on sudo dpkg --configure -a !

"sudo dpkg --configure -a" gives no error message (in fact it doesn't give any message :-P so I assume it's fine on that front)

but thr still are some issues like
1. the gnome-settings-daemon still comes up, but this time it says
"Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
2. screen resolution is now 800 x 600 (minor issue)
3. Some (Many?) things like Synaptic, nautilus wont start (it says starting administrative program but then disappears)
4. I can't see any files on my desktop (though I see them listed when I use ls command through terminal). No right-right clicking as far as I have tried.
5. Though they are listed when I use ls, I can't open with gnome-open (nothing happens)
6. Can't unlock (for e.g.) the network manager. It says "Could not authenticate." An unexpected error occurred.
7. It says hardy in system monitor but hardy software like firefox 3 are not installed. Yeah my system is truly part gutsy, part hardy now :-D

I think I am doing an overkill by putting so many issues in a single post (sorry :-( abt it )... 3, 4, 5 and 6 bother me the most

Revision history for this message
Thomas Kluyver (takluyver) said :

OK--if "sudo dpkg --configure -a" doesn't say anything, that means that all the packages its tried to install, it's managed to install. By the sounds of it, there are more that it should have tried to install.

Can you do:
sudo apt-get update
sudo apt-get upgrade

This should upgrade anything it still needs to. Then do "dpkg -l firefox" to see what versions it can see.

Revision history for this message
abilash0101 (abilash01) said :

do i need an internet connection to use the above 3 commands?

i'm not sure if i can connect to a net connection, given that i can't unlock into administrative mode to set my network up. anyway i'll try to break in to root mode (somehow) once i reach home today..

Revision history for this message
abilash0101 (abilash01) said :

i did dpkg -l firefox and it showed

some more progress... i fired up synaptic using sudo synaptic in terminal... then clicked on upgradable and then installed them all (including Firefox). i could install them without an internet connection as they all had been downloaded earlier before i pulled power off my laptop (see my first post)

i then re booted and now issues 1 to 6 are gone... permanently hopefully !

some minor gripes remain though:
1. i dislike using the trackpad for clicking, i prefer using it only for moving the pointer on the screen. But i see no setting for me to disable clicking thru track pad

2. can't select modem connection in network-manager !! when i check the Modem connection, it automatically gets unchecked in 1 second. really irritating :-( the reverse happens for wired and wireless connections. i can't uncheck them !

3. i don't know how many packages are still un upgraded from the old gutsy installation. installed some from what i had read on the web...

if i know what are missing, i'll probably download them (the debs) using my Windows install and then install them by booting into hardy (which has some gutsy :-P LOL)

am not sure if the above 3 are related to partial upgrade...

btw, i believe the main reason why i posted this question is solved (almost at least...)... so pls feel free to close this if u think the above 3 are unrelated to the partial upgrade ... or let me know so i can say "Problem Solved"

thx guys for ur support so far ! i had lost almost all hope and was contemplating a reinstall. trust me, just the fact that some one of u is replying gives a lot of strength :-)

Revision history for this message
Thomas Kluyver (takluyver) said :

OK, well, installing whatever it had downloaded was a good start.

The upgrade should also have changed the repositories you're using:

The file /etc/apt/sources.list should contain a number of double* entries like this:
deb http://gb.archive.ubuntu.com/ubuntu/ hardy main universe restricted multiverse
deb-src http://gb.archive.ubuntu.com/ubuntu/ hardy main universe restricted multiverse

If it made the appropriate changes, it should say hardy after the URL, as it does in mine. If not, it will say gutsy--you'll want to change it manually using a text editor (you'll need to do it as root, i.e. with sudo). Make sure to leave the spaces and everything intact. Oh, and don't worry if it doesn't look exactly like mine--it will be different depending on where you are and what you've enabled.

After that, running those two commands I mentioned above (or updating and upgrading in synaptic) should complete the upgrade. You will, however, need an internet connection. It should still be possible to configure it--if you can figure out what program you need to configure the network (I'm on KDE, I'm afraid, so I don't know what it is on GNOME), then you can sudo it.

*The ones starting "deb" are for compiled programs, and those starting "deb-src" are the source code.

Revision history for this message
abilash0101 (abilash01) said :

ok.. i'll check it today evening at home and post what transpired..

Revision history for this message
abilash0101 (abilash01) said :

oops.. i think i reopened it... without knowing what was going on :-(
I am pressing "Problem solved" now.. i think that'll close it back again

Revision history for this message
abilash0101 (abilash01) said :

sorry for the late reply.. my x-session crashed when it had almost finished fetching upgrades so had to do it all again

i just looked up the /etc/apt/sources.list file, and i saw many a "Line commented out by installer because it failed to verify:". All commented lines had gutsy, and one or two actually had fiesty.

i backed up sources.list file, replaced all gutsy/fiesty with hardy and then uncommented those lines... and also changed 20071016 to 20080423 ... and also removed the comments "Line commented out..."
The only line i left commented was
## deb http://archive.ubuntu.com/ubuntu/ hardy-backports universe main multiverse restricted
'cos i felt backports are not fully tested yet
... is all that ok?

then i went to synaptic, clicked on Reload and then came back to terminal and then did a sudo apt-get upgrade (i did reload in synaptic and not apt-get update in terminal 'cos of no real reason actually). it installed some more packages. it held back some packages ... no idea why. i still can't select anything in update-manager though :-(

but good news is that "xserver-xorg-input-synaptics" (i think) solved my trackpad issue i had mentioned. plus now hardy detects my SE w810i through usb and am able to connect to the net !! gutsy was able to do it with bluetooth and not usb. thx thr ...
btw, i thought gutsy was good... but my hardy is very functional now... and doing things with more elan ! no major crashes or bugs.. yet

Revision history for this message
Thomas Kluyver (takluyver) said :

Don't worry, I'm not timing you. ;-)

That sounds fine. Make sure that you have lines for: hardy, hardy-security, and hardy-updates. Probably with all four components enabled in each (main restricted universe multiverse (the order doesn't matter)).

Backports should be fine, but there's no need to use them unless you need a newer version of something. I don't have it enabled at the moment.

Yup, reload in synaptic does the same thing as "apt-get update". Try doing the upgrade in synaptic as well--it may install some things that apt-get didn't want to, and if it doesn't, you may get it to tell you why it's holding things back. If you can, try to work out what's stopping it--if not, run "sudo aptitude", and when it loads, press g, and browse through the list of what it's holding back--it should say why.

Glad it's coming together!