No reaction to bug reports. Are the developers aware of them?

Asked by Kupfer

There is a bug occurring in Ubuntu Maverick: When logging in, the Ambiance/Radiance (and other themes) revert to gnome default. The bug was reported by a lot of users not only in this Ubuntu Forums Thread (, but we also filed two bug reports in Launchpad:

Only problem is, no reaction to the bug reports from developers, not even confirming they are aware of the problem, or even the reports filed.

Usually, after filing a bug report in Launchpad, there is a reaction pretty fast. Sometimes it's just a categorization, sometimes even a fast answer from a developer. I filed a printer related bug two days ago and my problem was solved in a couple of hours! But regarding this specific bug, no reaction at all! Not even categorization. Complete silence.

We even filed the second report as a result of no reaction to the first one.

As the bug is viewed as pretty annoying and severe by most of us, my question would be: Are the developers aware of it, or the bug reports we filed?

Thank you for the answer.

Question information

English Edit question
Ubuntu gnome-settings-daemon Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
mycae (mycae) said :

gnome-settings-daemon is maintained by the gnome project (, which is not related to Canonical.

So chances are that the actual devs are not seeing your bug. If canonical has the resources, or prioritises your bug, then maybe they will look at it themselves, seperately from gnome. But looking at that bug, I (not a dev) have no idea what is going on, and the backtraces provided are not useful, as they do not have debugging symbols. So its not even clear what is going on.

Clarifying this transferrs some of the workload from the devs to the users, and the devs are much fewer in number than users, so this means that your bug is more likely to get fixed if you can at least nail down the problem

Revision history for this message
Sam_ (and-sam) said :

Well, as long as the status is 'incomplete' rather than 'confirmed' the bug will expire (as it says on top).
To determine if a bug has been abandoned, Launchpad uses the following conditions:
* it has the "Incomplete" status

In addition, someone who does experience the issue may report it upstream to raise attention, of course after searching gnome bug database.

Since I never had such issue it might be one regarding user config, (beside the preference of clean installation rather than upgrading).

However, create a test-user, monitor if the issue remains in order to exclude the case of culprit user config.

Does this reveal anything meaningful?
gnome-settings-daemon --debug --no-daemon

Or try via tty (ctrl+alt+f1):
gconftool --recursive-unset /apps/gnome_settings_daemon
and reboot.

Just in case, if there're any saved gnome-sessions remove them and disable saving sessions.

Revision history for this message
Sam_ (and-sam) said :

Regarding the 'BadMatch' error there is still an unsolved Bug #447431.

Revision history for this message
Kupfer (tamas-kadas) said :

Thanks for the answers. I forwarded Samanthas comment about how to test the problem to the forum thread:

I just reinstalled my Maverick 64bit and didn't finish configuring it yet. So far, the bug didn't show, but I expect it to appear at a later point and I know there are people still struggling with it. I will try to help get to the bottom of this with my limited technical skills - I can't say for sure whether the BadMatch error is related to our bug. Maybe someone else can confirm it.

Regarding Gnome, we did report our problem at

I hope the problem gets sorted out somehow. ;)

Revision history for this message
Best Sam_ (and-sam) said :

> but I expect it to appear at a later point
> didn't finish configuring it yet

Try to document each step so in case devs may reproduce it.
Until now I can't see a consistent pattern, as each user runs different setup and e.g. one time gnome-settings-daemon is started the other time it isn't.

Please also add bugzilla link to Bug #588155 that triagers can see there has been made an upstream report.

Revision history for this message
Kupfer (tamas-kadas) said :

Thanks Samantha (aka Sam), that solved my question.

Revision history for this message
Kupfer (tamas-kadas) said :

Thank you Samantha. I reinstalled Maverick 64bit and I'm using it with heavy artillery, namely a whole bunch of third party ppas right now. To my surprise, I didn't encounter the problem yet (it might or might not return). The same time my symptom vanished, someone else reported the bug occuring for him, so I hope this gets sorted out in the end. Until then, I see no point in keeping the Question open.

I added a link to Bug #588155 containing the report.

Thank You again for your help!