Default GNOME fallback session should be "GNOME Classic (no effects)" (Metacity)

Asked by Bob Bib on 2012-03-08

0) As for now, default GNOME fallback session called "Gnome Classic" uses Compiz.
It doesn't work well:
a) frames of some windows suddenly become torn (moving/refreshing helps);
b) if you change the settings of workspace switcher from default working settings (2x2 'desktops') to something else (e. g., 1x4) and then try to select another (not current) desktop, you'll get no more than full-screen wallpaper; to switch back to your workspace, you can launch a terminal (<Ctrl> + <Alt> + <T>); it reverts to default (2x2) after logout though;
c) <Alt> + <Tab> window switching hotkey is not working;
d) if you want to get the panel context menu, you should use <Super(Win)Key> + <Alt> + <RightClick> instead of <Alt> + <RightClick> (not working);
e) its 3D/2D effects doesn't fit the default Ubuntu theme (Ambiance) well (maybe, Adwaita theme'll help).

1) As a workaround, you can disable (or even remove) Compiz and use Metacity or simply select "GNOME Classic (no effects)" session at the login screen.

---

Ubuntu precise (development branch)

gnome-session-fallback 3.2.1-0ubuntu6
compiz 1:0.9.7.0~bzr2995-0ubuntu5
metacity 1:2.34.1-1ubuntu7

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-session Edit question
Assignee:
No assignee Edit question
Solved by:
Bob Bib
Solved:
2012-03-16
Last query:
2012-03-16
Last reply:
2012-03-16
Bob Bib (bobbib) said : #1

This looks more like a FAQ...

Bob Bib (bobbib) said : #2

"GNOME Classic (no effects)" session works less or more decently.

sam tygier (samtygier) said : #3