Why does the screensaver not lock the screen?

Asked by Stefan Lasiewski on 2012-09-16

I am running Ubuntu 12.04.1 LTS .

The screensaver does not lock, despite the fact that I have configured "All Settings: Brightness and Lock" to lock the screen after 30 seconds.

How can I fix this?

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu gnome-screensaver Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-19
Last reply:
2012-09-16
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

click Dash and write : brightness and lock

at the opened window make sure that :

1) Turn screen off when inactive for: Is not in "never" .

2) Lock is ON

3) Lock screen after : is set correctly

4) require my password when waking from suspend is checked.

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #2

IF all above (in answer #1) have been set properly and still not working , then open a terminal (Ctrl+Alt+T keys combo) and copy-paste from here to your terminal bellow command

gsettings set org.gnome.desktop.screensaver lock-enabled true

Thanks

If you make a new Ubuntu user and configure it, is it ok?

Answer #1: This is how it is configured already.

Answer #2: Unfortunately, that does not solve my problem. I typed that commmand, and waited. The screen does not lock.

> If you make a new Ubuntu user and configure it, is it ok?

Good question. If I create a new Ubuntu user, the new user has the same problem.

Note that the following command does actually lock the screen:

    $ gnome-screensaver-command --lock

I may be running into the following unresolved bug:

https://answers.launchpad.net/ubuntu/+source/gnome-screensaver/+question/202397

However, I am running Unity 3D not 2D.

I mean, this bug:

https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/1027902

Which is referenced from the following question:

https://answers.launchpad.net/ubuntu/+source/gnome-screensaver/+question/202397

However, I am running Unity 3D not 2D.

No luck getting an answer here.

I think I am probably experiencing the same issue as bug #1027902, so I will link to that bug.

Can you help with this problem?

Provide an answer of your own, or ask Stefan Lasiewski for more information if necessary.

To post a message you must log in.