How do I disable gnome-screensaver?

Asked by Zach Grogg on 2012-02-11

How do I permanently disable gnome-screensaver? I use Xscreensaver for my screensaver needs. I created a startup application command for the Xscreensaver to start, but the gnome-screensaver has to be stopped before X can start. Gnome isn't on the startup list. Is there a config file that I can edit? I am using Ubuntu 10.04.

Question information

English Edit question
Ubuntu gnome-screensaver Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Best Chris (fabricator4) said : #1

Open System -->Preferences -->Screensaver and untick "Activate Screensaver when idle"

Set the idle time to maximum for good measure.

You should also go into power management and set it to never put the monitor to sleep, unless that is what you really want to happen. That's not a very 'green' option however.

Alternately you can probably remove the screensaver from your system completely by un-installing it:

sudo apt-get remove gnome-screensaver


Sam_ (and-sam) said : #2
Sam_ (and-sam) said : #3

Skip #2 it's meant for 11.10.

Zach Grogg (yearomonkey) said : #4

I just zapped it in Synaptic Package Manager. I hadn't thought about trying to remove parts of Gnome. Thanks!

Zach Grogg (yearomonkey) said : #5

Thanks Chris, that solved my question.

to just disable the gnome-screensaver without removing it. Using the dconf editor and change the following options

org.gnome.desktop.lockdown disable-lock-screen
org.gnome.desktop.screensaver idle-activation-enabled
org.gnome.desktop.screensaver lock-enabled
org.gnome.desktop.screensaver ubuntu-lock-on-suspend

Careful: in 17.10 with the Budgie DE the suggested command #1 to remove the Gnome Screensaver will also remove your desktop.