prevent blank screen

Asked by dale francis on 2011-10-21

I have 1004 LTS on an ASUS eee PC 900. The screen goes blank after a short period of keyboard inactivity (between 1 & 5 minutes). I have set the power management opens for for put display to sleep to never for both ac and battery. Also when the screen goes blank, when I tap a key or the touchpad I have to re-enter a password. This has become major annoyance. Note that the screen will go blank even if something is running which does not require a key response(like security upgrades).

Any help would be appreciated for both issues (1. screen going blank; 2. re-enter password)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-screensaver Edit question
Assignee:
No assignee Edit question
Solved by:
enubuntu
Solved:
2011-10-22
Last query:
2011-10-22
Last reply:
2011-10-21
Best enubuntu (mr.tennents) said : #1

Hi, follow this:
http://www.liberiangeek.net/2011/04/how-to-disable-screensaver-lock-in-ubuntu-11-04-natty-narwhal/

You have to uncheck the box next to ‘Lock screen when screensaver is active’ and to 'Activate screensaver when computer is idle'

dale francis (p-dale-p) said : #2

1. Thanks. The article led me in the right direction. The location of the check box is in a different place in 10.04 (SYSTEM - PREFERENCES - SCREENSAVER), but unchecking the box works to prevent the screensaver. This part of the question is fixed.

2. Now, is there a way to minimize the number of times that passwords are required?

enubuntu (mr.tennents) said : #3

I don't know how to do this, I guess that this is possible, but I don't suggest to do this because the required of password is one of the most important thing that make linux better. Yeah I know, in the Update Manager is not usefull but it's better to have a little bit of security by the entering of a password, for the 'stupid' thing too.

dale francis (p-dale-p) said : #4

I will close this link with the solution to the display problemand open a new question about the password issuw whichis a different issue.

dale francis (p-dale-p) said : #5

Thanks Enrico "eNry" Carafa, that solved my question.