turn off some type of screen saver Maverick 10.10

Asked by george pharos on 2011-04-22

Ubuntu Maverick 2.6.35-28-generic #49, screen coes dark/blank after 5-10 minutes. Wether I am using htop or FF, if no actiivty from kybd/mouse the screen blanks. THis is a minimal cd isntall with no gdm/gnome isntalled. In other words no apps directory where gnome would reside. Things I ahve tried with Xserver, setterm -blank 0, setterm -powersave off, xset -dpms, and putting a line in xorg.conf, option "DPMS" "Off". I can not get it to stop blanking the screen. I have another install that has Ubuntu 2.6.32-25-generic #44 that does not exhibit this problem. I thought it was FF 4.0, but when htop and console starting doing it I knew it had to be something with the Xserver or OS. Please help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-screensaver Edit question
Assignee:
No assignee Edit question
Solved by:
george pharos
Solved:
2011-04-26
Last query:
2011-04-26
Last reply:
2011-04-23

Try running the command:

gnome-screensaver-preferences

If you get a "command not found" error or it tells you that the package providing that command is not installed, then try:

xscreensaver-demo

If neither of those works (or works correctly), please post a reply.

george pharos (speed32219) said : #2

Both give an error "command not found"
I should have stated that I had tried those options. Gnome and screensaver are not installed.

Please run this command:

xset -q

Then copy all the text associate with running that command (i.e., the whole line where you entered the command, plus all the output) to the clipboard, and paste it here.

(Also, when you post, if you're providing more information or indicating that an answer wasn't sufficient, please use the most correctly descriptive button for the nature of your post, rather than "Just Add a Comment." The "Just Add a Comment" button will not change the status of the question back from Answered or Needs Information to Open--therefore, it is difficult to know that you are requesting further response.)

george pharos (speed32219) said : #5

looking down the output that xset -q displayed, I am adding what looks to be revelant.
Screen Saver:
prefer blanking: yes allow esxposures: yes
timeout: 600 cycle: 600

DPMS (Energy Star):
Standby: 600 Suspend: 600 Off: 600
DPMS is Disabled

Please run this command and post the text from the Terminal (starting with the line where you typed it -- this command should produce less, and more specific output than the last command):

xset s 0; xset -q | grep timeout

I recommend copying and pasting that command, rather than manually retyping it, so as to reduce the chance of typos.

That should disable the screen saver from automatically coming on due to a period of inactivity. Please see if that is effective--if it is not, then something else is providing your screen saver. If that works, then you'll have to edit a configuration file to make it permanent (i.e., as it is, the change will only survive until the end of this X session). So when you reply about whether or not that was effective at disabling the screen saver for the current session, please also indicate whether you're going to want to make this change globally (for all users), or just for your specific user account.

george pharos (speed32219) said : #7

Here is the output:

 timeout: 0 cycle: 600

Over the past 24 hours I have tried a variety of commands inclduing setting the time to 0 or off.
(DISPLAY=":0.0" xset s 0)

I also tried DISPLAY=":0.0" xset s noblank and ran the xset -q to verify that it also was off which it was. The screen blanks after 10 minutes (600 seconds) no matter what I try. I even increased the timeout from 600 to 8000, but after 600 seconds, screen goes blank. I am really stumped, I am going to try some earlier Maverick kernels. I've not had this problem with earlier builds.

Update: I had a backup of an older kerenl/root (Clonezilla) 2.6.35-25-generic #44 and it has been running for over 12 hours without it blanking/scr saver. Here is the output of xset -q on this kernel.
Screen Saver:
  prefer blanking: yes allow exposures: yes
  timeout: 600 cycle: 600
DPMS (Energy Star):
  Standby: 600 Suspend: 600 Off: 600
  DPMS is Enabled
  Monitor is On

I'm either going to remove all apps or better yet, re-install the current kernel from sctrach and see if it blanks. Then add my drivers/programs one by one and see when it starts to occur. Or maybe just install the beta natty kernel.

george pharos (speed32219) said : #8

Update: I re-installed Maverick 2.6.35-28-generic. No screen saver no blanking. I then installed the following:

sudo apt-get install xinit x11-xserver-utils fluxbox htop lshw samba smbfs binutils gcc

sudo nano /etc/modprobe.d/blacklist.conf ###ADDEd to get ready for install of nvidia accelerated graphics
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
blacklist mceusb

sudo apt-get install linux-backports-modules-alsa-2.6.35-28-generic alsa-utils

Reboot

Screen saver is now active and after 10 minutes my screen goes blank.
xset command at this time does not work, unable to open display 0. Since I do not have the Nvidia display dirver loaded yet other than the default. My next step was to load the Nvidia, but I'm going to wait and see if you have any idea. X11-xserver-utils is installed, but I can not execute any commands. (xset -q or xset s 0)

george pharos (speed32219) said : #9

Well, Naverick screen saver just will not go away. I think I need to look at filing a bug. The screen just blanks after 10 minutes and I can not turn it off even prior to applcaitons being installed from a minimal ubuntu cd install.

george pharos (speed32219) said : #10

Well, after many hours I have found the app that is causing my screen blank. After 12 hours of non blanking while using FF 3.6.13 and dishonline video streaming it has not failed since I remove fluxbox. I did re-install fluxbox and the balnking started again, I then removed it and it is working again. So it is safe to say that fluxbox has something to do with the screen saver (Which you can try and trun off using xset cmds with no effect) with the latest release of ubuntu.