scrensaver puts computer to death sleep

Asked by will john on 2011-02-02

instead of preview the one called lock something (don't remember name) makes some words flash on my otherwise blank monitor then my monitor gos to sleep i can restart my computer but can't change scrensavers when i try it happins agen

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-screensaver Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-02-02
Last query:
2011-02-02
Last reply:
2011-02-02

Pressing a key on your keyboard doesn't rouse your computer from sleep, when this happens?

will john (will00dragonslayer) said : #2

no

will john (will00dragonslayer) said : #3

preview is in windo

What do you mean when you say that "preview is in windo"? Did you attempt to attach a screenshot? Launchpad does not support attaching screenshots to questions via email attachment (nor by any other method, unfortunately). However, if you want to post a screenshot of something, you can upload it somewhere like http://postimage.org/ and include a link to it in your post.

will john (will00dragonslayer) said : #5

when i go to system>prefrences>scrensaver that windo(bad spelling) has the prevew

Are you talking about the checkbox labeled "Lock screen when screensaver is active"?

Ubfan (ubfan1) said : #7

Earlier Lucid kernels had some serious lockup problems with Intel video hardware. Certain GL screen savers would instantly lockup. If you have one such screensaver selected, even the preview of it would lockup the machine. You may be able to switch the screensaver to the blank screen with a really really quick click before the preview shows up. There is no time to move the mouse, have it prepositioned so when the window opens, you instantly click. If the blank does not appear in the selections (it's at the top), keep doing this on the top entry until you find one which does not lockup, or until the blank shows.
  Or just update everything and see if the problem goes away

will john (will00dragonslayer) said : #8

no good lockword is at the top

will john (will00dragonslayer) said : #9

can scrensavers be changed in the comand line

"can scrensavers be changed in the comand line"

Yes, but it's easier to do it in the graphical program gconf-editor (which will not show previews and is just as unlikely to crash Ubuntu as the Terminal).

Press Alt+F2, type "gconf-editor" (without the quotes), and press enter.

If you get a "could not open location" error, then install the package called gconf-editor (you can do this in Applications > Ubuntu Software Center by typing "gconf-editor" into thre Find box and installing Configuration Editor) and try again.

In the left pane of the Configuration Editor, expand "apps". Under "apps" (in the expanded list), click on "gnome-screensaver". In the right pane, change "mode" from "single" to "blank-only". (To do this, right-click on it and click "Edit Key...".) Optionally, for "themes", remove all the values from the list (once you've done that, it will show "[]" to the right of "themes".)

Now, the screensaver will just blank the screen. If the screensaver is disabled, and then enabled, it will still just blank the screen, which will probably not cause a crash. However, if you also want to disable the screensaver from activating automatically after any amount of time, uncheck the box for "idle_activation_enabled".

This screenshot illustrates what it looks like to edit the gnome-screensaver settings in the gconf-editor:
http://postimage.org/image/15kcm5zvo/

Please post again if you have any questions or that doesn't solve your problem.

Thanks Eliah Kagan, that solved my question.