Ubuntu 10.10 - Screen saver / Lock comes up late

Asked by Maarten Jacobs on 2011-01-13

I've looked for an existing answer to the issue I'm having but can't find a good match. My apologies therefore if I'm opening a dup!

I'm having an issue where the Screen Saver and Lock do not kick in in accordance with the time I've set. Initially I had Screen Saver set to 5 minutes (and to lock the machine when the Screen Saver kicks in). In this situation, when I would leave the machine for a while and the screen saver should have come on, it didn't. Then, after returning to the keyboard, i would access an application and THEN the Screen Saver and Lock would come on.

I changed the time to 10 minutes and set the Screen Saver back to "Blank Screen". This seems to have sorted the problem with the Screen Saver not kicking in when expected (it now appears to do so) but then the machine doesn't lock and again when I get back to the keyboard the machine locks when I access an application.

Any thoughts anybody? I'm wondering if this is somehow related to CPU utilisation or something - but I'm not sure and not sure how I'd confirm that?


Question information

English Edit question
Ubuntu gnome-screensaver Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Sam_ (and-sam) said : #1

When screensaver is 10 minutes, what is the time in
system preferences -> power management?

Maarten Jacobs (maarten256) said : #3


Thanks for the pointers. The description in the bug gave me the idea about manually adjusting the delay in configuration editor (so now I'm running with the same setting for idle_delay as that set in system->preferences->screensaver).

Incidentally, power management has display off set to 15 minutes.

As I went through and played with this for a bit, I did notice something funky. I'm running VirtualBox on my second display, and if VirtualBox has focus, the screensaver does not come on! If another application (like Firefox) has focus it seems to work ok... Is that to be expected?


Best Sam_ (and-sam) said : #4
Maarten Jacobs (maarten256) said : #5

Thanks, got that clarified then!

Maarten Jacobs (maarten256) said : #6

Thanks Samantha (aka Sam), that solved my question.