we didnt define a password - but ubuntu asks a password after PC sleeps

Asked by Peter Schulz on 2011-01-12

With the installation we didn define a password
If computer is sleeping and we want to go back in he asks a password but doesnt accept Space or anything.
Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-screensaver Edit question
Assignee:
No assignee Edit question
Last query:
2011-01-12
Last reply:
2011-01-12

DO NOT HAVE BLANK PASSWORDS

I'm tired of this age old bug. Blank passwords not only break stuff but they are completely irresponsible and completely annihilate any sort of system security. Would you have a bank account with zero security, no. or your email account, no. If you use evolution or have your webmail password stored in your system then an attacker can VERY easily read this as you have ZERO security.

Lets get this mess sorted, when you boot hold SHIFT and select recovery mode, then rselect root. You can now run:

cd /home; ls

ls is a lowercase LS

You can now see the usernames in your system. You can run:

passwd foo

replace foo with your username and SET the password. You can now run:

reboot

and let the system boot normally, you can now log on as foo and you will be able to unlock the screen after the screensaver has ended.

delance (olivier-delance) said : #2

It is possible in preferences of screensaver to remove the password.

Can you help with this problem?

Provide an answer of your own, or ask Peter Schulz for more information if necessary.

To post a message you must log in.