Wireless disconnects after suspend and resume

Asked by New2Ubuntu on 2009-10-15

hi, i'm running jaunty 9.04 on a samsung nc10 and I'm having problems with the wireless after I have suspended the computer and resumed. the wireless wont pick up my networks (or any) and I have to shut down to enable it again. re-starting wont do it. for info i'm also running NetworkManager Applet 0.7.0.100. i've read a few articles on how to get around this, by adding a file however I'm new to ubuntu so not sure exactly how to do this and also if this is the right solution for the version I am running. as ever and help is greatly appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-power-manager Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-15
Last reply:
2009-10-15

Give this a go:

http://lilserenity.wordpress.com/2007/10/31/fix-ubuntu-dropping-wireless-on-suspendhibernate-resume/

Backup any files you modify first so you can easily roll back to the original version.

Basically what that is doing is unloading the driver and stopping networking then you put the driver back in and restart networking. You will need to replace what driver you are using with the one in the guide. If you are unsure you can run:

sudo lshw -C network

and read the output

Hibernate / Suspend / Sleep / Whatever is a MASSIVE pain to get working nicely and personally I dont see why so many people tear their hair out when it works so very badly. It is getiing better now but its still pretty shoddy.

Can you help with this problem?

Provide an answer of your own, or ask New2Ubuntu for more information if necessary.

To post a message you must log in.