Can not suspend or hibernate.

Asked by laptoplinux

If I try to suspend or hibernate from either the menu item, or by running the script directly, it fails and issues a warning saying that VLC is preventing it because it is running some media. Needless to say VLC is not running and no other media players are running. I even have checked the running processes.

Shutdown works without any problem.

This is recent behavior which leads me to believe something came down in one of the safe-upgrades that broke it? Any ideas/suggestions and should I report it as a bug?

Ubuntu 9.04 Jaunty
Kernel Linux 2.6.28-11-generic
GNOME 2.26.1

on a Toshiba Dynabook; TX/760LS

Question information

English Edit question
Ubuntu gnome-power-manager Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Tom (tom6) said :

Hi :)

I haven't tried VLC recently. Presumably you checked all the running processes with a command something like

ps aux | grep vlc

Please can you also give the results of

free -m

sudo fdisk -l

where the " -l" is a lower-case " -L"? Just copy and paste the outputs of those last 2 into here. I take it that hibernate used to work? Have you installed any new ram recently?

Thanks, good luck and regards from
Tom :)

Revision history for this message
laptoplinux (laptoplinux) said :

TX760LS-laptop:~$ ps -A |grep vlc
TX760LS-laptop:~$ ps aux | grep vlc
t*** 25973 0.0 0.1 3336 804 pts/1 S+ 13:26 0:00 grep vlc

TX760LS-laptop:~$ free -m
             total used free shared buffers cached
Mem: 489 482 7 0 1 105
-/+ buffers/cache: 375 113
Swap: 1906 313 1593

TX760LS-laptop:~$ sudo fdisk -l
[sudo] password for t***:

Disk /dev/sda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000cd805

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 1827 14675346 83 Linux
/dev/sda2 1828 11918 81055957+ 83 Linux
/dev/sda3 11919 12161 1951897+ 82 Linux swap / Solaris

No I haven't installed any new ram. I must say though that of the past 2 weeks there has been a serious drop in performance/strange behavior of my machine and the only changes that have happened are the regular updates via aptitude.


Revision history for this message
laptoplinux (laptoplinux) said :

Yes this is very recent behavior. I have never had problems with Hibernate or Suspend before on Jaunty.

Revision history for this message
Tom (tom6) said :

Wow, this is the most beautifully organised install that i have yet seen. Even my own machines aren't anything like this well setup. I was hoping to see some obvious errors or potential problems there but swap is larger than ram and not too hugely excessive. Also the partitions aren't squashed up into.

If the change has been quite sudden then i would install "clamtk" and all the other parts of the ClamAv antivirus scanner and thoroughly scan the machine. I know it isn't likely to be the problem but is vaguely possible. be gentle though and if you do find something then consider keeping it as a collectors item somewhere safe where it can't be run. Linux viruses are rare and fragile.

Mostly you can just deal with such things by doing a "Fix broken packages" and an update through Synaptic Package Manager.

Something else well worth doing is, from the top taskbar/panel click on

System - Administration - Computer Janitor

and maybe run it a couple of times. Also during boot-up if you get a lot of option for booting into Ubuntu the 2nd option has "recovery mode" at the end of it's line and leads to a disturbingly blue but quite friendly menu with a lot of options worth running about once every couple of months. Computer Janitor will already have done most of this but it's worth running through these options from here too. The ones i would avoid are "Fix x-server" & "Drop to Root Shell" (typing reboot gets out of that one ;) )

Apart from these general house-keeping tips which i suspect you do anyway i really can't think of anything much here. Please let us know how it goes with these tidy-ups tho!

Hopefully someone else will pop in with some other ideas later
Good luck and regards from
Tom :)

Revision history for this message
laptoplinux (laptoplinux) said :

Thanks for the kudos. To be honest, although i did do my homework before setting up my system, my configuration was probably as much luck as anything else.

Someone on the Ubuntu Forums gave me a tip that solved my immediate problem:

[QUOTE=P4man;7910318]try this (assuming you have at least vlc installed): start vlc > tools > preferences > show setttings "all" > uncheck "inhibit power mngt deamon during playback "

Im not sure how it works, but perhaps it puts a lock somewhere and its not removing it for whatever reason?[/QUOTE]

I still wonder why this problem ocurred rather suddenly (ie an update to VLC or something else) and why I don't see any VLC or related process when ps'ing. But I won't look a gift horse in the mouth.

I will start another thread but I would note that although I can successfully suspend/hibernate now when I wake up my machine it can't connect to the wireless network again unless I reboot.

Revision history for this message
Tom (tom6) said :

Hi )

Sounds good so far :) Congrats on that and thanks for pasting the answer into here :) Hopefully if someone else has a similar problem then this thread will help.

On a wired Lan network i sometimes find that doing

cd /etc/init.d
networking stop
networking start

Restarts my network if my neighbour had been fiddling with the server. If you are in the init.d folder can you do "ls" or "dir" to see if there's soemthing similar worth trying?

I hope this helps!
Good luck, thanks and regards from
Tom :)