9.04 on Toshiba A210 won't go into standby or hibernate

Asked by carlwright on 2009-04-24

HI I have a Toshiba A210-1B1 running 9.04, the problem I have is when I go into Standy or Hibernate all I get is a black screen with a flashing white _ in the top left hand corner.

My machine has a AMD Turion 64 and I've installed 9.04 i386 version. If i remember rightly I tried the pre release of the 64 bit version and it was the same.

I've run sleep quirk debugger and received the below:
_______________________________________________________________________
#!/bin/sh
#
# SuspendQuirks, copyright Richard Hughes 2007
# created : 29-07-2007
# modified : 29-07-2007

# updated: 2007-08-04 Thomas Perl <thp at perli.net>
# Added support for Debian distro, fix for xorg.conf commented-out drivers

supported_distro=""
unload_modules=""
quirks=""
arch="`uname -i`"

abort ()
{
 echo "CRITICAL ERROR: $1"
 exit 1
}

warn ()
{
 echo "WARNING: $1"
}

add_quirk ()
{
 quirks="$quirks\npm-suspend $1"
}

add_module ()
{
 if [ -z "$unload_modules" ]; then
  unload_modules="$1"
 else
  unload_modules="$1 $unload_modules"
 fi
}

echo -e "Checking your system...\n"

#find distro
if [ -e /etc/redhat-release ]; then
 supported_distro="redhat"
fi
if [ -e /etc/mandriva-release ]; then
 supported_distro="mandriva"
fi
if [ -e /etc/debian_version ]; then
        supported_distro="debian"
fi

#check distro
if [ -z "$supported_distro" ]; then
 abort "No supported distro"
fi

#check quirks are installed
if [ -z "`lshal | grep quirk`" ]; then
 warn "You have no quirks!"
 #IBM
 if [ "`hal-get-property --udi /org/freedesktop/Hal/devices/computer --key system.hardware.vendor`" = "IBM" ]; then
  add_quirk "--quirk-s3-bios --quirk-s3-mode"
 fi
 #LENOVO
 if [ "`hal-get-property --udi /org/freedesktop/Hal/devices/computer --key system.hardware.vendor`" = "LENOVO" ]; then
  add_quirk "--quirk-s3-bios --quirk-s3-mode"
 fi
 #Intel
 if [ -n "`cat /etc/X11/xorg.conf | grep intel`" ]; then
  add_quirk "--quirk-vbemode-restore"
  add_quirk "--quirk-vbe-post"
 fi
fi

#check kernel capabilities
if [ -n "`uname -r | grep 3194`" ]; then
 abort "Do not use the default Fedora 7 GOLD kernel. It's broken. Use a kernel from updates!"
fi
if [ -n "`uname -r | grep xen`" ]; then
 abort "Do not use a XEN kernel. It will not suspend!"
fi

#check kernel capabilities
if [ -z "`cat /sys/power/state | grep mem`" ]; then
 abort "Kernel does not support suspend!"
fi
if [ -z "`cat /sys/power/state | grep disk`" ]; then
 warn "Kernel does not support hibernate!"
fi

#check pm-utils is correct arch
if [ $arch = "i386" ]; then
 if [ -n "`rpm -q pm-utils | grep athlon`" ]; then
  abort "pm-utils is the wrong arch!"
 fi
fi

#check HAL has got the right value
if [ "hal-get-property --udi /org/freedesktop/Hal/devices/computer --key power_management.can_suspend" = "false" ]; then
 abort "HAL does not detect suspend!"
fi

#check for no consolekit in GNOME
if [ -n "`ps aux | grep gnome-session | grep -v grep`" ]; then
 if [ -z "`ps aux | grep console-kit-daemon | grep -v grep`" ];then
  abort "ConsoleKit is not running. Suggest 'chkconfig ConsoleKit on' and reboot"
 fi
fi

#check for nvidia binary graphics
if [ -n "`cat /etc/X11/xorg.conf | grep '^\s*[^#]*nvidia'`" ]; then
 abort "Using nvidia binary driver. This is not supported!"
fi

#check for ati binary graphics
if [ -n "`cat /etc/X11/xorg.conf | grep '^\s*[^#]*fglrx'`" ]; then
 abort "Using ATI binary driver. This is not supported!"
fi

#check for old intel graphics
if [ -n "`cat /etc/X11/xorg.conf | grep '^\s*[^#]*i810'`" ]; then
 abort "Using old 'i810' non-modesetting intel driver. Try using 'intel' driver!"
fi

#check for broadcom networking
if [ -n "`/sbin/lsmod | grep b44`" ]; then
 add_module "b44"
 warn "Using broadcom network driver."
fi

#check for ndiswrapper
if [ -n "`/sbin/lsmod | grep ndiswrapper`" ]; then
 add_module "ndiswrapper"
 warn "Using ndiswrapper network driver."
fi

#check for 915resolution
if [ -e /usr/bin/915resolution ]; then
 warn "Do not use 915resolution with the new intel driver!"
fi

#check for suspend
if [ -e /usr/bin/suspend ]; then
 abort "Do not use suspend2, it's unsupported!"
fi

#check for old intel networking
if [ -n "`ps aux | grep ipw3945 | grep -v grep`" ]; then
 abort "Use the mac80211 based iwl3945 driver instead. ipw3945d is closed source sometimes hangs on resume."
fi

#check for iwl3945
if [ -n "`/sbin/lsmod | grep iwl3945`" ]; then
 add_module "iwl3945"
 warn "iwl3945 is usually okay for suspend - but it might be worth trying unloading it."
fi

#check for kvm
if [ -n "`/sbin/lsmod | grep kvm`" ]; then
 add_module "kvm"
 warn "KVM will not suspend in kernels less than 2.6.23, but should work okay in later kernels."
fi
if [ -n "`/sbin/lsmod | grep kvm_intel`" ]; then
 add_module "kvm_intel"
fi
if [ -n "`/sbin/lsmod | grep kvm_athlon`" ]; then
 add_module "kvm_athlon"
fi

echo

if [ -z "$unload_modules" ] && [ -z "$quirks" ]; then
 echo "Suspend should work!"
else
 echo "Suggestions:"
 echo
 if [ -n "$unload_modules" ]; then
  echo -e "Add 'SUSPEND_MODULES=\"$unload_modules\"' to /etc/pm/config.d/unload_modules!\n"
 fi
 if [ -n "$quirks" ]; then
  echo -n "You might want to try the following pm-suspend entries:"
  echo -e $quirks
 fi
fi

echo

exit 0
______________________________________________________________________________
I've tried:

pm-suspend --quirk-s3-bios --quirk-s3-mode
pm-suspend --quirk-vbemode-restore
pm-suspend --quirk-vbe-post

and these cause the same.

Thanks

Carl

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-power-manager Edit question
Assignee:
No assignee Edit question
Solved by:
carlwright
Solved:
Last query:
Last reply:
Revision history for this message
Sam_ (and-sam) said :
#1

Is power management (acpid) activated in system administration services?
Is acpi_s3 or alike set in BIOS section power management?
In case to enter BIOS press DEL after starting the computer.
Since there is a variety of BIOSes example may look like this:
S3
STR
Suspend to RAM
Suspend to RAM (S3) enabled

S3 will not work if it shows someting like this:
S1
POS
Power On Suspend
Suspend to RAM (S3) disabled

Other options:

Check the file /var/log/pm-suspend.log

Maybe acpi=off is set?
To check by typing in a terminal:

cat /proc/cmdline
or
grep -i acpi /boot/grub/menu.lst

Since Intrepid there should be a file on how to debug:
/usr/share/doc/pm-utils/README.debugging

To check if hibernate or suspend is possible at all enter this one line command into terminal with copy&paste to avoid mistyping:

echo; for i in --suspend --hibernate --suspend-hybrid; do pm-is-supported $i && echo "$(echo $i | tr [:lower:] [:upper:] | tr -d -) is
supported"; done; echo

The output should look like this:

SUSPEND is
supported
HIBERNATE is
supported

Reference:
https://wiki.ubuntu.com/KernelTeam/Specs/JauntySuspendResumeHibernate
https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume
http://ubuntuforums.org/showthread.php?p=3066404

#older version
https://wiki.ubuntu.com/PowerManagement

Revision history for this message
Sam_ (and-sam) said :
#2

Sorry the format of the one line command corrupted, I'll try again to paste it correct:

echo; for i in --suspend --hibernate --suspend-hybrid; do pm-is-supported $i && echo "$(echo $i | tr [:lower:] [:upper:] | tr -d -) is supported"; done; echo

Revision history for this message
Sam_ (and-sam) said :
#3
Revision history for this message
Tom (tom6) said :
#4

http://www.ubuntu.com/getubuntu/releasenotes/904#Hibernation%20may%20be%20unavailable%20with%20automatic%20partitioning

It could be this known issue mentioned in the release notes?
Good luck and regards from
Tom :)

Revision history for this message
carlwright (carlwright79) said :
#5

Thanks for all you input guys, I've wanted to use ubuntu for ages now, but some of the issue I've had have prevented me using it e.g. wifi issues.

Now I've run through what Sam mentioned and got the below from pm-suspend.log and received the following:

__________________________________________________
Initial commandline parameters: --quirk-dpms-suspend
Fri Apr 24 12:55:04 BST 2009: Running hooks for suspend.
/usr/lib/pm-utils/sleep.d/000record suspend suspend: success.
/usr/lib/pm-utils/sleep.d/00auto-quirk suspend suspend: success.
/usr/lib/pm-utils/sleep.d/00logging suspend suspend: Linux ubuntu 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
Module Size Used by
ppp_deflate 12800 0
zlib_deflate 28312 1 ppp_deflate
bsd_comp 13568 0
ppp_async 16896 1
crc_ccitt 10112 1 ppp_async
isofs 39844 0
udf 87716 1
crc_itu_t 10112 1 udf
binfmt_misc 16776 1
radeon 342816 2
ppdev 15620 0
drm 96296 3 radeon
bridge 56340 0
stp 10500 1 bridge
bnep 20224 2
lp 17156 0
parport 42220 2 ppdev,lp
joydev 18368 0
arc4 9856 2
ecb 10752 2
snd_hda_intel 435636 3
snd_pcm_oss 46336 0
snd_mixer_oss 22656 1 snd_pcm_oss
snd_pcm 82948 2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy 10756 0
snd_seq_oss 37760 0
snd_seq_midi 14336 0
snd_rawmidi 29696 1 snd_seq_midi
snd_seq_midi_event 15104 2 snd_seq_oss,snd_seq_midi
rtl8187 53376 0
snd_seq 56880 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 29704 2 snd_pcm,snd_seq
snd_seq_device 14988 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
mac80211 217208 1 rtl8187
snd 62628 15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
eeprom_93cx6 10240 1 rtl8187
soundcore 15200 1 snd
psmouse 61972 0
i2c_piix4 18448 0
ati_agp 14988 0
agpgart 42696 2 drm,ati_agp
ricoh_mmc 11904 0
sdhci_pci 15232 0
sdhci 23940 1 sdhci_pci
snd_page_alloc 16904 2 snd_hda_intel,snd_pcm
shpchp 40212 0
option 28036 1
k8temp 12416 0
cfg80211 38032 2 rtl8187,mac80211
serio_raw 13316 0
pcspkr 10496 0
video 25360 0
input_polldev 11912 0
output 11008 1 video
ohci1394 38576 0
ieee1394 94660 1 ohci1394
usbhid 42336 0
r8169 40836 0
mii 13312 1 r8169
fbcon 46112 0
tileblit 10752 1 fbcon
font 16384 1 fbcon
bitblit 13824 1 fbcon
softcursor 9984 1 bitblit
             total used free shared buffers cached
Mem: 1930968 1036468 894500 0 360400 482036
-/+ buffers/cache: 194032 1736936
Swap: 262136 0 262136
success.
/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
/usr/lib/pm-utils/sleep.d/01PulseAudio suspend suspend: success.
/usr/lib/pm-utils/sleep.d/45iwlist suspend suspend: /sbin/iwlist
not applicable.
/usr/lib/pm-utils/sleep.d/48hid2hci suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: success.
/usr/lib/pm-utils/sleep.d/75modules suspend suspend: success.
/usr/lib/pm-utils/sleep.d/90chvt suspend suspend: success.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95anacron suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95hdparm-apm suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/95led suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/96laptop-mode suspend suspend: success.
/usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend suspend: not applicable.
/etc/pm/sleep.d/99laptop-mode suspend suspend: success.
/usr/lib/pm-utils/sleep.d/99video suspend suspend: kernel.acpi_video_flags = 0
success.
/etc/pm/sleep.d/action_wpa suspend suspend: success.
Fri Apr 24 12:55:05 BST 2009: performing suspend
___________________________________________________

Just to add this installation was done using Wubi within windows, so could the swap file issue Tom mentioned be a cause?

The following was returned when doing: echo; for i in --suspend --hibernate --suspend-hybrid; do pm-is-supported $i && echo "$(echo $i | tr [:lower:] [:upper:] | tr -d -) is supported"; done; echo

SUSPEND is
supported
HIBERNATE is
supported

Cheers for you help so far guys!

Revision history for this message
Tom (tom6) said :
#6

Aaaargh not the Wubi Wobbly!!! lol
Quickly change it to a normal instal rather than this demo for tourists into linux-land! The fact that this usually works extremely well for many people for years inside a rival OS that's dedicated to wiping linux out is amazing. On the rare occasions that it doesn't work then often simply migrating it to its own proper linux space on a decent ext3 primary partition rather than the horrible ntfs stuff almost always fixes all those horrible little problems in one swoop.

See part 8 of section 8
https://wiki.ubuntu.com/WubiGuide

However it does suggest going a bit tooo far. Most of us keep a proper dual-boot as it can be quite a laugh going back into Windows sometimes ;)
Good luck and regards from
Tom :)

Revision history for this message
carlwright (carlwright79) said :
#7

Hi Tom

I've now gone for the full install (dual-boot) and still the same issue with suspend / hibernate any ideas, I'd love to get this working!

Cheers

Carl

Revision history for this message
Sam_ (and-sam) said :
#8

No ideas here except:
to unplug USB
What about BIOS?
Check for related messages:
/var/log/syslog
/var/log/kern.log
/var/log/acpid
Deactivate hibernate on MSWindows

You may search ubuntuforums.org for some ideas, hibernate is a widespread issue on laptops.

Revision history for this message
Sam_ (and-sam) said :
#9

Another:
disable power save settings, e.g. in screensaver
coming from here:
http://ubuntuforums.org/showthread.php?t=807593

Revision history for this message
carlwright (carlwright79) said :
#10

Unfortunately I've had to throw in the towel again, my laptops now dropping the wireless connection as were previous versions. This coupled with with suspend issues has left me no choice but to go back to Vista, BOOOO HOOOO! I was really hoping this would work this time round, guess I'll have to wait till I get a new machine then go for one that comes with ubuntu pre-installed so I know it will work e.g Dell.

Thanks for your help guys!

Revision history for this message
Jeruvy (jeruvy) said :
#11

If your swap file is smaller than real RAM, then hibernation fails. This is a known bug.

If I read this correctly, that looks like why.

Revision history for this message
carlwright (carlwright79) said :
#12

I have 2GB of RAM and my swap file is 2GB too. DOH!

On Sat, Apr 25, 2009 at 9:07 PM, Jeruvy
<email address hidden> wrote:
> Your question #68469 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/68469
>
> Jeruvy posted a new comment:
> If your swap file is smaller than real RAM, then hibernation fails.
> This is a known bug.
>
> If I read this correctly, that looks like why.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Revision history for this message
LFH (mgraz) said :
#13

Hello,
This is my first post regarding this issue. Just want to say that I am having the exact same problem on the exact same machine - Toshiba Satellite Pro A210. Ubuntu 9.04 will not hibernate or suspend after trying many different things. Last thing I did was to increase swap space to approx 2.2GB for 2GB ram. Still, no luck.

When hibernate or suspend is started, the screen goes black, the machine appears to freeze in about a second, and only a white blinking cursor can be seen in the upper left of the display. At this point the only recourse is to unplug the power supply and pop out the battery.

The only workaround I can come up with is to not use hibernate and suspend at all. Have set the power settings never to suspend and only to blank the display after 15 minutes. And have set shutdown as the action for closing the laptop lid. This at least takes hibernate and suspend out of the picture. Thankfully Ubuntu boots quickly so at least the pain is not too great!

If there ever is a solution I would certainly appreciate hearing about it.
Thanks,
-LFH

Revision history for this message
Tom (tom6) said :
#14

Hibernate mode is very dodgy at best. It leaves the drives very vulnerable to the slightest problem such as a slight knock or cosmic-rays or even have slightly different kit plugged in so i would recommend avoiding hibernate/suspend/sleep at all anyway.

Some people think it's 'better for the environment' but i think they stop their clocks before the thing has finished shutting down as i've noticed that it still drains the same amount of power from the batteries but it just has a much longer 'close down' time rather than a long boot-up time.

The only advantage i can see is that it starts up slightly faster, assuming it all works properly. On the other hand that gives me less time to prepare to use it and definitely doesn't give me a good excuse for getting my first cup of tea in the morning!

lol, good luck and regards from
Tom :)

Revision history for this message
Tom (tom6) said :
#15

Hibernate mode is very dodgy at best. It leaves the drives very vulnerable to the slightest problem such as a slight knock or cosmic-rays or even have slightly different kit plugged in so i would recommend avoiding hibernate/suspend/sleep at all anyway.

Some people think it's 'better for the environment' but i think they stop their clocks before the thing has finished shutting down as i've noticed that it still drains the same amount of power from the batteries but it just has a much longer 'close down' time rather than a long boot-up time.

The only advantage i can see is that it starts up slightly faster, assuming it all works properly. On the other hand that gives me less time to prepare to use it and definitely doesn't give me a good excuse for getting my first cup of tea in the morning!

lol, good luck and regards from
Tom :)

Revision history for this message
Tom (tom6) said :
#16

Dual-boot means you can keep using Windows but just pop into Ubuntu for things you enjoy doing in Ubuntu (eg Wesnoth or whatever), eventually you'll find that you've picked up enough t stay in Ubuntu for longer and longer until eventually you find you rarely boot into Windows at all.

There's no need to make it all dramatic as Windows would like to force you into being, just take it slow and gently and then you'll find your migration to linux much easier ;)

Good luck and regards from
Tom :)

Revision history for this message
Tom (tom6) said :
#17

Hi :)

Have you been able to test the new Ubuntu 10.04 before it gets officially released?
http://www.ubuntulinux.org/testing/lucid/beta1
Trying it as a LiveCd or as an extra dual/multi-boot would be ideal. Developers and everyone are keen to try to iron out any problems before 10.04 gets officially released so you might find faster & more effective answers to your bug reports which would make 10.04 work better on your system for you

Thanks and regards from
Tom :)