Ubuntu struck on login screen: message: "the configuration defaults for the gnome power manager has not been installed correctly" How do I solve that problem?

Asked by dyk6j on 2008-07-11

I am running Ubuntu 9.10. After a routine update, the system asked for a restart; after which it popped up a warning: INSTALL PROBLEM: "the configuration defaults for the GNOME Power Manager have not been installed correctly. Please contact your computer administrator." From then many things have changed. My Ubuntu is not starting at all. Can someone please help me with sorting out this problem?
Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-power-manager Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Vadim Peretokin (vperetokin) said :
#1

It looks like the 8.04 -> 8.04.1 upgrade broke things for you. Try doing this - go to system - administration - synaptic package manager, and searchh for "gnome-power-manager". Right-click on it, and click on "mark for installation". Then click apply, and after it's done, log out and log back in. Did that help?

In regards to the graphs, try going to System - Administration - Hardware Drivers, and enabling the video driver.

Let me know if you'll have any issues still.

Revision history for this message
Colin Watson (cjwatson) said :
#2

It sounds to me as if the gconf database has been corrupted rather messily. To try to narrow this down, is it possible that you are low on disk space? (Show us the output of the 'df' command.)

Revision history for this message
dyk6j (dyk6j) said :
#3

Thanks for your response. Unfortunately, I had too much time on Friday and Saturday and tried as much as I could to solve the problem with little knowledge. I managed to mess up the Op system so bad it will not boot. I tried to repair the MBR /GRUB with some sofware and later the live cd. Nothing will work and in the end I reinstalled the Ubuntu 8.04. The hope the problem never recurs but if it does I will certainly try your suggestions. Thanks again

> To: <email address hidden>> From: <email address hidden>> Subject: Re: [Question #38900]: After a routine update I got this install problem "the configuration defaults for the gnome power manager has not been installed correctly" How do I solve that problem? > Date: Sat, 12 Jul 2008 14:02:42 +0000> > Your question #38900 on Ubuntu changed:> https://answers.launchpad.net/ubuntu/+question/38900> > Status: Open => Answered> > Vadim Peretokin proposed the following answer:> It looks like the 8.04 -> 8.04.1 upgrade broke things for you. Try doing> this - go to system - administration - synaptic package manager, and> searchh for "gnome-power-manager". Right-click on it, and click on "mark> for installation". Then click apply, and after it's done, log out and> log back in. Did that help?> > In regards to the graphs, try going to System - Administration -> Hardware Drivers, and enabling the video driver.> > Let me know if you'll have any issues still.> > -- > If this answers your question, please go to the following page to let us> know that it is solved:> https://answers.launchpad.net/ubuntu/+question/38900/+confirm?answer_id=0> > If you still need help, you can reply to this email or go to the> following page to enter your feedback:> https://answers.launchpad.net/ubuntu/+question/38900> > You received this question notification because you are a direct> subscriber of the question.
_________________________________________________________________
Connect to the next generation of MSN Messenger
http://imagine-msn.com/messenger/launch80/default.aspx?locale=en-us&source=wlmailtagline

Revision history for this message
Vadim Peretokin (vperetokin) said :
#4

Ah alright.

Revision history for this message
Rob (hgvlvcbzlfyu) said :
#5

I can confirm having the same set of problems after running yesterday's system update.

Since this message is now the third link on Google for the error message, I thought I'd post what I did:

- Go to Synaptic Package Manager, and reinstall gnome-power-manager
- Go to Hardware Drivers, and re-enable my video card
- Go to Preferences > Appearance, and futz around re-enable all the windows chrome, like close and minimize buttons

However, my Gnome is still semi-hosed - I can't seem to get rid of the blue-and-gray color scheme, or the "embossed" visual style on all widgets.

Any ideas how to fix that?

Revision history for this message
Vadim Peretokin (vperetokin) said :
#6

Tried adjusting the theme? System - Preferences - Appearance - Theme

Revision history for this message
Rob (hgvlvcbzlfyu) said :
#7

Unfortunately, adjusting the theme did nothing. Theme thumbnails show up, but if I click on them, they don't do much: the color scheme remains blue on gray, the "embossed" look don't change, etc. (On the other hand, it did change the shapes of window borders and title bars - but not the colors. How strange.)

All the UI customizations from Ubuntu (rounded buttons, flat toolbars, etc) seem to be gone, and even though the themes are still available, I can't seem to apply them.

If you have any ideas, they'd be much appreciated!

Revision history for this message
Vadim Peretokin (vperetokin) said :
#8

Can you please take a screenshot? Press the PrtSc button on your keyboard,
and attach it to your reply.

Revision history for this message
Robb Kidd (ubuntu-thekidds) said :
#9

I can confirm the issues mentioned here. Reinstalling gnome-power-manager resolved the problem initially described, but I, too, am left with a GNOME appearance that is wonky. If compiz is turned-off, I get no window management widgets (minimize, restore/maximize, close). Compiz must be on to get any buttons on the window decoration. Selecting a theme in gnome-appearance-properties gets the theme to take *within* gnome-appearance-properties, but the rest of GNOME remains unchanged. This same unchangeable appearance is inflicted upon all users, existing or freshly-minted.

I have a screenshot, but do not see an option to attach it to this reply.

Revision history for this message
Vadim Peretokin (vperetokin) said :
#10

You can attach a screenshot with the "attach file" option, or upload
to imageshack.us and give us a link

Revision history for this message
Robb Kidd (ubuntu-thekidds) said :
#11

I don't see an "attach file" option, so we're left with imageshack.us.

http://img514.imageshack.us/my.php?image=screenshotnf9.png

Revision history for this message
Lin Borkey (lin-bytejam) said :
#12

I'm seeing the same thing as Robb. Did a restart because audio had crapped out. When it came back up, I was getting the Gnome Power Manager message and Gnome was scrambled. Tried to delete all gnome and gconf settings, created new users, nothing helped. I can't apply any themes. Finally Compiz turned back on and I started getting the minimize, maximize and close buttons on each window again, but the interface is still fried.

Revision history for this message
Robb Kidd (ubuntu-thekidds) said :
#13

Reinstalling gnome-settings-daemon will fix the theme issue, just like reinstalling gnome-power-manager fixed its configuration defaults. I have to wonder if there was some common cause in an update that messed these two up and if there may be other things acting odd that are not so apparent.

Revision history for this message
Lin Borkey (lin-bytejam) said :
#14

Thanks, Robb, that helped. I can now change the theme. The window borders are still messed up. Miniimize, Maximize and Close don't appear unless I enable the "Normal" level under Appearance->Visual Effects. Off and Extra causes the buttons to disappear.

On another note, keys repeating when held down no longer works. Now that's irritating.

Revision history for this message
Robb Kidd (ubuntu-thekidds) said :
#15

I noticed that with Metacity (the Window Manager used when "None" is selected in Appearance -> Visual Effects), the window title and icon were shifted to the right. With that informing a Google search, I came across a forum thread regarding Metacity Missing Window Decorations[1]. I got Metacity decorations back with:
sudo rm /var/cache/apt/archives/metacity*
sudo apt-get install --reinstall metacity metacity-common

In running that, though, I discovered some filesystem problems that a boot to recovery mode and an fsck resolved for the moment. Looking in the APT log (/var/log/apt/term.log), I see that the last metacity update was messed up, probably by a corrupted download of the package. I recommend doing a filesystem check, too.

[1] http://ubuntuforums.org/showthread.php?t=639808

Revision history for this message
Andre (andretimokhin) said :
#16

I am experiencing the same problem. The GNOME power management and the fubared display exactly like Robb Kidd's screen shot. Anyone found a fix for this yet?

Revision history for this message
Andre (andretimokhin) said :
#17

Also my Ctrl+Alt+L stopped working as well as the lock screen applet. What gives?

Revision history for this message
Lin Borkey (lin-bytejam) said :
#18

Robb's ideas and notes helped but ultimately I was never able to get my machine back the way it was. Themes wouldn't apply, typomatic didn't work (repeat key) and a host of other, little things kept cropping up.

I did a complete re-install from scratch. My original conversion to Hardy was via upgrade so this new fresh install seems to be working even better than the original upgrade. Still, it was somewhat concerning that I had to resort to a rather drastic measure to get back the way I was.

Revision history for this message
Robb Kidd (ubuntu-thekidds) said :
#19

The system that had this issue was also brought up to hardy from dapper (upgraded vice fresh install).

Further observation of this system showed that packages continued to not be installed correctly, even with a clean filesystem. Symptoms were along the same lines as I saw earlier with filesystem problems: the log (/var/log/apt/term.log) would have an occasional GConf error and a blat of XML. Some searching on the GConf error returned suggestions to check RAM as well. memtest86 did indeed turn up some wonky bits. I've been running the system with a boot-time mem= to restrict memory usage to below the first wonky bit while waiting for new memory to arrive. I have not seen the GConf failure XML blat since then.

So, the latest advice I can give is to reboot, select memtest86 in the GRUB menu and give your RAM a workout.

In light of this discovery, I chose to slick the hard drive and reinstall from 8.04.1 media rather than try to suss out what bits of the GConf registry needed to be reconfigured.

Revision history for this message
Robb Kidd (ubuntu-thekidds) said :
#20

From dapper? I'm an idiot. From gutsy, from feisty.

Revision history for this message
Ralf Nieuwenhuijsen (ralf-nieuwenhuijsen) said :
#21

Funny, i'm getting the gnome-power-manager problem on intrepid installed in virtualbox.

I would like to know what is causing this?
And how messed up I can expect the system to be, at this point?

Considering I just rsynced the whole image into /tmp folder to respin ubuntu, there is good chance we temporarily ran out of harddrive space.

Would that be a good guess as a possible cause? Ifso, a completely reinstallation would make the most sense, right? Since, it's hard to tell what part of the gconf is fubar-ed at this point.

Revision history for this message
macadamianut (fausterrico) said :
#22

Hi.
I confirm the same problem with the last ordinary update of hardy 8.04.

Revision history for this message
macadamianut (fausterrico) said :
#23

is there any way to go back to the configuration before the update?

Revision history for this message
Richard Wooding (m-launchpad-richardwooding-com) said :
#24

I have the same problem, I have just done an routine ubgrade on Ubuntu Intrepid Ibex 8.10.

Revision history for this message
Richard Wooding (m-launchpad-richardwooding-com) said :
#25

I have the same problem, I have just done an routine ubgrade on Ubuntu Intrepid Ibex 8.10.

Revision history for this message
macadamianut (fausterrico) said :
#26

thanks Robb Kidd.

In my case, it turned out to be a ram memory problem.
What is strange is that we all had the same type of symptoms, but apparently the reasons are different.
Did somebody else performed a complete memcheck?
Could an upgrade make any damages to the memory? Of course, I don't think so, bat the circumstance is quite weird.

Revision history for this message
vctoria (vmrs1) said :
#27

need more information... new message says E: dpkg was interruptd. you must manually run 'dpkg-configure-a" to correct the problem, i tried doing that and it did not work. help

Revision history for this message
Colin Watson (cjwatson) said :
#28

The message says 'dpkg --configure -a', not 'dpkg-configure-a'. It's important to type it correctly, with the dashes and spaces in the right places.

You'll probably have to run it like this: 'sudo dpkg --configure -a'. If that doesn't work, we'll need to see the output of that command in order to help.

Revision history for this message
toddq (toddq) said :
#29

The answer to this question can be found at https://bugs.launchpad.net/gdm/+bug/35217/comments/32

Revision history for this message
dpacmittal (dpac-mittal2) said :
#30
Revision history for this message
toddq (toddq) said :
#31

Didn't help me.

Revision history for this message
sadiqshoukat (sadiq-shoukat) said :
#32

i am having the same problem in ubuntu 10.4 Lts but i am unable to login so how can i solve the problem?

Revision history for this message
Matt Lee (wmattlee) said :
#33

Ok My Dell Mini 9 has been doing much of the same for quite some time. I cannot pick up wireless and my Gnome Power Manager has installed wrong... I have tried typing in the

mv .gconfd/saved_state saved_state.old

code in the terminal window after CTRL+ALT+F1 and logining into the affected account.. --nothing

I rebooted afterward and the same error message comes up at login.

When I attempt to go into the Synaptic Package Manager I have an error message that comes up as the program opens that states

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report

Someone please help here. Like previously stated I think this all started after an update I ran a while back. Thank you!

Revision history for this message
Matt Lee (wmattlee) said :
#34

also when I do try to run the dpkg package it states that I do no have superuser privilege. Is there a default administrator login on ubuntu?

Revision history for this message
Matt Lee (wmattlee) said :
#35

ok i put 'sudo' before the 'dpkg --configure -a' and it started

"
Setting up sudo

Setting up gdb

Setting up libxm12

......

"

but its stuck here..

Revision history for this message
David Hockley (raven-heart83) said :
#36

Hi all, I'm having a similar problem with Ubuntu 10.04, though I think it's because I'm very low on disk space... It wont let me log in at all. When I enter my password, it goes straight back to the login screen... I'm only able to post this because I'm running off the CD!
Can someone tell me how to log in to delete some folders as a root user (considering I can't login ordinarily!) Any help would be fantastic as I have alot of things on my machine that I need for work!

Thanks in advance.

Revision history for this message
Matt Lee (wmattlee) said :
#37

Problem FIXED!!!!

I restarted and ran the 'sudo dpkg --configure -a' and it worked!! thank you !!

Revision history for this message
Florian Schröck (mael-reverted) said :
#38

i had this problem after enabling the "composite" feature of metacity (gconf-editor -> apps -> metacity -> general -> compositing_manager)
also the ALT key stopped working and the system monitor applet stopped working.

the solution was to disable the composite feature.

ubuntu 10.10

Revision history for this message
sudhir gaikwad (zissshh) said :
#39

no dpkg is working as iam supposed to be a superuser,,,now what is that,,,i have already loggedin terminal,,,
no avail or relief and have to change the system as it appears there is no solution

Revision history for this message
Colin Watson (cjwatson) said :
#40

Type 'sudo ' at the start of a command in the terminal to run it as the
superuser (think "Administrator" in Windows, if you're familiar with
that).

Revision history for this message
Jennesa Dyck (jennesac) said :
#41

Hello,

I'm having the same problem as David Hockley. I ran an update, then restarted as it requested, but now I can't get past a login screen (which I've never seen before). My Windows partition still works, but I can't use Ubuntu at all.

I've tried running the updates and error fixes from the recovery mode, but still no luck.
I'm in way over my head ...
How do I get back into Linux?

Revision history for this message
Jennesa Dyck (jennesac) said :
#42

Hello,

I'm having the same problem as David Hockley. I ran an update, then restarted as it requested, but now I can't get past a login screen (which I've never seen before). My Windows partition still works, but I can't use Ubuntu at all.

I've tried running the updates and error fixes from the recovery mode, but still no luck.
I'm in way over my head ...
How do I get back into Linux?

Revision history for this message
Vadim Peretokin (vperetokin) said :
#43

If you think that this package in question broke things, try uninstalling it
- the command template is:

sudo apt-get remove <package name>

Sorry I can't provide the exact name, on my phone atm. Try going with
gnome-power-manager. Then see if login would work - and its best to install
this back if it does work.

Oh, and you'll be able to type in.command after choosing the recovery
console option or somesuch. It'll be in text mode and you'll need to login
first. To restart when done, I think the command is sudo restart 0.

On 2010-12-20 7:38 PM, "Jennesa Dyck" <email address hidden>
wrote:

Question #38900 on gnome-power-manager in ubuntu changed:
https://answers.launchpad.net/ubuntu/+sour...
Jennesa Dyck proposed the following answer:

Hello,

I'm having the same problem as David Hockley. I ran an update, then
restarted as it request...

Revision history for this message
Jennesa Dyck (jennesac) said :
#44

Thank you Vadim, that worked brilliantly for removing gnome! The error message is gone, and it has been uninstalled.

I still can't log in though. Any further suggestions?

Revision history for this message
Vadim Peretokin (vperetokin) said :
#45

How come you can't log in?

Revision history for this message
Jennesa Dyck (jennesac) said :
#46

I wish I knew! I'm certain that I have the right username and password (because when I try something else it says authentication failed), but when I hit okay, it thinks for a minute then just takes me back to the login screen. I have no idea what's wrong with it.

Revision history for this message
Vadim Peretokin (vperetokin) said :
#47

I see. How about... somewhere at the bottom of the login screen, it'll say
'GNOME' in a menu or somesuch. Can you select 'failsafe GNOME' instead, and
try again? Does that work?

Revision history for this message
Jennesa Dyck (jennesac) said :
#48

That didn't work either.

But I did manage to figure it out!

It was because I was out of space on root - so I made a boot disk for Ubuntu, then went in and deleted files, uninstalled and reinstalled gnome, restarted - and voila!

Thank you so much for your help though!

If anyone wants more details about what I did, just let me know - I'll be happy to help.

Revision history for this message
mclaren (mclaren-gmx) said :
#49

@Jennesa Dyck

hi, please tell me more.
i have the same problem here.
what exactly did you uninstalled and reinstalled?

Revision history for this message
Jennesa Dyck (jennesac) said :
#50

Here's what I did:

1) Make a boot cd for Ubuntu from another computer or different patition if you have one - http://www.ubuntu.com/desktop/get-ubuntu/download
   This is the website I used, it was very straightforward and helpful. With this, you can run Ubuntu again, and then clear some space on your root drive by deleting old files. For me, it was a hidden trash file that hadn't been cleared in ages.

2) Once I cleared up some disk space, I uninstalled and reinstalled gnome power manager from the root terminal command screen (I have no idea what this is actually called ...).

On my computer, this is how I got to it -
during start up, choose to run Ubuntu in recovery mode. I get a screen with a number of options - use the arrow keys to scroll down to run as root and hit enter. You can then type in commands.

To uninstall gnome type: sudo apt-get uninstall gnome-power-manager - then hit enter and let it do it's thing.
To reinstall type: sudo apt-get install gnome-power-manager - again hit enter and wait.

when it's done, restart your computer and run as normal.

Hopefully that helps!
Let me know how it goes.

Revision history for this message
mclaren (mclaren-gmx) said :
#51

ok thank you , I tried this tow days ago.
doesn't worked for me.

I searched now again and found my help by doing " mv ~/.gconfd/saved_state ~/.gconfd/saved_state.old"

great, after two days my system still works :)

Can you help with this problem?

Provide an answer of your own, or ask dyk6j for more information if necessary.

To post a message you must log in.