Setting screen brightness

Asked by JCarlin on 2012-09-10

Since updating to Ubuntu 12.04, each time the computer (Samsung N210) is switched off the screen brightness defaults to the rather dim setting. How can I make a brighter setting the default?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-power-manager Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-10
Last reply:
2012-09-10
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

is this your problem ? https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/923940

If yes , then is a bug and you must wait for a fix.

or

we can try a workaround with some commands , until bug fixed.

just let me know .

Thanks

JCarlin (jcarlin) said : #2

Thank you, Nik, yes I believe that is the problem. I can reset it every
time I log on - in an ideal world I shouldn't need to! I will await a
fix.

On Mon, 2012-09-10 at 14:15 +0000, NikTh wrote:

> Your question #208155 on Ubuntu changed:
> https:��answers.launchpad.net�ubuntu�+question�208155
>
> Status: Open => Answered
>
> NikTh proposed the following answer:
> Hi ,
>
> is this your problem ? https:��bugs.launchpad.net�ubuntu�+source�gnome-
> power-manager�+bug�923940
>
> If yes , then is a bug and you must wait for a fix.
>
> or
>
> we can try a workaround with some commands , until bug fixed.
>
> just let me know .
>
> Thanks
>

Try:
gksudo gedit /etc/default/grub; sudo update-grub

Find:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Save the new file and close gedit. Reboot to test

Also run:

gksudo gedit /etc/rc.local

Add this line ABOVE the 'exit 0' line:

setpci -s 00:02.0 F4.B=00

Save the new file, close gedit then run:

sudo /etc/rc.local

HTH

N1ck 7h0m4d4k15 (nicktux) said : #5

On 09/10/2012 05:56 PM, actionparsnip wrote:
> Question #208155 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/208155
>
> actionparsnip proposed the following answer:
> Also run:
>
> gksudo gedit /etc/rc.local
>
> Add this line ABOVE the 'exit 0' line:
>
> setpci -s 00:02.0 F4.B=00
>
> Save the new file, close gedit then run:
>
> sudo /etc/rc.local
>
> HTH
>
Hi ,
@actionparsnip moved straight away to the workaround . :)

Follow the workaround that @actionparsnip provided . Hopefully will work.

Thanks

JCarlin (jcarlin) said : #6

Thank you, but where do I start??? What do you mean, try gksudo? Try it
where? And I don't know where to look for GRUB. I just want a box on
the brightness settings page which says "keep this setting as
default"...
Oh dear, perhaps I should have stayed with microsoft...

On Mon, 2012-09-10 at 14:56 +0000, actionparsnip wrote:

> Your question #208155 on Ubuntu changed:
> https:��answers.launchpad.net�ubuntu�+question�208155
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Try:
> gksudo gedit �etc�default�grub; sudo update-grub
>
> Find:
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
>
> Change it to:
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
>
> Save the new file and close gedit. Reboot to test
>

Press CTRL+ALT+T and you can run the commands

Can you help with this problem?

Provide an answer of your own, or ask JCarlin for more information if necessary.

To post a message you must log in.